You are here

[Launch] RunAsAdmin=force not working

9 posts / 0 new
Last post
jedione
Offline
Last seen: 10 years 5 months ago
Joined: 2013-08-21 23:32
[Launch] RunAsAdmin=force not working

trying to add HKLM.reg file
my app need it to run
--------------------------------------------------
[Launch]

RunAsAdmin=force
ProgramExecutable=portable\apppnameportable.exe

[Activate]
Registry=true

[RegistryKeys]
two=HKLM\SOFTWARE\Wow6432Node\
three=HKCU\S-1-5-21-2764583246-2298883548-3252906630-1001\Software\
one=HKCU\Software\
----------------------------------------------------------------
also tryed \compile-force

any reason why this wont work....HKCU are fine \\ HKLM is nogo!

jedione
Offline
Last seen: 10 years 5 months ago
Joined: 2013-08-21 23:32
Funny cause this is easy

Funny cause this is easy stuff to do in a batch file
REGEDIT /S "" "C:\Example.reg"
but I Love Portable apps and not leaving behind junk
please help anybody!

John T. Haller
John T. Haller's picture
Offline
Last seen: 8 hours 6 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Recompile

You need to recompile the launcher after you change it.

Please stop creating new topics for every single new related question. You could easily just keep this all in a single topic.

Sometimes, the impossible can become possible, if you're awesome!

Chris Morgan
Chris Morgan's picture
Offline
Last seen: 8 years 11 months ago
Joined: 2007-04-15 21:08
Stop!

Those [RegistryKeys] values will not do what you want by a long shot; I think (hope!) the "one" one will fail, the "three" one will fail (it doesn't exist), and the "two" one, if you run as admin, will attempt to remove that part of the registry.

Please go back and read the documentation and look at examples. You can't have [RegistryKeys] that are that coarse.

I am a Christian and a developer and moderator here.

“A soft answer turns away wrath, but a harsh word stirs up anger.” – Proverbs 15:1

jedione
Offline
Last seen: 10 years 5 months ago
Joined: 2013-08-21 23:32
thanks Chris, for your

thanks Chris, for your Reply
i am new to this..and it's just is so simple to add a HKCU file
and when i add a HKLM with RunAsAdimin=force it does not work
and yes Every attempt I re-compile the "Launcher"
some in'site is that I think I had it working in VM Ware.
but was Weird...{Worked but when I Deleted HKLM.Key from the Registry
would not work again till I imported a fresh copy of the {PAF}
almost like the old copy was saving something to the .ini files
again now nothing works "HKLM" that is....Q: I asume that using
"RunasAdmin"=force is old by now.... What could Be My Problem!
and also what is wrong with naming then uno,dose.trese,.reg
it follows the format to inject the .reg file...does it not
I would just like to say thanks for your input... I think that
I and other Laman's will find it insitefull. Sorry i am not a coder

and will stop ,starting a new thrred for a new conversation..

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 5 months 3 weeks ago
DeveloperModerator
Joined: 2008-07-24 18:46
post copies

jedione, please post copies of your launcher file as well as the reg files you're wanting to use to somewhere such as pastebin.com, and post the links here. That way we can help you better, since we can see what the problem is.

jedione
Offline
Last seen: 10 years 5 months ago
Joined: 2013-08-21 23:32
yes here is a link. and mind

yes here is a link. and mind that this is for personal use.
the point of this is to get to the bottom of why this wont work
feel free to email me also thanks jedione. jedigojedi@gmail.com
https://skydrive.live.com/redir?resid=88BBDF5F271968EA!403&authkey=!AJEr...

jedione
Offline
Last seen: 10 years 5 months ago
Joined: 2013-08-21 23:32
and also i know that their is

and also i know that their is no registry cleanup in the .ini yet
firt i'v got to get it to inject! thats my goal. thanks

jedione
Offline
Last seen: 10 years 5 months ago
Joined: 2013-08-21 23:32
[SOLVED] I am an Idiot, here

[SOLVED] I am an Idiot, here is what was wrong.
my path in the .reg key was wrong. I found this by digging
deeper into [HKLM] and found my key so i figured "Hay it is working
just going to the wrong location. aha..quick edit to the .reg file
and all is good. NOW I Am Addicted. now I see that their is know room
for error when making a PAF file. I will now go study the "Launcher guide" thanks to those that tried to help me!
mayby this might help some one.......

Log in or register to post comments