You are here

Eclipse Portable 4.4

8 posts / 0 new
Last post
gluxon
gluxon's picture
Offline
Last seen: 1 year 3 weeks ago
Developer
Joined: 2008-06-21 19:26
Eclipse Portable 4.4

Application: EclipseCategory: DevelopmentDescription: Eclipse is an open source community, whose projects are focused on building an open development platform comprised of extensible frameworks, tools and runtimes for building, deploying and managing software across the lifecycle.

Download Eclipse Portable, Classic Edition [208MB download / 215MB installed]
(MD5: 45c5e8cb41da0119c4c1655bd0247b95)

Release Notes:

Eclipse 4.4 Luna release. (2014-07-10)

gluxon
gluxon's picture
Offline
Last seen: 1 year 3 weeks ago
Developer
Joined: 2008-06-21 19:26
Java, PHP, C/C++ packages

Java EE, PHP, and C/C++ packages have been retired. Users can install these can install these packages themselves through Eclipse's plugin system.

tal
Offline
Last seen: 1 month 2 weeks ago
Developer
Joined: 2009-08-07 07:34
Thank you!

Can you publish only the Launcher? That we can make this (Java EE, PHP, and C/C++ ) eclipse by our own.
It very not convenient to downloads the plugins by yourself (need to understand, take time, and you can maybe make an error).
The simply way it to download it ready from eclipse, and past it at the launcher in the right folder.

Thank you for your hard work.
Tal

3D1T0R
3D1T0R's picture
Offline
Last seen: 2 months 1 week ago
Developer
Joined: 2006-12-29 23:48
Try the built in installer? (& @Gluxon: Splash Screen?)

Open the "Help" menu and choose "Install New Software", choose a site (or "--All Available Sites--") then look through the list (filter it if you know what you're lookin for) and check the items you want from it.
(Note: I haven't tested the Portability of this functionality, perhaps Gluxon can comment on it)

Also
@Gluxon: What? No Development Test Splash Screen?
And have you considered changing the built-in splash-screen to an Eclipse Portable one (for eventual release, not for Dev Tests)?

~3D1T0R

expert_vision
Offline
Last seen: 6 years 8 months ago
Joined: 2015-01-06 05:07
Launch using 64 bit Java

Currently the launcher is using 32 bit version of Eclipse, and if I install Java 64 bit I get exit code 13 when I launch Portable Eclipse.

Is there a way to configure the launcher to start the 64 bit Eclipse instead? If I download Eclipse from eclipse.org it will run 64 bit by default.

UPDATE:
Well, I figured it out. The portable version has the 32 bit version of Eclipse in it. To run the 64 bit version of Eclipse just download it from eclipse.org and put it in EclipsePortable\App\Eclipse.

eyenot
Offline
Last seen: 6 years 8 months ago
Joined: 2008-08-26 15:34
Javadoc portability ? (Aside: 64bit ?)

I am happily authoring and compiling using Eclipse Portable and Java Portable from a flash drive. But for projects I'm working on now, I am required to generate a javadoc of the code. I have tried in vain to simply point Eclipse to the javadoc.exe and receive this response:

"Error occurred during initialization of VM
java/lang/NoClassDefFoundError: java/lang/Object"

Is there some magic I need to do to clear this up? Would you happen to know what it is?

Also, an earlier comment mentioned success in making Portable Eclipse into the 64-bit version simply by over-writing in a certain directory. I have tried over-writing just the two files eclipse.exe and eclipsec.exe into the mentioned directory app\eclipse but I received a message: "The Eclipse executable launcher was unable to locate its companion shared library".

Would you happen to know what I could do more thoroughly in order to please 64-bit Eclipse that all of its friends are present so that it can play?

mcondarelli
Offline
Last seen: 6 years 4 months ago
Joined: 2015-04-28 04:34
Maven whoes

It seems Eclipse-Portable does not work fine with Maven.
On a brand new install I successfully installed several plugins, including m2e.
Unfortunately m2e seems unable to fetch artifacts (I checked: repositories are accessible from my machine, despite firewalls and such).
Trying to create a new Maven project results in error:

Could not resolve archetype org.apache.maven.archetypes:maven-archetype-quickstart:RELEASE from any of the configured repositories.
Could not resolve artifact org.apache.maven.archetypes:maven-archetype-quickstart:pom:RELEASE
Failed to resolve version for org.apache.maven.archetypes:maven-archetype-quickstart:pom:RELEASE: Could not find metadata org.apache.maven.archetypes:maven-archetype-quickstart/maven-metadata.xml in local (C:\Users\uidr5738\.m2\repository)
Failed to resolve version for org.apache.maven.archetypes:maven-archetype-quickstart:pom:RELEASE: Could not find metadata org.apache.maven.archetypes:maven-archetype-quickstart/maven-metadata.xml in local (C:\Users\uidr5738\.m2\repository)

and relevant maven error is:

#NOTE: This is an Aether internal implementation file, its format can be changed without prior notice.
#Tue Apr 28 12:01:54 CEST 2015
maven-metadata-central.xml.error=Could not transfer metadata org.apache.maven.archetypes\:maven-archetype-quickstart/maven-metadata.xml from/to central (http\://repo.maven.apache.org/maven2)\: connect timed out
maven-metadata-central.xml/@default-http\://repo.maven.apache.org/maven2/.lastUpdated=1430215314723

... sure enough I can access "https://repo1.maven.org/maven2/org/apache/maven/archetypes/maven-archety..." with content:

<metadata>
  <groupId>org.apache.maven.archetypes</groupId>
  <artifactId>maven-archetype-quickstart</artifactId>
  <versioning>
    <latest>1.1</latest>
    <release>1.1</release>
    <versions>
      <version>1.0-alpha-1</version>
      <version>1.0-alpha-2</version>
      <version>1.0-alpha-3</version>
      <version>1.0-alpha-4</version>
      <version>1.0</version>
      <version>1.1</version>
    </versions>
    <lastUpdated>20100501173945</lastUpdated>
  </versioning>
</metadata>

(notice discrepancy in "lastUpdate", if at all significant)
Any idea about what I'm doing wrong?

mwayne
Offline
Last seen: 9 hours 26 min ago
Developer
Joined: 2012-01-03 09:23
Eclipse Mars

Eclipse 4.5 released. Are you going to update?

Edit: I took over this project. A new Dev Test is available here.

Log in or register to post comments