You are here

[Fixed] Error on Platform load: "Invalid image size"

31 posts / 0 new
Last post
Ulf2014
Offline
Last seen: 1 week 6 days ago
Joined: 2014-05-05 05:16
[Fixed] Error on Platform load: "Invalid image size"

Always when you start PortableApps 12.0.1.0 I get the following message: "Invalid image sitze". This message comes after the update from 11.2.0.0 to 12.0.1.0 and after a Reinistallation.

I use PortableApps in Windows XP and 8.1.Portable Apps 12.0.1.0 seems to be broken, Portable Apps 11.2.0.0 is top.

This text was translated with Google.

John T. Haller
John T. Haller's picture
Online
Last seen: 41 min 24 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Some Questions

I will try to keep these short so they translate well:

1. Are you using one of the built-in themes? Did you add your own custom theme?

2. Do you have an OEM theme? This would be one that came with a drive you purchased such as the PortableApps.com Carbide, PortableApps.com Companion, KeyZ, or Gigs2Go.

3. Try to install fresh to another location temporarily. You can install right to your DESKTOP or to your MY DOCUMENTS directory. Does the problem occur then?

4. Can you please post your PortableAppsMenu.ini file? You can find it within the PortableApps\PortableApps.com\Data directory. You can exclude the Favorites and TimesRun sections for privacy if you wish.

Sometimes, the impossible can become possible, if you're awesome!

Ulf2014
Offline
Last seen: 1 week 6 days ago
Joined: 2014-05-05 05:16
Answers to the questions

1. I use an integrated design, no custom theme.

2. I do not use OEM theme.

3 Portable Apps have installed on meheren USB drives and Desktop. It always get these messages.

4.[DisplayOptions]
Language=German
LargeFonts=False
HideDesktopIcons=False
UseCategories=True
ShowAllApps=False
KeyboardFriendly=False
CollapseOtherFoldersOnExpand=False
ExpandCategoriesByDefault=False
CollapseCategoriesOnMinimize=False
DisableScrollBar=False
HidePortableInAppNames=False
BoldFolderNames=False
DisableSplashScreens=False
BoldFavorites=False
GlobalHotKey=CTRL-ALT-SPACE
Theme=Glassy
ThemeColor=Green
ThemeCustomColor=
StartPositionHorizontal=Right
StartPositionVertical=Bottom
AlphaBlendMain=255
[Localization]
DisableAppLanguageSwitching=False
[Updater]
UpdateAutomatically=True
BetaPlatformReleases=False
ShowStartupModeErrors=False
[Automation]
CloseAppsOnPlatformExit=True
AskCloseAppsOnPlatformExit=True
[AppDirectory]
ShowOpenSourceOnly=False
ShowAdvancedApps=False
ShowInstalledApps=False
[Protection]
AutoRun=True
AutoRunRealtime=False
[Search]
SearchWithinAppDescriptions=False
HideSearchWhenNotInUse=False
[Connection]
ConnectionType=Automatic
ProxyIP=127.0.0.1
ProxyPort=8080

5. I have installed portable software Portable Apps.

6. Message comes only when apps are installed and installert. The platform without apps start without notification.

This text was translated with Google.

John T. Haller
John T. Haller's picture
Online
Last seen: 41 min 24 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Can't Reproduce Yet

I loaded your PortableAppsMenu.ini into my platform installation. I tried starting and exiting the platform, installing a new app manually from a .paf.exe, installing a new app through the app store, uninstalling an app, closing and opening the platform, exiting the platform and then restarting. I'm still unable to reproduce the error.

Do you have a personal picture set in the upper right? This would appear as a personal picture BMP/JPG/PNG within your PortableApps\PortableApps.com\Data directory. Could you please take a screenshot of the error? You can host it on imgur.com and link to it from here.

Sometimes, the impossible can become possible, if you're awesome!

Ulf2014
Offline
Last seen: 1 week 6 days ago
Joined: 2014-05-05 05:16
Reproduce

I do not use personal image in Portable Apps. I use PortableApps as I installed it without third-party software and settings.

Screenshot - Error:
http://imgur.com/Vh70oLn

This text was translated with Google.

John T. Haller
John T. Haller's picture
Online
Last seen: 41 min 24 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Start or Refresh

Does it only happen on start? Or does it happen every time you refresh (F5) the app list?

Does it happen if you switch themes?

Sometimes, the impossible can become possible, if you're awesome!

Ulf2014
Offline
Last seen: 1 week 6 days ago
Joined: 2014-05-05 05:16
Start, Refresh and Install

The message comes whenever PortableApps starts when I press F5 when I change the theme and integrated if an app is installed. In all previous versions I never had problems only with the current version.

This text was translated with Google.

John T. Haller
John T. Haller's picture
Online
Last seen: 41 min 24 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
One Of Your Apps

Ok. If this is happening and the new EXE made no difference, it may be one of your apps the menu doesn't like. Are you using any apps not in the PortableApps.com App Store? These would be either development tests from our forums or non-PAF apps from other sites. I think one of them is what the menu is having an issue with, so we need to determine which one.

You could install another copy of the PortableApps.com Platform on your desktop or My Documents. Then copy in each app that's not from our app store one by one and refresh the new menu. Eventually, the error should start again and we'll know what the app is. If we can determine that, I can take a look at the app and try to figure out a way to prevent the error.

Sometimes, the impossible can become possible, if you're awesome!

Ulf2014
Offline
Last seen: 1 week 6 days ago
Joined: 2014-05-05 05:16
App Store

All installed apps from PortableApps.com from the App Store.

AIMPPortable
LibreCADPortable
LibreOfficePortable
PDF-XChangeViewerPortable
XnViewPortable
FirefoxPortable
...

John T. Haller
John T. Haller's picture
Online
Last seen: 41 min 24 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Possible Fix

Could you please try this modified version of the PortableApps.com Platform main EXE to see if it fixes your issue? You can download it here. Copy it into your PortableApps\PortableApps.com directory after making a backup copy of your current version.

Sometimes, the impossible can become possible, if you're awesome!

Ulf2014
Offline
Last seen: 1 week 6 days ago
Joined: 2014-05-05 05:16
The new EXE

The new EXE was no change. The message will continue if PortableApps is started.

I have Portable Apps several times downloaded and reinstalled. There always comes the message.

This text was translated with Google.

John T. Haller
John T. Haller's picture
Online
Last seen: 41 min 24 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
External drive?

Is this all from the same external drive? Could you please copy the whole thing locally and we if it happens? If it still does, please install a fresh copy over the new local copy. If it still occurs, please delete the contents of your PortableApps.com/data directory and try again.

Sometimes, the impossible can become possible, if you're awesome!

Ulf2014
Offline
Last seen: 1 week 6 days ago
Joined: 2014-05-05 05:16
external and internal hard drive

Everything is on the external hard drive and internal on my desktop PC desktop. Everything I have repeatedly reinstalled.

I delete everything in the Data folder, Portable Apps does not start anymore. I copy the PortableAppsMenu.ini again in the Data directory PortableApps starts again with the message.

I install everything under 11.x, get no messages.

John T. Haller
John T. Haller's picture
Online
Last seen: 41 min 24 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Fresh Install

You had said a fresh install did not have the message. Or is that incorrect?

If a fresh install does not have the message, we need to determine what in your specific install has this issue.

If you delete the contents of the Data directory or the Data directory itself, the PortableApps.com Platform will rebuild it on next launch. If it cannot rebuild it, then something is wrong with the permissions on your drive.

Sometimes, the impossible can become possible, if you're awesome!

Ulf2014
Offline
Last seen: 1 week 6 days ago
Joined: 2014-05-05 05:16
Fresh install

There is no message when I PortableApps freshly installed and no apps are installed.

Only when an app has been installed is the message. What are the differences between version 11 and 12? Only version 12 makes problems.

John T. Haller
John T. Haller's picture
Online
Last seen: 41 min 24 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Fresh Install Plus One App

Can you please try a fresh install and then install a single app from the directory to see if that works?

I'm attempting to narrow down where the issue is occurring. I think it is due to the code loading the new cascading system tray app menu.

The problem is that I can not reproduce it even when I have my platform setup exactly the same way as you. And no one else has reported the issue among the couple hundred thousand people that are already running 12.0. So, it is something specific to your setup that I need to determine.

Are you running Windows with large fonts on? Have you set a custom DPI setting?

Sometimes, the impossible can become possible, if you're awesome!

Ulf2014
Offline
Last seen: 1 week 6 days ago
Joined: 2014-05-05 05:16
Clean installation and one App

Thus, a new clean installation and one app, LibreOfficePortable, installed. After installing the app the message.

I have no large fonts in Windows and no custom DPI settings.

John T. Haller
John T. Haller's picture
Online
Last seen: 41 min 24 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Screenshot

After the error occurs and you dismiss the error, could you bring up the right-click system tray of the platform and take a screenshot, please? If you'd rather not share it publicly, you can email it to the developers email address on the contact page: https://portableapps.com/about/contact

Sometimes, the impossible can become possible, if you're awesome!

Ulf2014
Offline
Last seen: 1 week 6 days ago
Joined: 2014-05-05 05:16
System Tray

Screenshot - System Tray:
http://imgur.com/fd0H5cc

That with the right click, I have not yet understood.

3D1T0R
Offline
Last seen: 2 months 2 weeks ago
Developer
Joined: 2006-12-29 23:48
I believe the intent was for you to capture the context menu.

I believe the intent was for you to capture the context menu (which appears when right-clicking the tray icon) as it appears after the error has occurred.

Something like this: [image removed as it's no longer needed ~3D1T0R]

Also, if you're worried about privacy, you can use an image manipulation program (such as GIMP) to blur, or otherwise remove sensitive items which appear on your screen at the time of the screen capture.

~3D1T0R

Ulf2014
Offline
Last seen: 1 week 6 days ago
Joined: 2014-05-05 05:16
Screenshot

Screenshot context menu:
http://imgur.com/TxHoJ4K

@3D1T0R:
Thank you Smiling

John T. Haller
John T. Haller's picture
Online
Last seen: 41 min 24 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Check

I added a check to the Platform 12.0.2 release in the only location in the code that it adds images to an imagelist (which is what generates this error). Please let me know if it makes any difference. If it does, you may find some images missing from your cascading tray menu for some apps.

As an aside, I've tried everything I can think of to reproduce the error including odd DPI sizes on Windows XP but can't get it to occur, so I'm still very curious as to the underlying cause.

Sometimes, the impossible can become possible, if you're awesome!

Ulf2014
Offline
Last seen: 1 week 6 days ago
Joined: 2014-05-05 05:16
Platform 12.0.3

I have Version 12.0.3 installed and the Message no longer occurs. Laughing out loud

What is Different, I can not say, that no more Message comes.

Hopefully this will continue as now, even in later Versions. Thanks for the Help and the Version 12.0.3.

This text was translated with Google.

John T. Haller
John T. Haller's picture
Online
Last seen: 41 min 24 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Cool, Any Defects?

I'm glad to hear. Can you tell me if your right-click system tray still shows the icons for the Apps and Favorites folders as well as the category icons and app icons inside? I have the check in that code to simply skip any icon that is the 'wrong' size.

Sometimes, the impossible can become possible, if you're awesome!

Ulf2014
Offline
Last seen: 1 week 6 days ago
Joined: 2014-05-05 05:16
Shows the Icons

Screenshot context menu (v12.0.3):
http://imgur.com/xWOBwTJ

Screenshot Platform (v12.0.3):
http://imgur.com/hEvHtnc

When it comes, I always small icons. However, a difference between 12.0.1 and 12.0.3 I can not see.

This text was translated with Google.

John T. Haller
John T. Haller's picture
Online
Last seen: 41 min 24 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Deeper

Thanks for those first two shots. What about inside the Apps menu like this:
http://i.imgur.com/OzDGeVP.png

Also, what about inside one of the folders?

I did notice something odd about your screenshots. The icons in the system tray seem to be squashed. Compare your PortableApps.com icon in your system tray to mine here: http://i.imgur.com/2nxJNwJ.png

I only usually see that with a custom DPI settings in Windows. Or some other custom change. That PortableApps.com system tray icon should be a full 16x16 circle when rendered properly.

Sometimes, the impossible can become possible, if you're awesome!

Ulf2014
Offline
Last seen: 1 week 6 days ago
Joined: 2014-05-05 05:16
Taskbar

Unfolded context menu:
http://imgur.com/IoWqgEy

I have set Windows when displaying the window's title bar and menu bar to size 15. This also my taskbar as was narrower.

On the size of the symbols themselves, I have not changed anything. My resolution is 1920x1080

Translated with Google

depp.jones
Offline
Last seen: 6 hours 32 min ago
DeveloperTranslator
Joined: 2010-06-05 17:19
That's what Windows XP does

That's what Windows XP does with the not uncommon 120 DPI setting. I think that should be fairy standard since otherwise a 17" FullHD notebook display is nearly unusable. I had that the last six years and XP handles the 120 DPI setting awkwardly. Scaling is one of the things, that the newer versions of windows handle much better.

3D1T0R
Offline
Last seen: 2 months 2 weeks ago
Developer
Joined: 2006-12-29 23:48
Antivirus?

I see in your screenshots that you have the Avira logo among your tray icons. It's been a long time since I tried Avira, but as I recall it interfered with some things that it thought might be done by viruses, sometimes without any notification to the user. I'd recommend that you try temporarily disabling it to see if the issue goes away.

@JTH: If Avira is the cause then you should know that it's free so maybe you can install it (perhaps on a VM) and see if you can figure out some workaround.

~3D1T0R

John T. Haller
John T. Haller's picture
Online
Last seen: 41 min 24 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Good Thought, But Not It

I just tried running Platform 12.0.1 with Avira and one app installed in a Windows XP VM and did not produce the error.

Sometimes, the impossible can become possible, if you're awesome!

3D1T0R
Offline
Last seen: 2 months 2 weeks ago
Developer
Joined: 2006-12-29 23:48
Too bad, it would be nice to know what's causing this.

I hate to say that I wish an antivirus program was misbehaving, but I do wish we could find the cause of this weird issue.

@Ulf2014: Is there anything else on your computer that you think could possibly be interfering with the Platform?
Even if it doesn't make a whole lot of sense, maybe you could try exiting some other programs that you have running to see if one of them is causing the issue, I'd really like to know what's causing this.

~3D1T0R

Log in or register to post comments