You are here

Page Loads Slow or Only Partially

7 posts / 0 new
Last post
mnunez
Offline
Last seen: 17 years 5 months ago
Joined: 2006-12-12 08:55
Page Loads Slow or Only Partially

This site will take forever to load or simply load only partially:

http://www.projo.com (The Providence Journal)

I used to have the same problem with CNN.com. It seems to me as if FireFox Portable has trouble loading content from different servers on one page, such as advertisements.

For example, if you go to projo.com you see the ads at the top of the page or on the left will load, but in the status bar at the bottom left of PortableFireFox, you will see either of two addresses Firefox is taking time to negotiate with: "spe.atdmt.com" or "ads.belointeractive.com".

The page will either stall there (with only the two ads displayed) or take 5 minutes to load completely. Like I said, I used to notice the same problem at CNN, but they have since made some adjustments to their page that don't cause the error any longer.

Projo.com loads perfectly and quickly in Internet Explorer or regular Firefox 2.0 on the hard disk.

Any idea on the potential issue?

John T. Haller
John T. Haller's picture
Online
Last seen: 3 min 5 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Cache perhaps?

FFP has an unaltered copy of Firefox inside it. It's just some settings that are changed by default (no cache, history, form saving, etc). Try enabling the cache.

Or it could be a missing plugin. If it can't find the Windows Media plugin, for instance, their detection algorithm may get messed up.

Sometimes, the impossible can become possible, if you're awesome!

mnunez
Offline
Last seen: 17 years 5 months ago
Joined: 2006-12-12 08:55
No. My cache is at 0MB.

No. My cache is at 0MB. And the site doesn't appear to use plugins. Have you tried to load the site? Did you notice a plug-in?

Can someone else try to access this site http://www.projo.com. and see if the page loads in Firefox Portable? If I hit Refresh multiple times sometimes it will load. But basically, I cannot browse my hometown newspaper with PF, I have to open IE, because I cannot run PF with a regular hard disk based Firefox at the same time.

clumsy_99
Offline
Last seen: 17 years 5 months ago
Joined: 2006-12-13 12:08
Confirmation?

I do confirm this.

I have problems getting the site:
http://www.ford.de
shown correct in Firefox Portable 2.0.

Maybe this problem is connected to Javascript. With JS turned on while loading the URL changes to:
http://www.ford.de/undefined/undefined/home/-/rt_home/-/-/-
and only some pictures are shown (page displays incomplete).

When JS is turned off the site loads complete but is totally messed up (invisible menu that pops up when mouse hovers, pictures at wrong position, ...).

I have Firefox 2.0 (non portable) installed (same addons) and the page displays correct. I also uninstalled all addons with no results.

Maybe someone could confirm this behavior of the Portable Firefox 2.0 to confirm a bug or give hinds if my Firefox is broken.

John T. Haller
John T. Haller's picture
Online
Last seen: 3 min 5 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Enable cache?

Did you try enabling cache?

Sometimes, the impossible can become possible, if you're awesome!

clumsy_99
Offline
Last seen: 17 years 5 months ago
Joined: 2006-12-13 12:08
Yes

I tried it with cache enabled and disabled - there is no change.
In my case speed isn't the problem (the site loads straight until it breaks).

mnunez
Offline
Last seen: 17 years 5 months ago
Joined: 2006-12-12 08:55
I just loaded that site you

I just loaded that site you listed and it loads fine for me in Firefox Portable with Javascript on and off. Have you tried loading http:://www.projo.com. Does it load for you?

Topic locked