You are here

[Closed] Sessions in FirefoxPortable Nightly do not restore properly.

12 posts / 0 new
Last post
aekotra
Offline
Last seen: 2 years 11 months ago
Joined: 2015-01-22 17:57
[Closed] Sessions in FirefoxPortable Nightly do not restore properly.

To Reproduce
+ Install 38 Alpha x86 from here https://portableapps.com/apps/internet/firefox_portable/test
+ open browser
+ set Options > General > When Firefox starts: Show my windows and tabs from last time
+ load at least one website
+ restart browser

Results
Tabs from the previous session are appear as empty "New Tabs".

I first noticed this behaviour in 37 Nightly. However, this problem no longer exists in 37 Developer Edition. That makes me think the problem may be Electrolysis related...

John T. Haller
John T. Haller's picture
Online
Last seen: 6 min 36 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Base app bug?

This sounds like a base app issue, which isn't what we track bug-wise. We only track bugs in our portablization of apps. If you can confirm that this isn't an issue with a local install of nightly but is with the portable version, let us know and we'll re-open and investigate.

Sometimes, the impossible can become possible, if you're awesome!

aekotra
Offline
Last seen: 2 years 11 months ago
Joined: 2015-01-22 17:57
Yes, sorry, I forgot to

Yes, sorry, I forgot to mention that. I've confirmed that sessions restore properly in nightly if locally installed.

I used new profiles to test both the local installer and the portable version.

John T. Haller
John T. Haller's picture
Online
Last seen: 6 min 36 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Same build and settings?

You said you thought it was electrolysis related. Were the settings different in local vs portable? Also, were you using the same build of each?

Sometimes, the impossible can become possible, if you're awesome!

aekotra
Offline
Last seen: 2 years 11 months ago
Joined: 2015-01-22 17:57
Are you referring to the

Are you referring to the profile settings? I simply let both Firefox's generate a new profile which I tested immediately. So, whatever the defaults are in either case.

It's likely not the same build (I'm assuming PortableApps is behind), but I can tell you that the local and portable Nightlies I tested are the ones available for download _today_.

Like I said, I experienced the same problem with PortableApps Nightly 27 (and not with Developer 27) so I'm thinking this is not a build-specific issue but a feature being tested on the Nightlies (eg. electrolysis) that conflicts with the PortableApps launcher somehow.

John T. Haller
John T. Haller's picture
Online
Last seen: 6 min 36 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Generated Settings

We use an old style default profile setup to generate the settings. I'm unsure if Nightly builds handle this correctly. We don't test Nightly other than to see if it starts up and only make it available as a courtesy to users and testers. I'm wondering if something like Electrolysis is enabled in one but not the other.

Sometimes, the impossible can become possible, if you're awesome!

aekotra
Offline
Last seen: 2 years 11 months ago
Joined: 2015-01-22 17:57
I've confirmed that if I copy

I've confirmed that if I copy my profile from the local install to Data/profile in the portable install, I experience the same bug.

John T. Haller
John T. Haller's picture
Online
Last seen: 6 min 36 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Does it happen in Developer?

Just to confirm, you say this no longer occurs in the portable packages of Developer 37 even though it occurred in Nightly 37, correct? It could be a specific bug in Nightly with Electrolysis and using a custom profile path, I'm just trying to narrow my test cases.

Sometimes, the impossible can become possible, if you're awesome!

aekotra
Offline
Last seen: 2 years 11 months ago
Joined: 2015-01-22 17:57
That is correct. Actually, I

That is correct.

Actually, I just realized that there's a setting to disable e10s in Options > General. When e10s is disabled, the bug is gone!

John T. Haller
John T. Haller's picture
Online
Last seen: 6 min 36 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Makes Sense

It's not ready for primetime, so it's enabled by default in Nightly and disabled by default in Developer. So, that's the different between the two. I'd wager Electrolysis doesn't play well with a custom profile path.

Sometimes, the impossible can become possible, if you're awesome!

aekotra
Offline
Last seen: 2 years 11 months ago
Joined: 2015-01-22 17:57
Now that users of the

Now that users of the Developer Edition (40) are prompted to enable Multiprocess, it might be time to investigate the session restore problem.

John T. Haller
John T. Haller's picture
Online
Last seen: 6 min 36 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Working

It's working in Dev 40 with our launcher. It was a base app bug related to multi-process that was fixed.

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments