You are here

Gaim Portable 2.0 Beta 6 Pre-Release 1 (Testers Needed)

26 posts / 0 new
Last post
John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 14 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Gaim Portable 2.0 Beta 6 Pre-Release 1 (Testers Needed)

I've posted a pre-release of Gaim Portable 2.0 Beta 6. This updates Gaim to the new 2.0 Beta 6 release.

It also adds in the ability to use a common GTK location without needing to use an INI. If you have your GaimPortable directory in your PortableApps directory, for instance. You can move the GTK directory within GaimPortable\App\gtk to the PortableApps\CommonFiles\GTK and Gaim Portable will use that location. GIMP will be updated the same way as will the other upcoming GTK-based apps. So, now you can have a single GTK on your drive, saving space. A later version of the installer will allow you to do this without doing it manually.

I'd also like folks to test to ensure that this can be installed over an existing Gaim Portable 2.0 Beta 5 installation successfully.

This includes the GTK shipped with Gaim 2.0b6 and I don't think they're officially supporting Win9x anymore. I'll post the older Win9x-compatible GTK as a patch later on.

Also, if some folks could ensure that the current OTR plugin works:
https://portableapps.com/downloads/testing/GaimOTRGaim2b5t1/gaim2-otr.dll

Copy that to your GaimPortable\App\Gaim\plugins directory in an instance of Gaim Portable 2.0 Beta 6. Then try using it on a PC without OTR installed locally to chat with someone else using OTR and see if it works or not.

Download Gaim Portable 2.0 Beta 6 Pre-Release 1

Regards,
John

Simeon
Simeon's picture
Offline
Last seen: 9 years 4 months ago
DeveloperTranslator
Joined: 2006-09-25 15:15
So

the "CommonFiles"-Age has begun...

"What about Love?" - "Overrated. Biochemically no different than eating large quantities of chocolate." - Al Pacino in The Devils Advocate

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 14 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Optional

It's optional. The apps are still standalone. It's just a nice option to save space.

Sometimes, the impossible can become possible, if you're awesome!

Ryan McCue
Ryan McCue's picture
Offline
Last seen: 14 years 4 months ago
Joined: 2006-01-06 21:27
Woot!

Now just gotta wait for Java and the server Wink
----
Ryan McCue
Person 1: Oh my god. You will never believe what just happened.
Person 2: What?
Person 1: I can't remember, I've forgotten.

"If you're not part of the solution, you're part of the precipitate."

rlabus
rlabus's picture
Offline
Last seen: 4 years 6 days ago
Joined: 2006-02-03 09:30
Installed

over the top of existing beta and seems to work ok but it took up another 45megs of space does this seem right?

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 14 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
No

It should be about 36mb total. It's the multilingual version.

Sometimes, the impossible can become possible, if you're awesome!

Xoslorg
Offline
Last seen: 16 years 11 months ago
Joined: 2007-01-24 16:10
Error

Error when i try insert new account.

An unhandled win32 exception occurred in gaim.exe [520].

fluffman86
Offline
Last seen: 16 years 7 months ago
Joined: 2006-11-02 09:20
Common Files

I can't get GTK to work when I place it in portableapps\commonfiles\gtk. Is this feature ready yet?

Also, I get the same error as the above post: I can't edit or add accounts.

--
The Weekend Meltdown - my podcast

rlabus
rlabus's picture
Offline
Last seen: 4 years 6 days ago
Joined: 2006-02-03 09:30
CommonFiles

Im Having same problem after moving gtk to commonfile

Gizmokid2005
Gizmokid2005's picture
Offline
Last seen: 2 months 3 weeks ago
Developer
Joined: 2007-01-17 19:24
No go

Just the same as my install that I did using the guide on sourceforge. It will work running locally (as it's installed) but as soon as I make it portable all of my AIM and ICQ accounts die, whereas my Yahoo and MSN still work. I'm thinking it has to do with some type of file location association but not sure.

But, if you get another one, I'll be right here!

somredcm
Offline
Last seen: 17 years 4 weeks ago
Joined: 2006-11-16 07:24
So far so good

Extracted over the last version and for some reason it wouldn't login to ICQ. Started from scratch and readded my accounts with no problems.

clivers
Offline
Last seen: 13 years 4 months ago
Joined: 2006-07-04 16:21
invisible text

this still has the invisible text problem. does anyone else have this problem?

DaveyNL
Offline
Last seen: 14 years 12 months ago
Joined: 2006-11-21 09:28
Initial account problems

When I installed gaim b6 over b5 I was not able to log in to a couple of accounts. When I tried to edit the account, gaim crashed.

I then renamed my old install directory and created a new fresh one. After I copied my accounts.xml all worked fine.

B6 seems a lot more stable, B5 used to crash when somebody sent me a (non-smiley) emoticon.

JJDafoe
Offline
Last seen: 8 years 1 month ago
Joined: 2007-02-02 20:03
Yahoo Contacts

My Yahoo contacts don't show up... all my other accounts work just fine.

guestt
Offline
Last seen: 16 years 8 months ago
Joined: 2007-02-10 18:01
Works well but it seams

Works well but it seams there is a new bug. It`s telling me "waiting for network connection" all time, even if I am conncted.

If I first start Gaim and go online later it will never connect. This bug did not exists in previous version.

I also suggest to include OTR by standard. If I want to suggest someone to use a secure messenger I could just redirect them to Gaim Portable with OTR. I don`t see any disadventages due OTR, no reason not to use it.

bastya_elvtars
Offline
Last seen: 15 years 9 months ago
Joined: 2006-06-01 06:53
Encryption

Hello John,
I think you might want to check this. Basically, it encrypts passwords using a master password. There are Win32 beta6 installers, I have unpacked one and put it over my Gaim Portable beta5 and works just fine.

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 14 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Can't

This is a patch to the Gaim code itself and it requires recompiling the entire Gaim package if you wish to use it with one of the actual releases. We should petition the Gaim folks to accept this into the tree, though.

Sometimes, the impossible can become possible, if you're awesome!

dooglus
Offline
Last seen: 17 years 7 hours ago
Joined: 2007-01-22 09:54
gaim-devel

I posted a message to the gaim-devel mailing list mentioning the master-passord patch, but I didn't hear anything back. I'm guessing they decided not to include it.

I've been using the patch myself since, and it does seem to be working well.

I don't understand the gaim developers' resistance to using something like this. It's certainly a big improvement on storing passwords in plain text, especially for us portableapps users.

Here's my old email to the list:
http://sourceforge.net/mailarchive/forum.php?thread_id=31633846&forum_id...

SmithTech
SmithTech's picture
Offline
Last seen: 1 year 10 months ago
Developer
Joined: 2006-11-24 18:06
Error running Gaim with gtk

Error running Gaim with gtk in \PortableApps\CommonFiles\gtk
1. "This application failed to start because intl.dll was not found. Re-installing the application may fix the problem."
2. "Error loading gtkgaim.dll.
Error:(126) The specified module could not be found.
This probably means that the GTK+ can't be found."

I tried with the gtk from the latest Gaim as well as the latest GIMP.

"Because they stand on a wall and say, 'Nothing is going to hurt you tonight. Not on my watch.'" (A Few Good Men)
Coincidence is God's way of remaining anonymous.(Albert Einstein)

abeckstrom
Offline
Last seen: 14 years 4 months ago
Joined: 2006-09-08 10:45
Experiencing same issue when running with gtk in CommonFiles

1. "This application failed to start because intl.dll was not found. Re-installing the application may fix the problem."
2. "Error loading gtkgaim.dll.
Error:(126) The specified module could not be found.
This probably means that the GTK+ can't be found."

Hope this gets fixed as this is likely to be a huge boost to the portable apps space. If I can run Gaim, Gimp, Workrave, X-Chat, StarDict, DIA, and the countless other apps that require gtk without having to have a copy of gtk in each apps' program directory that will save a ton of space Smile

Sanicle
Offline
Last seen: 6 years 11 months ago
Joined: 2006-11-16 07:05
I just tested the potential

I just tested the potential scenario of someone downloading the portable apps suite and installing beta 6 over the one in the original package. I got the standard "you have no accounts, would you like to add some?" message, but clicking on the add accounts button caused a crash. I tried this multiple times to ensure it wasn't a one off occurrence. Deleting the files within the gaim directory and then extracting beta 6 worked fine though.

sunmaker
Offline
Last seen: 12 years 11 months ago
Joined: 2007-03-08 09:28
Updating 2.0 b5 to 2.0 b6 PR1

I tried updating my Gaim Portable from beta 5 to beta 6, and even though I have my AIM, ICQ, MSN, and Yahoo! accounts to enable when Gaim launches my AIM and ICQ accounts show me my login name with (unknown) by each of them. I have no problems with my MSN or Yahoo! loging, but for some reason the AIM and ICQ accounts have a problem.

I tried editing the accounts, but I get what appears to be an error in memory and shuts down Gaim completely. I thought this was because the Gaim I used was English only and the beta 6 PR 1 is multilingual. I tried installing the beta 5 multilingual and install beta 6 PR 1 to see if that worked, and it didn't.

I am removing beta 5 and trying just to install beta 6 PR 1 by itself to see if I have any problems. If I do, I'll post it here.

Thanks for all you do!
Robert

Update: I figured out why the AIM and ICQ logins don't work. In beta 5, the AIM and ICQ selection in the list is the same selection. In beta 6, AIM and ICQ are separate selections. I do remember upgrading beta 5 to beta 6 on my local hard drive and didn't have this problem. Hope this helps.

Mancus Nemo
Offline
Last seen: 10 years 1 month ago
Joined: 2007-04-14 13:27
gaim b6 + otr

Hey guys,
the gaim b6 in a compleate new clean install is running perfect but the otr has no button to activate it. Onely the other side must start the session with otr.

Gaim b5 upgrade to b6 i was flamming with error and bug messages. Hm. So long it not use otr complete it is not very interestet. But it crashs as b5 as in uninterested moments. So it is not so bad.

Hope can help.

mfg

Mancus Nemo
Offline
Last seen: 10 years 1 month ago
Joined: 2007-04-14 13:27
upgrade to b6 from b5

After a new test it will run. But the otr button is not there that is the only one bug i have found. So long you can bring it out when this bug will clean.

rcdiugun
Offline
Last seen: 16 years 9 months ago
Joined: 2007-05-16 18:56
gaim.dll error

I get this error when I load it:

Error loading gaim.dll. Error: 1114

I'm using Windows XP SP2.

xaminmo
Offline
Last seen: 16 years 8 months ago
Joined: 2007-06-15 12:51
Gaim 2.0 b6-1 plus OTR test

This is to confirm, that this beta installs into a new, clean dir, and that the OTR plugin works.

The main point I notice is that OTR no longer provides a selector in the chat window to verify a sender; however, this has been gone since I moved off of 2.0 b2.

OTR starts faster. I haven't tested to see if suspend hangs GAIM yet.

Topic locked