You are here

[Solved] PAP UI messed up w/ Win7 Classic theme

30 posts / 0 new
Last post
CelticKat
CelticKat's picture
Offline
Last seen: 4 years 7 months ago
Joined: 2015-08-04 14:02
[Solved] PAP UI messed up w/ Win7 Classic theme

If I switch my Windows 7 theme to Classic, the apps list in PAP will still have a black background, and it looks really crappy. I can still use it, but it definitely is cringe-worthy UI-wise. Any idea on how I could fix this by any chance? The problem doesn't go away if I change the PAP theme to a light one.

I took screenshots of what it looks like under every theme for reference. Here they are:

  1. Default Light
  2. Default Dark
  3. Classic Light
  4. Classic Dark
  5. Smooth Light
  6. Smooth Dark
  7. Retro Light
  8. Retro Dark
  9. Modern Light
  10. Modern Dark
  11. Glossy Light
  12. Glossy Dark
  13. Flat Light
  14. Flat Dark

__________________________________________________
Specs:

  1. Make & Model: HP Compaq dc5700 SFF
  2. Operating System: Windows 7 Pro SP1 x64
  3. Medium Installed On: Dropbox for Windows, v3.8.6
John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 23 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Fine Here

I've got it running in a Windows 7 VM with the "Windows Classic" theme right now without issue (see here). I've never seen the behavior you're describing. Are you sure your color depth and video settings are correct?

Sometimes, the impossible can become possible, if you're awesome!

CelticKat
CelticKat's picture
Offline
Last seen: 4 years 7 months ago
Joined: 2015-08-04 14:02
Oops

Oops, I just updated my post with screenshots and didn't even know someone responded. Haha!

__________
What do zombie string theorists crave? Branes!

CelticKat
CelticKat's picture
Offline
Last seen: 4 years 7 months ago
Joined: 2015-08-04 14:02
And I'm Unsure...

Do you know how to determine if they are correct? I'm pretty sure it's correct. I haven't changed anything related to the resolution and colour settings since I installed this OS...

__________
What do zombie string theorists crave? Branes!

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 23 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Custom Colors

Did you set custom colors at the OS level in addition to selecting Windows Classic? If you switch it to Windows 7 theme is it OK? If you then switch it to just Windows Classic (not any custom theme you created) does it work right? Could you show a screenshot of more of the screen?

Sometimes, the impossible can become possible, if you're awesome!

CelticKat
CelticKat's picture
Offline
Last seen: 4 years 7 months ago
Joined: 2015-08-04 14:02
I did just today but...

I hadn't when I first posted this question. As for the themes you mentioned,

  • Windows 7: Looks just fine.
  • Windows Classic: As I said, I had only Windows Classic set when I first posted this question, and it was as the screenshots show. But, for the sake of your question, I tried again. It's the same.

Also, about the screenshot you're requesting, how does it possibly matter? All that's behind it is my desktop, which since I didn't change anything after switching to Windows Classic is the default, plain blue wallpaper. That's all you'd see. Or maybe the pale-ish taskbar, depending on what more you'd want me to screenshot.

__________
What do zombie string theorists crave? Branes!

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 23 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Other Apps UI Elements

Seeing other apps and UI elements would help, that's what I'd meant. Specifically the rest of your taskbar and maybe the PC properties and Explorer. It looks like something on your system is purposely applying a gray background and white text theme to every single label somehow. Are you using any sort of theming engine?

The menu is tested on and works with Windows Classic theme on Windows XP through 7. There is no Windows Classic theme in Windows 8 and up.

Sometimes, the impossible can become possible, if you're awesome!

richo
richo's picture
Offline
Last seen: 3 days 1 hour ago
Joined: 2007-01-31 22:03
I think I found a clue

I think I found a clue towards the problem. I just tried this myself and had similar graphic issues.

I switched from my custom theme to the standard Windows 7 theme, then switched to the Windows Classic theme (PAP was running when doing this)

PAP looked very similar to CelticKat's problem. I believe that a component used to build PAP doesn't properly support how the Desktop Window Manager applies theme changes on particular systems.

After exiting PAP (as in completely closing the platform) and starting PAP back up, the problem disappeared.

I believe this to be a minor issue as it only seems to happen when changing how Windows looks.

CelticKat, have you restarted PAP at all since having this issue? I suggest to try it, just to see what happens.

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 23 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Could Be

That could easily be it. The platform doesn't do anything at all to detect theme changes. So, it's just the default Delphi and Windows API component handling, which is likely less than optimal. I've seen lots of apps that custom draw their GUI that mess up on theme changes.

It's probably not worth pursuing given that the Classic theme is only in Windows 7 and ditched in Windows 8, 8.1, and 10.

Sometimes, the impossible can become possible, if you're awesome!

CelticKat
CelticKat's picture
Offline
Last seen: 4 years 7 months ago
Joined: 2015-08-04 14:02
Makes sense...

I switched from my custom theme to the standard Windows 7 theme, then switched to the Windows Classic theme (PAP was running when doing this)

PAP looked very similar to CelticKat's problem. I believe that a component used to build PAP doesn't properly support how the Desktop Window Manager applies theme changes on particular systems.

Yes, that explanation sounds very possible, even with my very limited understanding. And, indeed, I agree that it is a minor issue.

CelticKat, have you restarted PAP at all since having this issue? I suggest to try it, just to see what happens.

Yes, I have, and it no longer seems to be the case. Though I've also since customised the individual colours for particular objects with the UI. I can't remember which came first, to be honest. Sorry... :/

__________
What do zombie string theorists crave? Branes!

CelticKat
CelticKat's picture
Offline
Last seen: 4 years 7 months ago
Joined: 2015-08-04 14:02
Nope...

Are you using any sort of theming engine?

Nope. I'm using just what came default with Windows 7.

Also, totally just realised I never put my specs in my post. My mistake. Going to edit that in.

__________
What do zombie string theorists crave? Branes!

Wm ...
Offline
Last seen: 5 years 9 months ago
Joined: 2010-07-17 12:37
Default Light not recognisable

I use Default Light on Win 8.1 and Win XP and it looks nothing like your screenshot.

In what way have you shafted your poor system?

Wm

CelticKat
CelticKat's picture
Offline
Last seen: 4 years 7 months ago
Joined: 2015-08-04 14:02
What are you talking about?

"Shafted your poor system"

Sounds very accusatory, Wm ... :/

__________
What do zombie string theorists crave? Branes!

Wm ...
Offline
Last seen: 5 years 9 months ago
Joined: 2010-07-17 12:37
absoloutely :)

I tend to make systems work rather than fiddle with them so other people have to make them work again. tossed coins

Wm

CelticKat
CelticKat's picture
Offline
Last seen: 4 years 7 months ago
Joined: 2015-08-04 14:02
σ_σ ...

You automatically accuse me of fucking up my system, without any knowledge of any thing I might or might not have done?

__________
What do zombie string theorists crave? Branes!

Mavis Beacon
Offline
Last seen: 7 years 2 weeks ago
Joined: 2015-05-17 04:46
There's no need to use obscene language

Please do not use obscene language in these forums. There's no need, and many will find it offensive.

CelticKat
CelticKat's picture
Offline
Last seen: 4 years 7 months ago
Joined: 2015-08-04 14:02
You're right.

My apologies.

__________
What do zombie string theorists crave? Branes!

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 23 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Let's Stop Here Please

Let's stop here please and be civil. Please no additional name-calling, come-backs or explanations. There is no need on anyone's part to be hostile to users asking questions or return additional hostility. It's interruptive to our forums and against the guidelines.

Sometimes, the impossible can become possible, if you're awesome!

richo
richo's picture
Offline
Last seen: 3 days 1 hour ago
Joined: 2007-01-31 22:03
About the guidelines

John,

I don't know if it occurs enough to warrant updating the guidelines, but what are your thoughts on maybe adding something about making accusations without doing the following:

  • accurately following steps to reproduce a problem,
  • asking for additional steps on reproducing the problem,
  • or obtaining extra details to help identify the cause

or any other points you could think of.

Edit: It would probably supplement the "Play Nice" guideline.

Wm ...
Offline
Last seen: 5 years 9 months ago
Joined: 2010-07-17 12:37
or asking for help without

+ saying what the steps are to reproduce a problem when reporting it
+ asking what additional information other people might need to reproduce it
+ or anything else the helpers might need

tossed coin, again

Wm

CelticKat
CelticKat's picture
Offline
Last seen: 4 years 7 months ago
Joined: 2015-08-04 14:02
I did all those things, Wm ...

• I said what I did prior to it occurring.
• I couldn't say anything more than what I already did, as all that happened prior to this issue occurring was no more complicated than what I said I did.
• I included what specs I run, so if someone needed additional information, it's called ask; I'm not a mind-reader.

Either way, you shouldn't have just assumed I'm an idiot. You could have politely asked whatever you needed to know, and I would have probably been more than willing to do what I could to find out said information.

__________
What do zombie string theorists crave? Branes!

Steve_Storm
Offline
Last seen: 2 days 4 hours ago
Joined: 2008-01-23 17:05
Default light and dark themes are the same color

I just updated to PAP 12.1, when I try the default light and dark themes they are both showing up light, The text is correct on the dark theme, but the theme color is the same as the light. I'm running windows 10 Home Build 10240. All of the other themes are fine. I can deal with it, but I thought you might want to know. Thanks for your hard work John!

Edit: I looked at the PATheme.ini file and under [Menu] it has Chrome=custom instead of Chrome=default_dark. I changed it and seems to be working correctly now.

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 23 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Unrelated

Sorry to hear of the issue, but this is unrelated to this thread... Windows 10 doesn't even have a Windows Classic theme. Platform themes are unchanged in 12.1 from 12.0.5 and I just verified a fresh install shows properly. Please post a new thread with the details (install path, new vs upgrade, etc) including a screenshot if you can.

Sometimes, the impossible can become possible, if you're awesome!

Steve_Storm
Offline
Last seen: 2 days 4 hours ago
Joined: 2008-01-23 17:05
I edited my comment/ fixed

I apologize for piggybacking on this thread. I fixed the issue myself. I haven't done a fresh install of the PAP in years, it was probably something left over from a past upgrade. I'm familiar enough with the platform to have been able to fix my issue. I appreciate your response John, keep up the good work sir. Smile

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 23 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Glad to Hear

Glad to hear. Since you did an upgrade, you got the quick-install patch version which only updates files that have changed. Since the theme files hadn't changed, your manual edit remained from before. When the themes are updated in the next few weeks, it would have fixed itself then anyway. Smile

Sometimes, the impossible can become possible, if you're awesome!

CelticKat
CelticKat's picture
Offline
Last seen: 4 years 7 months ago
Joined: 2015-08-04 14:02
Conclusion...

How do I mark this thread as "solved"?

__________
What do zombie string theorists crave? Branes!

vf2nsr
vf2nsr's picture
Offline
Last seen: 5 years 11 months ago
Developer
Joined: 2010-02-13 17:10
Go to original post

choose edit

Change post tile to something like [Solved] PAP UI messed up w/ Win7 Classic theme

“Be who you are and say what you feel because those who mind don't matter and those who matter don't mind.” Dr. Seuss

CelticKat
CelticKat's picture
Offline
Last seen: 4 years 7 months ago
Joined: 2015-08-04 14:02
Thanks.

Much appreciated.

__________
What do zombie string theorists crave? Branes!

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 23 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Could be a Delphi bug

Out of curiosity, I wrote a quick message handler to trap when Windows changes its themes. I can catch the change and then do something in the menu like reload the theme. But it seems like the actual labels are getting stuck. I think it's a bug in Delphi (the language it's written in) itself with having a transparent PNG (the highlight) over the labels (the text like the names of the apps in the list, etc. It happens with all the apps and Documents but not the other labels on the right. I'm going to experiment with it a bit later.

UPDATE: It does appear to be a Delphi bug specifically with the old classic theme. It doesn't happen for any other theme changes including DWM changes of going from Aero to Basic themes (with/without transparency). I've noted it on the bug page for completeness.

Sometimes, the impossible can become possible, if you're awesome!

CelticKat
CelticKat's picture
Offline
Last seen: 4 years 7 months ago
Joined: 2015-08-04 14:02
Okies.

Thanks. Smile

__________
What do zombie string theorists crave? Branes!

Log in or register to post comments