You are here

Need Windows XP users to test new eject utility (Update 2017-12-04)

11 posts / 0 new
Last post
John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 1 min ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Need Windows XP users to test new eject utility (Update 2017-12-04)

The PortableApps.com Platform uses the USB Disk Ejector utility internally to handle safe ejects of USB drives. It's a solid open source utility with years of work behind it. Unfortunately, version 1.3.x of the utility, while fixing some issues, has caused issues for some of our Windows XP users in the past. Most recently, we tried upgrading it in the Platform 14.0 release but had to revert back the old 1.1.2 disk ejector in Platform 14.1.

In preparation for the next platform release, I'd like to see if the new 1.3.0.6 version of the USB disk ejector utility is working for the Windows XP users that were affected by the drive issues previously. If you'd like to help out, please do the following:

1. Browse to the PortableApps\PortableApps.com\App\Bin directory and rename eject.exe to eject_original.exe
2. Visit the USB Disk Ejector website and click the download button at the bottom of the page (you may need to dismiss the cookie notice to see it) and then click download again on the next page.
3. Open USBDiskEjector1.3.0.6.zip and extract the USB_Disk_Eject.exe file
4. Place USB_Disk_Eject.exe in your PortableApps\PortableApps.com\App\Bin directory and rename it to eject.exe
5. Now try running the platform's eject feature on your Windows XP machine

Thanks in advance for any help you can provide with this.

UPDATE 2017-06-08: Publisher released 1.3.0.5, updated topic and added new comment calling for new testing
UPDATE 2017-12-04: Publisher released 1.3.0.6, updated topic and added new comment calling for new testing

Freehunter
Offline
Last seen: 1 week 1 day ago
Joined: 2014-06-26 10:21
Test Eject

Hope this is not too late. Followed your instructions to relace the eject.exe.

I don't usually use the eject on the platform so I don't know what the problem looked like previously

Tried the Platform's eject several times and worked.

Clicked eject and Platform closed but the drive did not eject.

Worked several times and then failed. Platform closed but drive did not eject.

Watching TaskManager and see eject start and then close and Platform close but drive did not eject.

Notice that an icon for USBDiskEjector remains in the TaskBar until try to hover over to see if it has a Tooltip. Eject.exe is not running at the time.

Then had a string where it failed to eject repeatedly.

Windows XP Home Edition SP3

Processors Information
-------------------------------------------------------------------------
Processor 1 ID = 0
Number of cores 1 (max 1)
Number of threads 1 (max 1)
Name Intel Core Solo
Codename Yonah
Specification Genuine Intel(R) CPU T1350 @ 1.86GHz
Package (platform ID) Socket 479 mPGA (0x5)
CPUID 6.E.8
Extended CPUID 6.E
Core Stepping C0
Technology 65 nm
Core Speed 1861.7 MHz
Multiplier x Bus Speed 14.0 x 133.0 MHz
Rated Bus speed 531.9 MHz
Stock frequency 1866 MHz
Instructions sets MMX, SSE, SSE2, SSE3
L1 Data cache 32 KBytes, 8-way set associative, 64-byte line size
L1 Instruction cache 32 KBytes, 8-way set associative, 64-byte line size
L2 cache 2048 KBytes, 8-way set associative, 64-byte line size
FID/VID Control yes
FID range 6.0x - 14.0x
Max VID 1.263 V

Chipset
-------------------------------------------------------------------------
Northbridge Intel i945GM rev. 03
Southbridge Intel 82801GHM (ICH7-M/U) rev. B0
Memory Type DDR2
Memory Size 512 MBytes
Channels Single
Memory Frequency 266.0 MHz (1:2)
CAS# latency (CL) 4.0
RAS# to CAS# delay (tRCD) 4
RAS# Precharge (tRP) 4
Cycle Time (tRAS) 12
Bank Cycle Time (tRC) 16
Host Bridge 0x27A0

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 1 min ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Thanks, Standard Work?

Thanks for that. Does the standard version included with Platform 14.1 work for you?

Sometimes, the impossible can become possible, if you're awesome!

Freehunter
Offline
Last seen: 1 week 1 day ago
Joined: 2014-06-26 10:21
Standard version works

Yes, the one that comes with 14.1 seems to work consistently without any hesitation. Should have reported that too.

gmbudwrench
gmbudwrench's picture
Offline
Last seen: 3 days 5 hours ago
Joined: 2007-06-25 05:00
Closes the platform

but does not eject the drive. Wins XP sp3. I normally use the eject function of windows, but decided to try this to contribute some info.

Update: Renaming the new version to eject, not eject.exe seems to have fixed the problem initially, will keep trying it.

Also: the old one works for me too.

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 1 min ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Please Try 1.3.0.5

If any of the affected Windows XP users are still around that previous 1.3.x releases did not work for, could you please try the new 1.3.0.5 release of USB Disk Ejector following the instructions outlined in the main post. I'd like to see if this new release addresses the old bug so we can move to the newer version. If not, we'll stick with 1.1.2.0 as currently included in the platform.

Sometimes, the impossible can become possible, if you're awesome!

Freehunter
Offline
Last seen: 1 week 1 day ago
Joined: 2014-06-26 10:21
Seems to be working

Sorry, haven't been going through the forums in detail lately and hadn't notice this new post. If I recall correctly the old test failed pretty quickly. This time didn't have any failures.

Windows XP Home SP3
Still on the same old laptop
PortableApps.com Platform 14.4.1 new installation

Using old version that came with Platform, eject OK 15 times (for comparison)

USB 3.0 Flash, Using new downloaded eject.exe, eject OK 25 times

USB 2.0 Flash Using new downloaded eject.exe, eject OK 20 times

Looks like it is working

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 1 min ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Thanks!

Thanks for taking the time to test! I don't have access to a Windows XP machine anymore, just virtual machines that complicate the use of USB so I can't rely on it for testing a system level eject.

Sometimes, the impossible can become possible, if you're awesome!

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 1 min ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Please Try 1.3.0.6

A new version was released and I'd like some Windows XP users, particularly those with previous issues, to test it out on their PCs if they can.

Sometimes, the impossible can become possible, if you're awesome!

Freehunter
Offline
Last seen: 1 week 1 day ago
Joined: 2014-06-26 10:21
Appears to work

Windows XP Home, SP3 same laptop as first test
Platform 14.4.1, new install

30 times with old version as a control, worked every time

30 times with new 1.3.0.6, worked every time

new version appears to be OK

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 1 min ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Thanks!

Thanks for testing. It confirms we should be good including this in the new platform which will better handle ejecting on newer systems.

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments