You are here

[Fixed] Inkcsape Portable - Language handling broken

5 posts / 0 new
Last post
leminsc8
Offline
Last seen: 1 year 7 months ago
Joined: 2016-11-21 13:15
[Fixed] Inkcsape Portable - Language handling broken

i cant cnage my languange to german.
@ https://inkscape.org/en/learn/faq/#how-change-inkscapes-interface-language it tells im must

Edit > Inkscape Preferences > Interface: Language. This requires a restart of Inkscape to take effect.

But after restart it have nothing change.
can you help me?

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 3 hours 23 min ago
DeveloperModerator
Joined: 2008-07-24 18:46
Confirmed, Use fix until released

I've confirmed this is a bug with the portable packaging. I've marked this as a bug as a result.

Until an updated build is released, replace X:\PortableApps\InkscapePortable\InkscapePortable.exe with this one, and replace the contents of X:\PortableApps\InkscapePortable\App\AppInfo\Launcher\InkscapePortable.ini with the following:

[Launch]
ProgramExecutable=Inkscape\inkscape.exe
DirectoryMoveOK=yes
SupportsUNC=yes

[Activate]
Ghostscript=find
XML=true

[Environment]
INKSCAPE_PORTABLE_PROFILE_DIR=%PAL:DataDir%\settings
HOME=%PAL:DataDir%\settings
APPDATA=%PAL:DataDir%\settings
PYTHONHOME=%PAL:AppDir%\Inkscape\python
PATH=%PATH%

[FilesMove]
recently-used.xbel=%LOCALAPPDATA%

[Language]
Base=%PortableApps.comLocaleglibc%
CheckIfExists=%PAL:AppDir%\Inkscape\locale\%PAL:LanguageCustom%\*.*
DefaultIfNotExists=en_US

[LanguageFile]
Type=XML attribute
File=%PAL:DataDir%\settings\preferences.xml
XPath=/inkscape/group[@id="ui"]
Attribute=language

[FileWrite1]
Type=XML attribute
File=%PAL:DataDir%\settings\preferences.xml
XPath=/inkscape/group[@id="ui"]
Attribute=language
Value=%PAL:LanguageCustom%

[FileWrite2]
Type=Replace
File=%PAL:DataDir%\settings\preferences.xml
Find=%PAL:LastDrive%%PAL:LastPackagePartialDir%\
Replace=%PAL:Drive%%PAL:PackagePartialDir%\

[FileWrite3]
Type=Replace
File=%PAL:DataDir%\settings\preferences.xml
Find=%PAL:LastPortableAppsBaseDir%\
Replace=%PAL:PortableAppsBaseDir%\

[FileWrite4]
Type=Replace
File=%PAL:DataDir%\settings\preferences.xml
Find=%PAL:LastDrive%\
Replace=%PAL:Drive%\

[FileWrite5]
Type=Replace
File=%PAL:DataDir%\settings\.recently-used.xbel
Find=file:///%PAL:LastDrive%%PAL:LastPackagePartialDir:ForwardSlash%/
Replace=file:///%PAL:Drive%%PAL:PackagePartialDir:ForwardSlash%/

[FileWrite6]
Type=Replace
File=%PAL:DataDir%\settings\.recently-used.xbel
Find=file:///%PAL:LastPortableAppsBaseDir:ForwardSlash%/
Replace=file:///%PAL:PortableAppsBaseDir:ForwardSlash%/

[FileWrite7]
Type=Replace
File=%PAL:DataDir%\settings\.recently-used.xbel
Find=file:///%PAL:LastDrive%/
Replace=file:///%PAL:Drive%/

I'll also be submitting this fix to the Inkscape Team for inclusion in their next release.

[EDIT] Fix submitted: https://bugs.launchpad.net/inkscape/+bug/1643730

John T. Haller
John T. Haller's picture
Offline
Last seen: 8 hours 26 min ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Fixed in 0.92

This is fixed in today's release of Inkscape Portable 0.92

Sometimes, the impossible can become possible, if you're awesome!

djnavas
djnavas's picture
Offline
Last seen: 2 days 14 hours ago
Joined: 2008-01-30 17:27
I have installed version 0.92

I have installed version 0.92 / Windows 7 SP1 and the language change is not applied. I changed in the *.ini the following:

DefaultIfNotExists=en_US

to my default language: es_ES

John T. Haller
John T. Haller's picture
Offline
Last seen: 8 hours 26 min ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Outdated

The above is outdated. Language switching now works as it should. Change it in the app or in the PA.c Platform.

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments