You are here

Profile RANDOM corruption/missing/lost/XYZ?!

5 posts / 0 new
Last post
AntiVirGear
AntiVirGear's picture
Offline
Last seen: 2 years 11 months ago
Joined: 2017-05-08 15:44
Profile RANDOM corruption/missing/lost/XYZ?!

Hey,

I have some serious issues with FF, TB and several other Apps over PortableApps!

I own three different PC (Windows 10 64bit as User/AntiVirGear-N10, Windows 7 64bit as AntiVirGaming/AntiVirGamingT7 and Windows 7 64bit as User/AntiVirGear-N7) and all my data and apps are on a 1TB HDD without any errors (weekly SMART check, file defragmentation and chkdsk) and here is the point: It happens randomly!

Let me show you some scenarios and define N10 as A, T7 as B and N7 as C!

1. A using FF for browsing, downloading and watching videos.
2. B uses FF for browsing and downloading.
3. A uses FF again for browsing and watching videos.
4. C uses FF for browsing.
5. B uses FF for watching videos
6. A get a corrupted profile, settings are lost or dot detected (for example, all my password are gone but if I start FF as admin, then I can see them!)

Sounds like B cause the corruption, right? NO! It also happen if I use C, it mostly happens, if I use FF on another PC and then it just need a bit of luck whether I can use FF without any problem or have to restore/rebuild a profile AGAIN!
But here is the point, PortableApps is MADE for using apps on any kind of PC so why does it happen to me all the time?

AV doesn't affect anything since I refuse them to access the portableapps folder!
I always safely remove the HDD and only plug it in after windows have been loaded!
I don't start FF or else as admin since I don't think I need to.

So yes... I'm now making a backup with toucan every time before unplugging but this shouldn't be a solution for that.
Tell me what's wrong with my configuration and thank you therefore so much.

Best regards
AntiVirGear

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 48 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Permissions

If running as admin gives you access to things you otherwise don't have, that's generally a permissions issue. If the drive is formatted as NTFS, it can have permissions set to now allow other computers access to a give folder or file, which will cause things like passwords to disappear. There's nothing in the platform, launcher, or Thunderbird/Firefox code to do anything like this, so something on one or more of your PCs is causing it, it's just a matter of figuring out what.

If you right-click on the drive in Explorer and select Properties then the Permissions tab, make sure "Everyone" is set up with "Full Control". Even if you use the same login on multiple PCs, it's treated as a different user.

Sometimes, the impossible can become possible, if you're awesome!

AntiVirGear
AntiVirGear's picture
Offline
Last seen: 2 years 11 months ago
Joined: 2017-05-08 15:44
It happened again and this

It happened again and this time, I lost every Outlook account on Thunderbird! After a restart, they appeared again but empty!
I already set the whole external HDD to Owner:Everyone, set the permission AND I didn't changed the machine so... what now?

EDIT: Restarted Thunderbird the third time because it refused to receive the emails and now everything is back?... I mean, it appeared like magic...

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 48 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Something else

There's nothing in any code that would make any difference starting it a first, second, or third time, nor anything that would cause any of the behavior you're mentioning above. You can review the code yourself within ThunderbirdPortable\Other\Source.

The possibilities are a (1) permissions issue, though this should not be the case if 'Everyone' is set to 'Full Control' (it must be set that way only), (2) an issue with the drive itself in which case trying another drive could eliminate the issue, (3) something interfering on one or more PCs which could be antivirus, antispyware, an infeact, or similar, or (4) a short in a USB port which could cause issues with some files becoming unavailable.

Sometimes, the impossible can become possible, if you're awesome!

AntiVirGear
AntiVirGear's picture
Offline
Last seen: 2 years 11 months ago
Joined: 2017-05-08 15:44
Okay, I thought about a bug

Okay, I thought about a bug somewhere since I also faced some random issue to the installed version of Thunderbird like that all emails "disappeared" because the columns aren't visible/checked anymore.

Log in or register to post comments