You are here

Possible Layout Problem

5 posts / 0 new
Last post
Cooker
Offline
Last seen: 6 years 11 months ago
Joined: 2017-08-15 17:48
Possible Layout Problem

Hello

While browsing pixiv with the firefox portable the site layout became borked losing some of it's several functions.

Context:
Messed up layout - http://imgur.com/n3BnFRr http://imgur.com/xzeS7oh
Correct layout - http://imgur.com/40YqtXV

It won't also display which links were previously opened ( http://imgur.com/SVt82Wp ). Site won't work on any stored portable version, but works on the non-portable firefox version (45.7.0 ESR). Everything was fine yesterday, what can be the problem?

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 8 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Unmodified Firefox

The copy of Firefox included within Firefox Portable has not been modified. So it will render sites the same as a locally installed version does. It is likely the website did not test in the current version of Firefox and has some CSS that doesn't display quite right. If you're using an ad blocker, that could also interfere.

Sometimes, the impossible can become possible, if you're awesome!

Cooker
Offline
Last seen: 6 years 11 months ago
Joined: 2017-08-15 17:48
Both the Firefox Portable and

Both the Firefox Portable and the normal installed Firefox are the same version, 45.0.7 ESR, so by what you're saying shouldn't both be displaying the same thing?

Some days ago I had this exact same problem, but changing into Private Browsing would fix most issues that weren't cause by using a very outdated version, so I assumed it was a problem with some corrupted files. Changed to Firefox Portable version 26.0 and everything was fine, until today. All the pictures from the previous links were also taken on a clean installation of Firefox Portable 45.0.7 ESR, so it has no add-ons installed.

PS - Just tested pixiv on the latest portable version (55.0.1 (64-bit)), still has the same issues.
PPS - Slightly weird. Tested out the page on the installed Firefox 45.0.7 ESR and all is fine as previously confirmed, but by using Private Browsing the website is messed up. How is that possible?

Edit - To clarify, the site preferences are always on default, on every version.

Thank for your time.

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 8 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
We Don't Support Firefox

We don't support browsing issues within Firefox itself. We only support portability issues. Firefox.exe is called directly with the official -profile switch which is the sole difference between local and portable. That switch is supported by Mozilla. The portable launcher adjusts paths, moves files into place, and cleans up afterwards. We don't alter the way Firefox actually browses in any way. The default profile included with Firefox Portable has two changes from standard Firefox. The disk cache is disabled (since it slows Firefox down when run from slow USB media and overwhelms file sync services in cloud folders) and the updater is set to ask about updating before doing so. No changes would alter the way Firefox displays pages.

We don't support any version of Firefox Portable prior to the current releases of Firefox Portable 55.0.1 and Firefox Portable ESR 52.3.0. Anything earlier is insecure.

Sometimes, the impossible can become possible, if you're awesome!

Cooker
Offline
Last seen: 6 years 11 months ago
Joined: 2017-08-15 17:48
I see, terribly sorry for

I see, terribly sorry for wasting your time. I was thinking if it could be something like problems with the cache on RAM or anything. I finally managed to test the problem with someone else and it was replicated 100%.

Again, terribly sorry for bugging you and thank you so much for the help and clarifications.

Cheers

Log in or register to post comments