You are here

[Fixed] Failed connection to PortableApps.com in platform 14.4.2 on 32-bit OS

9 posts / 0 new
Last post
Portablist
Offline
Last seen: 3 weeks 22 hours ago
Joined: 2016-04-06 12:34
[Fixed] Failed connection to PortableApps.com in platform 14.4.2 on 32-bit OS

After update to latest platform February 1, 2018, I get, when trying to check for further updates:
"Unable to retrieve to PortableApps.com to retrieve portable apps. Please try again later.
[Invalid ZipFilePossibleNoConnectionOrFirewall]"
That never happened before.

What can I do?

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 11 min ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Retry

Just retry. The server was a little overloaded.

Sometimes, the impossible can become possible, if you're awesome!

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 11 min ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
32-bit OS

If you're on a 32-bit OS, you will be unable to update, use the app store, or backup-restore as the 64-bit version of 7-Zip was inadvertently included as the default. I've built a PA.c Platform 14.4.3 release that is now available for manual download that will fix the issue for you. It will be pushed out automatically to those on 14.4.1 and earlier and 64-bit OSes shortly.

If you're on a 32-bit OS and need to install manually, head to the Download page at the top of the website and download the installer. Run it. If it automatically detects your install, just install that way to upgrade. If you must select your location manually, select the directory containing Start.exe already.

Sometimes, the impossible can become possible, if you're awesome!

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 11 min ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Fixed in 14.4.3

There was a bug in 14.4.2 that prevented the updater/app store and backup/restore from working on 32-bit version of Windows. A quick fix release of version 14.4.3 was posted soon after, but anyone on a 32-bit version of Windows who updated to 14.4.2 in those few hours will need to manually update. To do this, head to the Download page and download the full installer for the PortableApps.com Platform 14.4.3. Run the installer. If you've installed to one of the standard locations (Start.exe in the root of your external drive or APPDATA or your cloud folder) it should detect it automatically. If it doesn't, select Custom Location and browse for the directory containing the Start.exe you use to start the platform. Don't pick the PortableApps or PortableApps.com directories inside that.

The issue was that the 64-bit version of 7-Zip was included as the default. So, the updater/app store was unable to unzip the app database on 32-bit systems since 7-Zip wouldn't run. This quick fix repairs this issue.

My apologies for any inconvenience due to my mistake.

Sometimes, the impossible can become possible, if you're awesome!

harimorgan
Offline
Last seen: 5 days 53 min ago
Joined: 2018-02-13 18:52
Updated to 14.4.3

Hiya

Couldn't update to 14.4.3 So downloaded as directed, it installed ok into existing directory. Platform loads up ok ....

But now when any App needs updating it fails with a message :

"The downloaded copy of whateverApp is not valid and can not be installed. this could be due to an incomplete download or other network issue. please try running the updater again when complete."

Its as if it knows the previous apps where installed by an older version of the platform and it won't allow this newer version to proceed. I'm on Win 7 64bit.

Thanks for all your hard work

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 11 min ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Which File?

Please detail which specific file is failing in a separate thread. This is unrelated to the issue with upgrading the platform. Some go out of date when the publisher releases a new version of an app and we have yet to update it. For example, with some live installers that download the app from the publisher, we hash the publisher's release since we know it's clean and have scanned it in 60 antivirus engines. When the publisher releases a new version, the hash changes. Our platform's updater as well as the app's live installer itself will reject this with the exact above error message by design.

Sometimes, the impossible can become possible, if you're awesome!

harimorgan
Offline
Last seen: 5 days 53 min ago
Joined: 2018-02-13 18:52
Not an issue any more

Hi John

It was every app that needed updating which included:
- Audacity
- Autoruns
- FileZilla
- Chrome
- x2 jPortable
- Notepad
- Rapid CRC

All reported same message, in fact none would update which made it seem relate to the platform update....

However I then went to update Chrome 64 bit manually , but the connection to the following was down..
https://downloads.sourceforge.net/portableapps/GoogleChromePortable64_64...
so then it looked unlikely to be the platform update, and more likely the location where the updated files live.

By this morning, the issue is no longer. Have updated the apps. So it was probably an outage ~ midnight UTC on the location of the app files. Do they all reside in the same place...?

Thanks

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 11 min ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
SourceForge

That means your local SourceForge mirror was having issues. That's why I had no issues and most others didn't either. That's also one reason I was asking what specific app. We have no control over SourceForge mirrors which is one reason we're looking into possible ways to replace them.

Sometimes, the impossible can become possible, if you're awesome!

danjng
Offline
Last seen: 1 week 2 days ago
Joined: 2018-02-13 22:51
Running into the same issue

Running into the same issue here... Any leads on how to fix this?

I'm seeing the same exact errors but on Windows 10 64bit.

Log in or register to post comments