You are here

[Fixed] LibreOffice Portable 6.0.1 won't run on systems without VC runtime 2015

16 posts / 0 new
Last post
getco
Offline
Last seen: 1 year 8 months ago
Joined: 2008-08-03 05:31
[Fixed] LibreOffice Portable 6.0.1 won't run on systems without VC runtime 2015

After installing:

LibreOfficePortable_6.0.1_MultilingualStandard.paf.exe
or
LibreOfficePortable_6.0.1_MultilingualAll.paf.exe

non of the launchers will run:

LibreOfficePortable.exe
LibreOfficeWriterPortable.exe
LibreOfficeMathPortable.exe
LibreOfficeImpressPortable.exe
LibreOfficeDrawPortable.exe
LibreOfficeCalcPortable.exe
LibreOfficeBasePortable.exe

LibreOfficePortable.exe shows up briefly as a new task and then dies.

Windows 7 64-bit. Never had this problem before.

John T. Haller
John T. Haller's picture
Online
Last seen: 1 min 21 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Confirmed

LibreOffice itself seems to not run. I think it may be a shared library issue. I'm investigating...

Sometimes, the impossible can become possible, if you're awesome!

John T. Haller
John T. Haller's picture
Online
Last seen: 1 min 21 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Test Fix 1

Sometimes, the impossible can become possible, if you're awesome!

getco
Offline
Last seen: 1 year 8 months ago
Joined: 2008-08-03 05:31
Thanks!

Thanks!

Installed the patch in the same folder as LibreOfficePortable 6.0.1, but it didn't solve the problem. The situation is the same as before.

Tried installing both LibreOfficePortable_6.0.1_MultilingualStandard.paf.exe and LibreOfficePortable_6.0.1_MultilingualAll.paf.exe

John T. Haller
John T. Haller's picture
Online
Last seen: 1 min 21 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Working Here

I just tried installing LibreOffice Portable 6.0.1 Standard and then the patch on a clean Windows 10 virtual machine and it's working without issue. Please open up LibreOfficePortable\App\LibreOffice\program and run soffice.exe directly. This will run it in local mode but will allow it to show you any errors. Also, while you are in that directory, ensure you see the file api_ms_win_core_console_l1_1_0.dll and similar to verify that the patch installed correctly.

Sometimes, the impossible can become possible, if you're awesome!

getco
Offline
Last seen: 1 year 8 months ago
Joined: 2008-08-03 05:31
Yes, the patch is there and

Yes, the patch is there and the error is the missing patch:

"The program can't start because api_ms_win_core_console_l1_1_0.dll is missing from your computer. Try reinstalling the program to fix this problem."

Perhaps it's a Windows 7 issue. Any other ideas?

John T. Haller
John T. Haller's picture
Online
Last seen: 1 min 21 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Various Reasons

I've seen people write about various reasons for this online including needing to re-run SFC and some IE add-ons interfering. Not sure what it is in your case. Did LibreOffice Portable 6.0.0 work on the affected PC? Can you try temporarily installing the local 32-bit version of LO 6.0.1 and see if it works? And just to confirm, api_ms_win_core_console_l1_1_0.dll is in the same directory as soffice.exe?

ADDENDUM: Also, just to ensure it's not another piece of the app having an issue, could you please go to the LibreOfficePortable\App\AppInfo\Launcher directory and open up the LibreOfficePortable.ini file. Within it, after the [Activate] section and its 3 lines could you please add:

[ENVIRONMENT]
PATH=%PAL:AppDir%\LibreOffice\program;%PATH%

After that, try running LibreOfficePortable.exe again.

Sometimes, the impossible can become possible, if you're awesome!

getco
Offline
Last seen: 1 year 8 months ago
Joined: 2008-08-03 05:31
Yes, I can confirm that api

Yes, I can confirm that api_ms_win_core_console_l1_1_0.dll is in the same directory as soffice.exe.

I've tested what you suggested in the ADDENDUM and it still doesn't work.

Yes, 6.0.0 portable works without any issues.

Tried installing a local 6.0.1 version:

Created a system restore point to make sure nothing is left after removing the local version.

Installed a local 6.0.1 32-bit version and it works. Also once installed the portable 6.0.1 works.

Did a system restore and went to pre-LO state.

Installed a local 6.0.1 64-bit version and it works. Also once installed the portable 6.0.1 works.

I suppose that has something to do with MS Visual C++ that was also installed with the local version. It was Microsoft Visual C++ 2015 Redistrbutable (x64) - 14.0.24215... Previously I only had the 2013 version.

HuyoS
Offline
Last seen: 4 years 9 months ago
Joined: 2018-02-18 09:12
LibreOffice Portable 6.0.1 won't run

I have the same problem with L.O. 6.0.0.1 up to 6.0.2 on Windows 10 (1709) with Microsoft Visual C++ 2013 Redistrbutable (x64). I can solve it by returning to L.O. 5.

getco
Offline
Last seen: 1 year 8 months ago
Joined: 2008-08-03 05:31
I think you should update to

I think you should update to Microsoft Visual C++ 2015 Redistrbutable (x64)

John T. Haller
John T. Haller's picture
Online
Last seen: 1 min 21 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Test Fix 2

Please try applying this patch to LibreOffice Portable 6.0.1 on your system: https://portableapps.com/downloads/temp/LibreOfficePortable_6.0.1_Rev_2_...

This corrects an issue with the bundled files in Test Fix 1

Sometimes, the impossible can become possible, if you're awesome!

getco
Offline
Last seen: 1 year 8 months ago
Joined: 2008-08-03 05:31
It works! Thank you!

It works! Thank you!

Abraxian
Offline
Last seen: 3 weeks 2 days ago
Joined: 2010-08-18 10:40
Patched and Working

I just downloaded LibreOfficePortable_6.0.1_MultilingualStandard.paf.exe and installed to a Windows 7 Pro. x64 SP1 system. Then I tried launching LibreOfficeWriterPortable.exe and it wouldn't run. After faffing around with it for a while I came to the forum to see if any help there. Then read this thread. Installed the LibreOfficePortable_6.0.1_Rev_2_Test_2.paf.exe patch and then Writer launched without issues. So question is, could you give some brief overview of what the patch actually does? What does it install and why?

EDIT: Removed my question about the Ribbon interface. (Leaving it here might just confuse people.)

Use Portable Apps on both Flash Drive and HDD/SSD.

Abraxian
Offline
Last seen: 3 weeks 2 days ago
Joined: 2010-08-18 10:40
Woops! Scrap My Question About the Ribbon

Just found out that I needed to go to (Menu) Toolbar Layout > Notebookbar to enable the Ribbons. Scrap my question about ribbon - working fine now. Sorry.

Still though, what does the patch actually do?

Use Portable Apps on both Flash Drive and HDD/SSD.

John T. Haller
John T. Haller's picture
Online
Last seen: 1 min 21 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Missing Files

All it does is add some shared DLL to the existing LibreOffice Portable install. It will shortly be released as 6.0.1 Rev 2 officially.

As for other features, you'd need to ask the publisher. Those same options are also greyed out in my local install. Please keep this topic just on the bug being addressed as people get email notifications of every post here.

Sometimes, the impossible can become possible, if you're awesome!

John T. Haller
John T. Haller's picture
Online
Last seen: 1 min 21 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Fixed in LibreOffice Portable 6.0.1 Rev 2

This is fixed in LibreOffice Portable 6.0.1 Rev 2 which has just been posted. Platform users with 6.0.1 already installer will get a small quick-install patch similar to the above automatically.

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments