You are here

GNU Octave Portable 5.1.0 Development Test 1

48 posts / 0 new
Last post
WacksBaby
Offline
Last seen: 2 years 10 months ago
Joined: 2007-07-22 19:02
GNU Octave Portable 5.1.0 Development Test 1

Application: GNU Octave Portable 5.1.0 Development Test 1
Category: Education
Description: GNU Octave is a high-level language, primarily intended for numerical computations. It provides a convenient command line interface for solving linear and nonlinear problems numerically, and for performing other numerical experiments using a language that is mostly compatible with Matlab.

Download 32/64-bit GNU Octave Portable 5.1.0 Development Test 1 [495MB download]
(MD5: d951377787cf2e229ef1a56b7a30aa8f)

Project on SourceForge / Fossil

Release Notes:

5.1.0 Development Test 1 (2019-08-02): Updated base app + combined both 32-bit and 64-bit in a single installer
4.4.1 Development Test 1 (2018-09-19): Updated base app
4.4.0 Development Test 4 (2018-08-08): Added BLAS Library Switcher
4.4.0 Development Test 3 (2018-07-30): Added optional install for Octave packages
4.4.0 Development Test 2 (2018-07-28): Bug fixed, detailed changes here
4.4.0 Development Test 1 (2018-07-27): Initial release

Drazick
Offline
Last seen: 1 day 32 min ago
Joined: 2010-09-06 06:36
Great!

Thank you for offering Octave in Portable Mode.

Any chance you share the file in GitHub?
For instance have a look on Micehal Wayne projects:
https://github.com/2wayne

WacksBaby
Offline
Last seen: 2 years 10 months ago
Joined: 2007-07-22 19:02
Source repository

Hi, all of my projects are currently using self-hosted repository.

You can find the source files here.

WacksBaby
Offline
Last seen: 2 years 10 months ago
Joined: 2007-07-22 19:02
Update

GNU Octave Portable 4.4.0 Development Test 2 Update

Bug fixed: Octave packages not loading using:

pkg load package_name
Gord Caswell
Gord Caswell's picture
Offline
Last seen: 23 hours 21 min ago
DeveloperModerator
Joined: 2008-07-24 18:46
Update first post

Please update your first post, rather than posting a link in the comments.

WacksBaby
Offline
Last seen: 2 years 10 months ago
Joined: 2007-07-22 19:02
Thanks

First post updated.

Unknown123
Offline
Last seen: 1 year 3 months ago
Joined: 2016-06-23 04:38
An advice

I think it would be better and convenient if there are two version, one without package (the current one), and the other one with all of the maintained package pre-installed. So that I don't need to install it manually.
https://octave.sourceforge.io/packages.php

Thank you for your hard work, I really appreciate it!

Drazick
Offline
Last seen: 1 day 32 min ago
Joined: 2010-09-06 06:36
Totally Agree

I also think this is a great idea.

WacksBaby
Offline
Last seen: 2 years 10 months ago
Joined: 2007-07-22 19:02
Updated to Dev Test 3

Currently there are 45 packages preinstalled which occupies ~25MB. Considering the installed size of ~1.2GB, the ~25MB may not be worth to remove. To keep things simple I will make these packages as an option during installation.

Package updated to Dev Test 3.

Unknown123
Offline
Last seen: 1 year 3 months ago
Joined: 2016-06-23 04:38
An option is also a wise

An option is also a wise choice! I like it!

btw, why only 45? There are 68 maintained package which consists of 48 community and 20 external

WacksBaby
Offline
Last seen: 2 years 10 months ago
Joined: 2007-07-22 19:02
Default packages

The 45 packages is the default I guess someone have decided that those 45 on the list are the most useful ones.

Here is the list of packages not included (as of July 2018) by default:
bim, BSLTL , cgi, divand, doctest, econometrics, fem-fenics, fpl, image-acquisition, level-set, mpi, msh, mvn, ncarray, octclip, octproj, optics, parallel, secs1d, secs2d, secs3d, sparsersb, symbolic, vibes, vrml

I would say that the important ones are already included plus the following:
bim, bsltl, cgi, divand, econometrics, fem-fenics, image-acquisition, mpi, msh, mvn, ncarray (maybe replaced by netcdf), optics, parallel, symbolic.

I can include these additional packages but it does take some time to compile them.

John T. Haller
John T. Haller's picture
Offline
Last seen: 6 hours 57 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
No Need

There is no need to make it an option. We only do that when a large percentage of the install size is optional.

Sometimes, the impossible can become possible, if you're awesome!

tal
Offline
Last seen: 1 month 2 weeks ago
Developer
Joined: 2009-08-07 07:34
It working greate!!!

It working greate!!! Smile
Thanks!! Smile

tal
Offline
Last seen: 1 month 2 weeks ago
Developer
Joined: 2009-08-07 07:34
GNU Octave with java

This version does not recognize the java on the computer.
Can you recognize it with portable Java we have here? or regular Java.

https://octave.org/doc/v4.0.0/How-to-make-Java-classes-available_003f.html

This is 64bit version?
Thank you for your time and help.

WacksBaby
Offline
Last seen: 2 years 10 months ago
Joined: 2007-07-22 19:02
The packaged version does not use Java

The packaged version does not use Java at all. I will have a look and see if Java can be recognized when I find some time.
This is a 32-bit version of GNU Octave. Including the 64-bit part will probably double the size of the installed package but it might also be useful since there might be performance benefits when doing mathematical processing in 64-bit as compared to 32-bit.

tal
Offline
Last seen: 1 month 2 weeks ago
Developer
Joined: 2009-08-07 07:34
32bit Gnu Octave is not working with 64bit JAVA

32bit Gnu Octave is not working with 64bit JAVA.
Most of this day use is 64 bit Java, there for, Can you make only 64bit version of gnu octave?
because when you mix it, it doesn't choose correctly the architect.

Thank you for your work and your time. this is amazing.

Drazick
Offline
Last seen: 1 day 32 min ago
Joined: 2010-09-06 06:36
64 Bit Is a Must

We really need 64 Bit Version.

Storage isn't an issue in our days.
Moreover for scientific computing 64 Bit is a must.

Could we also have a 64 Bit version?

By the way, Ocatve is shipped with OpenBLAS which isn't enabled by default yet it is order of magnitude faster than the default BLAS library in Octave.
I can tell you how to enable it if you want your Octave to be faster out of the box.

tal
Offline
Last seen: 1 month 2 weeks ago
Developer
Joined: 2009-08-07 07:34
Can you tell me how to enable?

Can you tell me how to enable?

Drazick
Offline
Last seen: 1 day 32 min ago
Joined: 2010-09-06 06:36
Replace the Reference BLAS Library with OpenBLAS in Octave

Got to the bin folder of Ocatve.

In it you'll find 3 DLL files named:
* libblas.dll - The BLAS Library used by Octave.
* libopenblas.dll - The OpenBLAS Library.
* librefblas.dll - The Reference BLAS Library of Octave.

By default, libblas.dll = librefblas.dll.
In order to use OpenBLAS instead of the Reference what you need to do is:
1. Delete libblas.dll.
2. Make a copy of libopenblas.dll.
3. Rename the file of (2) to libblas.dll.
4. Restart Octave and enjoy the enhanced performance.

WacksBaby
Offline
Last seen: 2 years 10 months ago
Joined: 2007-07-22 19:02
OpenBLAS

No need. The GNU Octave Portable installer is already configured to use OpenBLAS library as a default.

Drazick
Offline
Last seen: 1 day 32 min ago
Joined: 2010-09-06 06:36
Virus Scan Results

I scanned the GNU Octave Portable 4.4.0 Development Test 3 for virus using VirusTotal:

https://www.virustotal.com/#/file/b7a448f7c9ff141846738b83c7a6b0d300d7bd...

Looks clean.

Regarding OpenBLAS.
You indeed use something bigger than the Reference BLAS but while the OpenBLAS library in the Official Octave 4.4 ZIP is ~26 [MB] the one supplied in yours is only ~11 [MB].
I guess it might be because yours it 32 Bit.

Could you release 64 Bit version?
32 Bit is a joke and I think today it is not needed for modern scientific computing (For instance MATLAB doesn't support 32 Bit for a long time).

WacksBaby
Offline
Last seen: 2 years 10 months ago
Joined: 2007-07-22 19:02
Added BLAS Library Switcher

Updated to GNU Octave Portable 4.4.0 Development Test 4

I will make a 64-bit on the next release when I switch a build machine. My 512GB SSD is full especially when you have installed with Visual Studio, LabVIEW, AutoCAD and other CAD programs. Building these portable apps requires 3x the installed size.

Drazick
Offline
Last seen: 1 day 32 min ago
Joined: 2010-09-06 06:36
Looking Forward for the 64 Bit Version

Looking Forward for the 64 Bit Version.

Thank you for your efforts.
I hope one day it will replace FreeMat in the Official Suite.

WacksBaby
Offline
Last seen: 2 years 10 months ago
Joined: 2007-07-22 19:02
64-bit initial release

I have uploaded an experimental 64-bit version. You just have to install the optional 64-bit bit of GNU Octave if you want to use the 64-bit edition. This will install both 32-bit and 64-bit.

Download GNUOctavePortable_4.4.0_x86_64_Development_Test_1.paf.exe (MD5: fea72738e386ebab20c37ae2ddb974d4)

Drazick
Offline
Last seen: 1 day 32 min ago
Joined: 2010-09-06 06:36
64 Bit Only

Could we have a version of 64 Bit only?

I really don't see use cases for Octave on 32 Bit System.

WacksBaby
Offline
Last seen: 2 years 10 months ago
Joined: 2007-07-22 19:02
For 64-bit only workaround

I for one still use a 32-bit build and development system for my software development. This is not because I do not have a 64-bit machine but because the available software utilities that I require is only available in 32-bit versions which is why there is no point for me to switch my build system to 64-bit. I also use 32-bit system to build and cross-compile 64-bit software.

I will create an installer that is either 32-bit or 64-bit only support for GNU Octave but for now if you only require the 64-bit version the best I can suggest is install with the 64-bit option selected which will also install the 32-bit version (PortableApps installer still have limited option regarding this so I have to create a separate installer for this). You can then just delete the App\Octave32 directory if you are really sure you will never use the PortableApp in a 32-bit system. This will not affect the functionality but then the launcher will complain if you ever to run the PortableApp in a 32-bit system.

Drazick
Offline
Last seen: 1 day 32 min ago
Joined: 2010-09-06 06:36
64 Bit as Default, 32 Bit as Optional

I can see some people working in 32 Bit.
I meant I don't think anyone use Octave for real on 32 Bit System in modern workflow.
I might be wrong, but given MathWorks dropped 32 Bit support for MATLAB a year ago I guess this is reality.

The problem is downloading huge files.
Especially when there is no "Resume" option in case the connection dropped.

Moreover, I would set the default to install 64 Bit and 32 Bit will be on demand.

Thank you for your effort.
It would be nice to also have Julia Pro MKL (Once version 1.x.xxx is out) as PortableApp.

Olivher
Offline
Last seen: 3 years 10 months ago
Joined: 2018-08-22 20:19
I greatly appreciate the work

I greatly appreciate the work you do to bring this development and share it with everyone, excuse my English I am using a translator, would like to know how I install portable software on a USB device? I am new in these subjects but I am very interested in learning, thanks in advance friend

WacksBaby
Offline
Last seen: 2 years 10 months ago
Joined: 2007-07-22 19:02
Just run the installer

Just run the installer and change the drive letter to match your USB drive. Another way would be is to use the PortableApps.com menu. Install the PortableApps.com Platform. After installing the Platform you can either run the GNU Octave portable installer and it will find the USB drive or from the PortableApps menu, click on Apps and click on Install a New App.

Olivher
Offline
Last seen: 3 years 10 months ago
Joined: 2018-08-22 20:19
Thank you very much friend!

Thank you very much friend! What a surprise to have an answer so soon, you do an excellent job and we appreciate it!

tal
Offline
Last seen: 1 month 2 weeks ago
Developer
Joined: 2009-08-07 07:34
Java is working!

That great,
the java is working on 64bit version!
can you make it the default download version!
I like it a lot! thanks! Smile

WacksBaby
Offline
Last seen: 2 years 10 months ago
Joined: 2007-07-22 19:02
64-bit JRE

It could be that you have installed a 64-bit JRE/JDK instead of 32-bit that is why it wasn't working with 32-bit Octave. I will make the 64-bit version default and make the 32-bit as an option on the next dev release.

SolarPortable
Offline
Last seen: 3 years 10 months ago
Joined: 2018-08-20 08:48
Thanks a lot for the work! I

Thanks a lot for the work! I'm donwloading it right now and will report back if I encounter any problems Smile

WacksBaby
Offline
Last seen: 2 years 10 months ago
Joined: 2007-07-22 19:02
64-bit update

The 64-bit installer will now default to install the 64-bit version of GNU Octave but still gives you an option to install 32-bit.

GNUOctavePortable_4.4.0_x86_64_Development_Test_1A.paf.exe

Drazick
Offline
Last seen: 1 day 32 min ago
Joined: 2010-09-06 06:36
Great!

This is great!

Could you, as Tal suggested, release version 5 and update the first post?

Also, Is there a way to employ higher level of compression?
VirusTotal won't accept files larger than 256MB.

WacksBaby
Offline
Last seen: 2 years 10 months ago
Joined: 2007-07-22 19:02
Updated to 4.4.1 Development Test 1

Updated to 4.4.1 Development Test 1. Separate GNUOctavePortable for 32-bit and GNUOctavePortable64 for 64-bit. The installer by default is already using the highest level of compression. There is an increase of installation size for every GNU Octave release. Once it hits the limit of the PortableInstaller I will need to use a different software packager.

tal
Offline
Last seen: 1 month 2 weeks ago
Developer
Joined: 2009-08-07 07:34
Thank You!

Thank you for your time and effort!
Can you make it 4.4.0 Development Test 5 and update the post?

WacksBaby
Offline
Last seen: 2 years 10 months ago
Joined: 2007-07-22 19:02
Updated to 4.4.1 Development Test 1

Updated to 4.4.1 Development Test 1. Separate GNUOctavePortable for 32-bit and GNUOctavePortable64 for 64-bit.

WacksBaby
Offline
Last seen: 2 years 10 months ago
Joined: 2007-07-22 19:02
Updated to GNU Octave 4.4.1

Updated base app to GNU Octave 4.4.1. A separate installation file for 32-bit and 64-bit system is provided.

Drazick
Offline
Last seen: 1 day 32 min ago
Joined: 2010-09-06 06:36
Update the First Post with 64 Bit Links as Well

Great!

Could you please update the first post to include link to the 64 Bit version as well (https://sourceforge.net/projects/octave-portable/files/4.4.1/GNUOctavePo...)?

I also did a VirusTotal test on the 64 Bit version:
https://www.virustotal.com/#/file/3a203f848ac56e71bf6878d777fb8fbade598c...

Looks good.

Thank You.

tal
Offline
Last seen: 1 month 2 weeks ago
Developer
Joined: 2009-08-07 07:34
add exe in the end of extension file of 64bit file version

add exe in the end of extension file of 64bit file version

Drazick
Offline
Last seen: 1 day 32 min ago
Joined: 2010-09-06 06:36
Octave 5.1 Is Out

Octave 5.1 Is Out.
Any chance for update?

WacksBaby
Offline
Last seen: 2 years 10 months ago
Joined: 2007-07-22 19:02
Updated to GNU Octave 5.1.0

I have been very busy for the past few months. With the family moving overseas I am trying to fit it in my day job. Coding wise there are a lot of changes in 5.1 from the previous version. I have automated my build scripts so that it would be less iwork in the future. The 5.1 release combines both 32-bit and 64-bit in a single installer. I will try to update the main post once I find time. My website will also go offline for a few months until I moved in to another location.

The download size have doubled but the installation size for the 64-bit is about 200MB less than the previous version. The installation of the BLAS Library Switcher is also optional but included in the default installation. The installer will add a separate menu entry for the Library Switcher when installed.

tal
Offline
Last seen: 1 month 2 weeks ago
Developer
Joined: 2009-08-07 07:34
Update for 5.2

Please update for 5.2
Please make a regular install and not custom installer.
Make install will install both 32 and 64 bit version (user will not choose) and open the correct version depends on pc version.
if gui is not open, you can do this:
"%SYSTEMROOT%\system32\wscript.exe" octave.vbs --force-gui
Thanks for your great job.

Drazick
Offline
Last seen: 1 day 32 min ago
Joined: 2010-09-06 06:36
32 + 64 Bit Are Bad In My Opinion

Why install both 32 Bit + 64 Bit? It will cause the installation file to be ~2 times bigger.
If you want you can install both on the same USB.

John T. Haller
John T. Haller's picture
Offline
Last seen: 6 hours 57 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Standard Policy

As you know, it's standard practice to do dual mode apps here.

Sometimes, the impossible can become possible, if you're awesome!

Drazick
Offline
Last seen: 1 day 32 min ago
Joined: 2010-09-06 06:36
Well, Is Octave Official?

I wish Octave was official, then it would be a small price to pay in order to get it :-).

I know you set this policy. You have explained why you think it is good.
I still think a better policy, even according to your reasoning, would be having 32 Bit as default and 64 Bit for advanced users to chose.

Then those who are not familiar with 32 / 64 but or those who don't know which target will they meet can have 32 Bit and it will be the default while others will go with the official policy of Windows (Non ARM) - Move to 64 Bit, leave 32 Bit behind. You'll get performance and security. Who knows, maybe soon we won't see the "Virtual" 32 Bit Window on Windows installed by default (Long shot, but one can hope :-)).

But it is great anyone could have its own preferences.
Since it is your project, yours is the policy things happens according to.
But maybe one day I will be able to change your mind. If not, still nothing bad. PortableApps is great either way.

Unknown123
Offline
Last seen: 1 year 3 months ago
Joined: 2016-06-23 04:38
Please update the software

Hi WacksBaby, thank you for your hard work making this software portable

There's a new update, octave-5.2.0_1
https://www.gnu.org/software/octave/download.html

And also, I see there are already 46 package installed after I run "pkg rebuild" then "pkg list"
Meanwhile, there are 50 Maintained Package and 21 External Packages on the octave page.
https://octave.sourceforge.io/packages.php

if you don't mind, I would like to ask you to include all of them instead, so that we don't need to install and update it again manually later on.
Thank you so much.

Log in or register to post comments