You are here

Upgrade from 38.5

7 posts / 0 new
Last post
upchuck
Offline
Last seen: 3 years 11 months ago
Joined: 2007-11-19 19:05
Upgrade from 38.5

I need to update my Thunderbird as described in the title. I tried upgrading directly to 60.2.1 but the upgrade did not go over the existing program. Instead, it wanted me to 'create a new account.'

How can I get from 38.5 to 60.2 and keep my existing settings, emails, etc?

Abraxian
Offline
Last seen: 1 day 48 min ago
Joined: 2010-08-18 10:40
Best to Start Afresh

You are making a big jump going from v38.5 to v60.0+ also known as Thunderbird Quantum. Quantum is major revision of Thunderbird and will often not load old style addons or run old style addons correctly. For some details see https://blog.mozilla.org/thunderbird/2018/08/whats-new-in-thunderbird-60

Taking all that (jump) into account it is best to start with a completely fresh install and build up from there. At least for me, Quantum easily created my hotmail and yahoo accounts and I only had to do minor tweaking to them to get them to function in the way that wanted. If you want to preserve old emails etc. the you would be better directing you enquires to MozillaZine forums http://forums.mozillazine.org/index.php

Use Portable Apps on both Flash Drive and HDD/SSD.

upchuck
Offline
Last seen: 3 years 11 months ago
Joined: 2007-11-19 19:05
Upgrade from 38.5

I have no add ons so that is not an issue. But I have archived emails from 2001 - 2018 and that is a big deal from me. Am I understanding you correctly that there is NO easy upgrade path from 38.5? WOW.

upchuck
Offline
Last seen: 3 years 11 months ago
Joined: 2007-11-19 19:05
upgrade from 38.5

Sorry I left this out, quote, bolding mine: "Thunderbird version 60.0 is only offered as direct download from thunderbird.net and not as upgrade from Thunderbird version 52 or earlier. A future version 60.1 will provide updates from earlier versions." Source: https://www.thunderbird.net/en-US/thunderbird/60.0/releasenotes/ Where is V60.1? Can't find it.

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 1 day 22 hours ago
DeveloperModerator
Joined: 2008-07-24 18:46
Non-existent

Thunderbird 60.1 is non-existent. According to here, both 60.1.0 and 60.2.0 were skipped.

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 1 day 22 hours ago
DeveloperModerator
Joined: 2008-07-24 18:46
This may work

The following may work for you, although as Mozilla state that version 60 does not upgrade earlier versions, it may not help at all.
From here, try upgrading to 45.8.0, then 52.9.1 prior to attempting to upgrade to 60.2.1.

AlexMail
Offline
Last seen: 2 years 9 months ago
Joined: 2018-05-08 01:35
Try the following

Back up a copy of your of existing Thunderbird profile. Download Thunderbird 60.2.1 from below:
https://portableapps.com/apps/internet/thunderbird_portable

Install it over your existing copy of Thunderbird 38.5 folder. All profile data, emails, settings, etc. should remain unchanged. I have tried it from Thunderbird 31 to 60.2.1 with no problems.

As Abraxian mentioned, if you have legacy add-ons, those add-ons may stop working. See below for more info on add-ons/extensions compatibility:
https://www.ghacks.net/2018/07/06/thunderbird-60-extension-and-theme-cha...
https://wiki.mozilla.org/Thunderbird/Add-ons_Guide_57

Log in or register to post comments