You are here

GPG Plugin does not work in TB 60.5 :-(

10 posts / 0 new
Last post
ThirB
Offline
Last seen: 3 months 2 weeks ago
Joined: 2019-02-01 16:42
GPG Plugin does not work in TB 60.5 :-(

I installed the portable plugin to ThunderbirdPortable\App\gpg. But TB 60.5 always requests to Install GnuPG since Enigmail states that it is NOT INSTALLED? But it is.

What am i doing wrong??

John T. Haller
John T. Haller's picture
Online
Last seen: 32 min 22 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
New Version

You likely just need the new version released today. Enigmail will often lock out older versions.

Sometimes, the impossible can become possible, if you're awesome!

ThirB
Offline
Last seen: 3 months 2 weeks ago
Joined: 2019-02-01 16:42
Thanks for that really rapid

Thanks for that really rapid response Smile Smile !!!

ThirB
Offline
Last seen: 3 months 2 weeks ago
Joined: 2019-02-01 16:42
Oh, I'm afraid the issue is

Oh, I'm afraid the issue is still pending. Again I was told to install GnuPG Shock

John T. Haller
John T. Haller's picture
Online
Last seen: 32 min 22 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Location

I just noticed you're using the wrong location. You should install to:

X:\PortableApps\ThunderbirdPortable
X:\PortableApps\CommonFiles\GPG

X:\PortableApps can be whatever you want but the ThunderbirdPortable and CommonFile plugins need to be in that relative layout. That's the only way it's supported going forward.

The platform will handle this all for you including updates, of course.

Sometimes, the impossible can become possible, if you're awesome!

ThirB
Offline
Last seen: 3 months 2 weeks ago
Joined: 2019-02-01 16:42
I'm afraid this doesn't help.

I'm afraid this doesn't help. It doesn't matter whether I installed GPG to PA\ThunderbirdPortable\App\gpg or to PA\CommonFiles\GPG. Thunderbird alway tells me: "To use Enigmail/PEP GnuPG is required. Please install." [my translation from German]

I got the "\ThunderbirdPortable\App\gpg" advice from this manual:

https://portableapps.com/support/thunderbird_portable#encryption

John T. Haller
John T. Haller's picture
Online
Last seen: 32 min 22 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Check prefs.js

Could you please close Thunderbird Portable, ensure it closes in task manager. And then ensure that the GPG Key Agent and pep-json-server.exe are also closed in task manager. You could also just reboot and not start either to be sure.

At that point, explore to PA\ThunderbirdPortable\Data\profile and make a backup copy of prefs.js. Open the file in Notepad++ Portable or your favorite text editor. Scroll down until you see user_pref("extensions.enigmail.... There should be an entry for user_pref("extensions.enigmail.configuredVersion", "2.0.9"); After that, if it is not present, please add the entry: user_pref("extensions.enigmail.juniorMode", 0);

In my testing, enigmail doesn't always add this and it appears to be required.

Sometimes, the impossible can become possible, if you're awesome!

ThirB
Offline
Last seen: 3 months 2 weeks ago
Joined: 2019-02-01 16:42
Hi John,

Hi John,

your setting leads to disableing of PEP, right? Thunderbird starts without issues, but when I activated PEP again, I got the same error :-(.

John T. Haller
John T. Haller's picture
Online
Last seen: 32 min 22 sec ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
PEP

I can't get PEP working locally or portably. It appears to be what's messing things up for portable use entirely. It also has a habit of getting stuck running and only killing it in Task Manager stops it.

Sometimes, the impossible can become possible, if you're awesome!

ThirB
Offline
Last seen: 3 months 2 weeks ago
Joined: 2019-02-01 16:42
Help from the PEP guys?

Hi John,

thanks a lot for your help! Since PEP is REALLY very nice Smile I started a thread in the PEP community:

https://pep.community/t/pep-has-problems-with-thunderbird-portable/43/

Maybe the solution would be very simple with some support of the PEP team? It would be so nice to have a portable version of ThunderBird with PEP support. PEP is really very easy to use and would help to introduce the subject of encryption to many people.

Log in or register to post comments