You are here

[Solved] appicon.ico only show the grey arrow

3 posts / 0 new
Last post
Makazzz
Makazzz's picture
Offline
Last seen: 2 years 1 month ago
Joined: 2019-04-30 15:58
[Solved] appicon.ico only show the grey arrow

When I am creating a new app in the Portableapps.com Format I extract this archive PortableApps.com_Application_Template_3.5.2.zip for begining the work. But when I create a new icon for the app and rename it appicon.ico and delete the old one it is reverting for the AppName one (with the arrow)... But only the preview become the logo of Portableapps and when I change a parent folder name's; it is becoming the real logo preview. Its like windows or something else keep a link to this file when I extract the file. Then I tried to clear icon cache with Disk Cleanup from Windows 10 but it dosn't work. So only when the ico is in AppName/App/AppInfo folder (and with the same parent folder) it is reverting the preview to the one proposed.

John T. Haller
John T. Haller's picture
Offline
Last seen: 1 hour 27 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Windows caching

This is Windows caching icons and not anything to do with the app or ICO file. Manually clearing the icon cache via deleting the IconCache.db and then rebooting is the nuclear option to ensure it refreshes. It doesn't matter, really, though as the icon is the new one and you're just looking at Windows Explorer's preview based on the icon cache.

Sometimes, the impossible can become possible, if you're awesome!

Makazzz
Makazzz's picture
Offline
Last seen: 2 years 1 month ago
Joined: 2019-04-30 15:58
Thanks!

Thank you, I did follow this tutorial and now its normal

Portabilizing application... 14 at the moment

Log in or register to post comments