I need some help for Linux again!
I built the latest version of GLib from source, but ATK is confused when I try to configure it. Problem is, I had an old version of GLib I got via apt-get when I built the newer version, and there are 82 programs that depend on it, so removing it and rebuilding the new version isn't really an option. KPackage sees the current version as 2.6.4-1, but I built version 2.12.11 from source.
I get this when I try to configure ATK:
checking for GLIB - version >= 2.5.7... *** 'pkg-config --modversion glib-2.0' returned 2.12.11, but GLIB (2.6.4) *** was found! If pkg-config was correct, then it is best *** to remove the old version of GLib. You may also be able to fix the error *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing *** /etc/ld.so.conf. Make sure you have run ldconfig if that is *** required on your system. *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH *** to point to the correct configuration files no configure: error: *** GLIB 2.5.7 or better is required. The latest version of *** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed *** but not in the same location as pkg-config add the location of the file *** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.
I had no problem building glibmm (which depends on glib).
[Moderator RM fixed your <code> tags; remember, it's <pre>]