You are here

I need Calibre 4.23

2 posts / 0 new
Last post
AmberNayseyAlexander
Offline
Last seen: 1 year 10 months ago
Joined: 2020-12-01 14:38
I need Calibre 4.23

I was wondering if I may redownload Calibre 4.23 Portable because the DeDRM tool doesn't work in higher versions? Please help.

John T. Haller
John T. Haller's picture
Online
Last seen: 53 min 18 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
SourceForge Project

You can get previous versions of our open source apps from our SourceForge project. Here's the calibre section: https://sourceforge.net/projects/portableapps/files/calibre%20Portable/

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments