You are here

Themes not working with pFF

6 posts / 0 new
Last post
costnowt
Offline
Last seen: 5 years 5 months ago
Joined: 2007-02-10 06:44
Themes not working with pFF

Hi! I'm aware that answers have ostensibly been given in this forum to the question I'm about to ask but having tried the suggestions I'm still stuck, so here goes. I too am having problems getting my themes to work for my pFF.

I download one from addons.mozilla.com, it will show up in 'All-in-One Sidebar' with a message to restart Firefox to complete installation. I then click 'Use Theme', again I am invited to restart, which I do and I'm still left with the default theme.

I've performed the 'cache' fix suggested in the known issues to no avail. I'm not quite sure how to perform FILE and then OPEN on XPIs?

I've checked the profile folder on my flash disk, not quit sure what I'm looking for but non of the installed themes appear to be there?

I don't have any problems getting Extensions to run.

I am running FF 2.0.0.3

Hope you don't thin I am being lazy with this, as I have spent some time searching round the forums. Any help greatly appreciated as this is driving me nuts?

Thx
Paul

John T. Haller
John T. Haller's picture
Offline
Last seen: 8 hours 2 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Save them

Save the XPI locally by right-clicking on it, just as you would any other file. Then just click File - Open in Firefox and open it. Or drag it onto the Add-Ons - Themes window when it's open.

Sometimes, the impossible can become possible, if you're awesome!

costnowt
Offline
Last seen: 5 years 5 months ago
Joined: 2007-02-10 06:44
Hi! Thx for the quick

Hi! Thx for the quick reply.I don't know if I made myself very clear before but it's FF themes that I'm having trouble with as opposed to extensions which are fine. Am I right in saying that the 'Jar' theme files are different to 'XPI's' and that opening them through the file menu won't work? I tried this and got the error message:

Java Virtual Machine Launcher

Invalid or corrupt jarfile C:\...

I then tried dragging the jarfile to the open themes window with exactly the same results as trying to install them directly through 'addons.mozilla.com'.

I checked the profile folder on my flash disk and still non of the installed themes appear to be there? Think this maybe significant?

For the record, the themes I have been trying to use are Blue Ice 1.2.4, Noia 2.0 (eXtreme) 3.371, AeroFox Basic 1.9.5. Does anyone know if there are specific compatibility issues with these particular themes or am I doing something else wrong?

Thx again

wsm23
Offline
Last seen: 12 years 5 months ago
Joined: 2006-01-09 22:05
Mr Tech.

You don't have to do it this way. It is just a suggestion.

First I would use Mr Tech's Local Install. It streamlines installation if .xpi and .jar files.

Then after you have your themes downloaded to your hard drive or flash drive(not installed yet, download them separately), go to Tools > Extensions(Add-Ons) > Install. You should be able to browse to the theme you want to install.

I know you should be able to install the files with File > Open File in FF itself, but I have never had much luck with that. I also have had some trouble with just clicking on the files to install.

Hope that helps.

--
Life is about the journey not the destination!

My site * My Blog

The Kazoo Spartan

Life is about the journey not the destination!

The Kazoo Spartan

costnowt
Offline
Last seen: 5 years 5 months ago
Joined: 2007-02-10 06:44
Mr Tech suggestion implemented

Hi! Thx for the response. I did as was suggested but still no joy, the result is the same as in my first post.

Any more suggestions greatly appreciated.

amysu88
Offline
Last seen: 17 years 3 months ago
Joined: 2007-04-10 23:21
I'm having the same problem

I'm having the same problem only I have saved the extensions on my pc and opened them through the File option. When I go into extensions the ones that I downloaded to pc say they'll be "updated" when I restart Firefox and the others I installed straight from the web say they'll be "installed" when I restart Firefox but after many restarts nothing has changed and none of the extensions will work. Any ideas and/or suggestions would be greatly appreciated.

Log in or register to post comments