You are here

Dictionaries with Thunderbird_Portable_2.0_RC1

4 posts / 0 new
Last post
muzzae
Offline
Last seen: 16 years 10 months ago
Joined: 2007-04-11 19:38
Dictionaries with Thunderbird_Portable_2.0_RC1

Unable to install british_english_dictionary-1.19-fx+zm+tb.xpi into TBP 2.0 RC1
Error Message:- Incompatible Extension. British English Dictionary 1.19 could not be installed because it is not compatible with Thunderbird 2.0.0.0. (British English Dictionary 1.19 will only work with Thunderbird versions from 2.0a1 to 2.0b1)

The Australian Dictionary english_australian_dictionary-0.2-fx+zm+tb.xpi installs okay.

John T. Haller
John T. Haller's picture
Offline
Last seen: 6 hours 37 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
And?

This just means they haven't updated it to work with RC1 yet. Not surprising as localization stuff is often out of sync until the final release.

Sometimes, the impossible can become possible, if you're awesome!

shark007
Offline
Last seen: 16 years 10 months ago
Joined: 2007-01-08 06:18
same in German

It's all the same with the German dictionary atm. Hope this can be updated soon.

rtrout
Offline
Last seen: 16 years 10 months ago
Joined: 2006-07-31 21:17
You can easily modify the .xpi

I hacked the dictionary file myself. Here's how:

1. Open the XPI in a zip tools (7-Zip, winzip etc)
2. Open install.rdf in your favourite editor
3. Change the maxVersion attributes to 2.0.* (there's 3 - I just changed them all)
4. Update the XPI with the modified install.rdf

Note: if/when someone updates the XPI properly, the version number should be changed, and Automatic Updates will send you a new version (without the hacks).

Hope this helps.

Log in or register to post comments