You are here

Standalone Installation -- No apps working

4 posts / 0 new
Last post
martin-z
Offline
Last seen: 9 months 4 weeks ago
Joined: 2023-04-15 17:50
Standalone Installation -- No apps working
Summary

Hi, I wanted to double-check my understanding of the portableapps.com standalone installation / usage as there were a few apps I was interested in using, but I downloaded 2 as a test and neither work - so either I've mis-understood something or there are some issues!

Summary tech info:

  • O/S: Windows 11 (Pro)
  • Download location: D:\Downloads\PortableApps.com[Application]
  • App 1: PDF-XChangeEditor
  • App 2: SSD-Z
Standalone Installation Process
  1. I browsed the list of available apps online

  2. Clicked on the app, which took me to a page like this one for PDF-XChangeEditor

  3. Clicked the large, green download from portableapps.com button

> NOTE The support page says: "just click the Download button from the application's page. You'll see a SourceForge download page that automatically selects a download server close to you and redirects you to the download."

  1. However, in my case I was taken to a portableapps.com page

  2. I downloaded the .exe file to D:\Downloads

  3. Double-clicked the PDF-XChangeEditorPortable_9.5.368.0.paf.exe installer and chose the folder where to extract the files, in my case ```D:\Downloads\PortableApps.com\PDF-XChangeEditorPortable``

> NOTE The support page says to: "If you're running it standalone, browse to the directory you installed the AppNamePortable directory you installed to and then double-click the AppNamePortable.exe file. Then, just use the app as you'd use the regular version.

  1. However, in my case when I try to run D:\Downloads\PortableApps.com\PDF-XChangeEditorPortable\PDF-XChangeEditorPortable.exe, the app crashes immediately with the following error: "The application was unable to start correctly (Oxc000007b). Click OK to close the application,"

  2. When I tried to run "D:\Downloads\PortableApps.com\SSD-ZPortable\SSD-ZPortable.exe" as a second test, this does not even open! -- I get a UAC prompt (which I approve) however nothing then appears and I can't detect the app running in task manager

Assistance would be great
  • 100% failure rate is unusual so I'm assuming either portableapps.com bundling / repackaging process has some major issue, or I've missed something in the instructions / am doing something wrong
  • I don't want to use the portableapps.com platform (and even on the portableapps.com support pages, it makes it clear that this isn't necessary and standalone running of apps is supported)
  • If someone can please advise what's going wrong I would be very grateful, thanks in advance
Markdown/Formatting Note

When checking the preview before posting, this page did not look right at all, however I copied into into an external markdown validator and it confirmed all the formatting was correct and the page looked fine there... So if this page reads very badly, I'm sorry, I tried but must be a portableapps.com issue.

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 58 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Did you turn on mandatory ASLR?

If you turned on mandatory ASLR within Windows Security, it'll break quite a few Windows executables and they'll throw an error like that. Many of our launchers will have that issue as they are NSIS2 based.

Sometimes, the impossible can become possible, if you're awesome!

martin-z
Offline
Last seen: 9 months 4 weeks ago
Joined: 2023-04-15 17:50
Thanks, that helped!

I did (or at least it is "on by default")

I created an exception for PDF-XChangeEditorPortable.exe and was pleasantly surprised† to see that the app opened fine -- thanks!

Sadly though, this trick did not work for SSD-ZPortable.exe do you know what else could be interfering with this? (I checked my security settings and all exploit preventions are turned currently on)

I appreciate your advise about this causing problems for several apps but just from my own experience I have over 90 apps I use portably (in their native portable version) and never experienced this issue before so was sceptical this would work, but don't get me wrong am very happy to be proved wrong in this case! #alwayslearning

John T. Haller
John T. Haller's picture
Offline
Last seen: 3 hours 58 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
ASLR Is Off By Default, Another Changed Setting

Mandatory ASLR is always off by default on Windows 10 and 11 because it breaks stuff unless you installed it as part of an company/university with an image that specifically turns it on.

Only the ASLR setting will interfere with all apps based on the NSIS2 PA.c Launcher to my knowledge. So, the SSD-ZPortable.exe launcher should be fine. I'm guessing another security setting you turned on is interfering with SSD-Z itself. You can check by opening up the SSD-ZPortable\App\SSD-Z directory and running SSD-Z.exe directly.

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments