You are here

Weird Multiple Instances Problem

2 posts / 0 new
Last post
An Unused Username
Offline
Last seen: 2 weeks 6 days ago
Joined: 2021-06-16 10:23
Weird Multiple Instances Problem

For years I've been running multiple instances of Firefox portable with no problem. As of version 119.0, I've run into an odd situation... if any other instance (BTW all instances are the same portable version) is launched after the primary instance (the one I always have running) it just opens another window of the same primary instance. Which is obviously a problem because the primary instance is the one always running. However, if I launch one of my secondary Firefox portables first (ones I only use ocassionally), then my primary one will launch as it should. However, this isn't an practical workaround for obvious reasons. I'm baffled why this is happening since:

a) they're all the same exact Firefox portable version, even updated using the same updater file
and
b) they're all using the same exact FirefoxPortable.ini containing:
[FirefoxPortable]
FirefoxDirectory=App\firefox
ProfileDirectory=Data\profile
SettingsDirectory=Data\settings
PluginsDirectory=Data\plugins
FirefoxExecutable=firefox.exe
AdditionalParameters=
LocalHomepage=
DisableSplashScreen=true
AllowMultipleInstances=true
DisableIntelligentStart=false
SkipCompregFix=false
RunLocally=false

Any idea how to resolve this new anomalous multiple instance behavior depending on which Firefox portable was launched first? Thanks!

John T. Haller
John T. Haller's picture
Online
Last seen: 19 min 54 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Known Issue

Known issue you can follow along with here: https://portableapps.com/node/69514

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments