You are here

GIMP Font issue

8 posts / 0 new
Last post
jsroot
Offline
Last seen: 15 years 4 months ago
Joined: 2008-12-06 15:34
GIMP Font issue

Hi all,

First off thanks for the awesome software. I can't live without it.

I am having a problem with GIMP Portable 2.6 on Vista. I must have at some time used a font that I no longer have. When I click on the Font tool on the toolbox an error pops up:

"Pango-ERROR **:Unable to open font file C:/Windows/fonts/DejaVuSans.ttf for font DejaVu Sans 16, exiting

aborting..."

I checked and the font is not in the directory.

Then the Microsoft Visual C++ Runtime Library says that the application has requested to terminate in an unusual way and GIMP (and my pretty pics) close without the ability to save.

How can I change the font that loads when I click on the font tool so I don't encounter this error?

In future versions, dear programmers, perhaps it could be made to ask for a different font on font load failure.

Thanks, jsroot

ceciliaFX
ceciliaFX's picture
Offline
Last seen: 1 month 1 week ago
Joined: 2007-04-24 14:18
if you go into your GIMP

if you go into your GIMP preferences/Folders/fonts

you can add a directory that you can keep fonts that are not accessed by windows, but GIMP can use them just fine....you can put this directory anywhere....

now, I use GIMP from my hard drive so it's easy to have a directory on my HD just for such fonts....

when you use GIMP from a flash drive and your removeable drive will sometimes get a different Letter then the solution is to use Fonts Portable

https://portableapps.com/node/16003

"No one man can terrorize a whole nation unless we are all his accomplices." - Edward R. Murrow

wyrdmaege
Offline
Last seen: 15 years 3 months ago
Joined: 2008-12-28 23:00
other solutions?

I've tried Portable Fonts, adding my font directory to gimp through the preferences dialog and I still can't get it to recognise new fonts unless I manually install into the C: font folder. I've read in other places where one could also install fonts into \GIMPPortable\App\gimp\etc\fonts and they would be recognized, but that's not working for me either.

Is there anything I haven't tried or anything I'm missing?

thx in advance,
WM

ceciliaFX
ceciliaFX's picture
Offline
Last seen: 1 month 1 week ago
Joined: 2007-04-24 14:18
First, I have only used True

First, I have only used True Type fonts with those techniques. Not sure if other type of fonts work. They might, I just don't know.

second, if GIMP seems to not see the new fonts, try deleting the files in GIMPPortable\Data\settings\fontconfig\cache

and restart GIMP. The new fonts should then be in the newly made list.

"No one man can terrorize a whole nation unless we are all his accomplices." - Edward R. Murrow

OliverK
OliverK's picture
Offline
Last seen: 2 years 9 months ago
Developer
Joined: 2007-03-27 15:21
You have to use the

You have to use the preferences to add the folder.

Too many lonely hearts in the real world
Too many bridges you can burn
Too many tables you can't turn
Don't wanna live my life in the real world

wyrdmaege
Offline
Last seen: 15 years 3 months ago
Joined: 2008-12-28 23:00
could it just be a vista issue?

The computer I was working on when I was having trouble was an Acer laptop w/Vista Home Edition. I've since tried the same procedures on two XP machines and not had a problem at all. Fortunately, the laptop isn't mine and I don't work on it often. Still, it's a PIA. Thanks for the suggestions, and until I or someone with much more experience figures out what the deal is, I'll stick to XP machines as much as possible.

ceciliaFX
ceciliaFX's picture
Offline
Last seen: 1 month 1 week ago
Joined: 2007-04-24 14:18
I have no access to Vista

I have no access to Vista (and I consider myself lucky I guess). only Windows 2000 and XP sometimes. You may very well have a point.

"No one man can terrorize a whole nation unless we are all his accomplices." - Edward R. Murrow

OliverK
OliverK's picture
Offline
Last seen: 2 years 9 months ago
Developer
Joined: 2007-03-27 15:21
Could be. Vista loads a

Could be. Vista loads a couple fonts on the GIMP very slowy. I have no clue why. It just does. You may try converting to pd1 or pd2 and then loading it.
Here's a opensource convertor: http://ttf2pt1.sourceforge.net/

You'll need to download some files, but it should b easy to get those. There is a windows binary available. Windows (XP) wouldn't load a ttf font, but covnerting it with this tool took care of the problem.

Too many lonely hearts in the real world
Too many bridges you can burn
Too many tables you can't turn
Don't wanna live my life in the real world

Log in or register to post comments