You are here

VistaSwitcher Portable 1.1.4 Dev Test 4

47 posts / 0 new
Last post
Pyromaniac
Pyromaniac's picture
Offline
Last seen: 7 years 7 months ago
Developer
Joined: 2008-09-30 19:18
VistaSwitcher Portable 1.1.4 Dev Test 4

App: VistaSwitcher
Category: Utilities
Description: from website VistaSwitcher is an elegant and powerful task management utility for Windows OS. Once installed, it replaces the default Windows Alt-Tab dialog with a nice box that shows a list of all running tasks, with their names and preview snapshots, and enables the user to take actions on them using the mouse and keyboard shortcuts. With just one click, you can switch tasks, minimize, maximize, restore the main window, or close the process.

Freeware: This software is freeware and is distributed with the permission of NTWind Software.

Download VistaSwitcher Portable 1.1.4 Dev Test 4
600 KB Download / 900 KB Installed
MD5: 02e68356170abe4031b6fe81157da239

Release Notes
December 1, 2011 - 1.1.4 DT4: Added language changes. Fixed compatibility issues on x64 machines. Removed x64 build.
November 30, 2011 - 1.1.4 DT3: Made some changes, hope this fixes some bugs on x64 machines.
November 28, 2011 - 1.1.4 DT2: Added 64-bit build.
November 25, 2011 - 1.1.4 DT1: Initial Release

depp.jones
Offline
Last seen: 1 hour 57 min ago
DeveloperTranslator
Joined: 2010-06-05 17:19
Nice app, simple and

Nice app, simple and efficient. I tested it and it came out clean - as expected. Wink (WinXP Sp3/admin)

I ran the validator and it shows two small quirks:
PortableApps.com Format validation failed with 2 errors and 1 warning.

Errors

  • appinfo.ini: [Details], required value AppID is missing
  • appinfo.ini: [Details], invalid value AppId

Warnings

  • File App\AppInfo\Launcher\splash.jpg is missing

Two further remarks:
- The PackageVersion in appinfo.ini is 1.1.4.01. That may eventually break automatic updating to an official release (if you plan to do so) that should get a PackageVersion 1.1.4.0. (But that's just cosmetics)
- Do you consider automatic language switching? Not that you encounter much text in daily usage...

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 7 years 7 months ago
Developer
Joined: 2008-09-30 19:18
good, good...

I wish that validator thing wasn't case sensitive. I also purposely excluded the splash.

As for the versioning, I'm thinking of having it as x.x.x.0[dev test number] for future apps (that recent spam attack reminded me of that old rant by Gord) and when they go official, they'll be x.x.x.1 (like first release), then x.x.x.2 for revisions and so on.

My only excuse for not doing language switching is that I didn't feel like doing it Blum

depp.jones
Offline
Last seen: 1 hour 57 min ago
DeveloperTranslator
Joined: 2010-06-05 17:19
...and when they go official,

...and when they go official, they'll be x.x.x.1 (like first release), then x.x.x.2 for revisions and so on.

Seems perfectly reasonable.:)
And language switching is obviously not the most important thing for this app. I had to search for any text anyway and found it in the preferences box. These settings normally need to be adjusted only once if ever... Biggrin

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 1 week 3 days ago
DeveloperModerator
Joined: 2008-07-24 18:46
Versioning though

One thing to be aware of is that x.x.x.0N is equal to x.x.x.N, hence why I decremented, especially in the case of four-part version numbers.

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 7 years 7 months ago
Developer
Joined: 2008-09-30 19:18
Blaspemy!!

Ok, then how's about this: all dev tests are x.x.x.0, then official releases are x.x.x.1 then revs with x.x.x.2?

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 1 week 3 days ago
DeveloperModerator
Joined: 2008-07-24 18:46
Your choice

AFAICT, that would work in this case, so long as the base app doesn't release 1.1.4.x.

However, I still recommend decrementing the version. But don't take that as a requirement. Smile

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 1 week 3 days ago
DeveloperModerator
Joined: 2008-07-24 18:46
Doesn't run on x64

As reported here, VistaSwitcher Portable doesn't run on x64. I have confirmed this on my own system as well. Looks like this is an app that requires x86_64 as well as x86.

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 7 years 7 months ago
Developer
Joined: 2008-09-30 19:18
Done and done

thanks for the heads up.

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 1 week 3 days ago
DeveloperModerator
Joined: 2008-07-24 18:46
WorkingDirectory? UAC?

I tried Dev Test 2 again, still not working for me. Could it need WorkingDirectory set? I'll try again on an x86 machine and let you know the results.

Can someone else test this on x64, to verify it's not just me?

[EDIT]

VistaSwitcher FAQ:
A: There is no portable version of VistaSwitcher and there are no plans for it to be released. On Windows 7 and Vista, VistaSwitcher must be installed in the system "Program Files" directory. This is concerned with the new security technology first introduced in Windows Vista. For more information, see User Account Control (UAC) and User Interface Privilege Isolation (UIPI).

The bold stuff is the pertinent stuff. This could be what's causing the issue.

It's also worth noting that i can run vswitch64.exe directly, so it's not a matter of the executable being corrupted or anything.

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 7 years 7 months ago
Developer
Joined: 2008-09-30 19:18
well,

I wish the developer told me before making it portable.

Should I call it quits, then, since it doesn't look like it can be made portable (by our standards?)

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 1 week 3 days ago
DeveloperModerator
Joined: 2008-07-24 18:46
Not necessarily

I was able to run vswitch64.exe directly from %PAL:AppDir%\VistaSwitcher\x64 and it ran with no issues, so it might be the UAC stuff.

In other words, that "must be installed to 'Program Files'" stuff is a load of BS.

Keep at it, this looks like a great app!

OLLI_S
Offline
Last seen: 1 month 7 hours ago
Joined: 2011-10-19 04:36
Not working on x64, working on x32

Hello,

the DevTest 2 is not working in Windows 7 Professional x64 SP1.
In Windows XP SP3 (x32) it is working normally.

In System Explorer (Win 7 System) I see that the process "VistaAwitcher" starts but is terminated at once.

Greetings

OLLI

sst
Offline
Last seen: 3 weeks 2 days ago
Translator
Joined: 2009-01-23 04:52
Please verify your ".dll" files

At my side the x64 version work.

Please verify ".dll" files = COMCTL32.dll.

sst
Offline
Last seen: 3 weeks 2 days ago
Translator
Joined: 2009-01-23 04:52
Must be option ProgramExecutable64

Please look at x86 x64 mame portable https://portableapps.com/node/27281

Launcher "VistaSwitcherPortable.ini"
Before =

[Launch]
ProgramExecutable=VistaSwitcher\x86\vswitch.exe
ProgramExecutable=VistaSwitcher\x64\vswitch64.exe

Must be ProgramExecutable64 =

[Launch]
ProgramExecutable=VistaSwitcher\x86\vswitch.exe
ProgramExecutable64=VistaSwitcher\x64\vswitch64.exe

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 1 week 3 days ago
DeveloperModerator
Joined: 2008-07-24 18:46
D'oh!

I didn't look closely at your launcher.ini

I've fixed that in mine, but still no luck. What DLL's are you referring to, sst?

Also, since the x86 and x64 directories are identical other than vswitch(64) and vsconfig(64), I recommend combining the directories in App\VistaSwitcher.

sst
Offline
Last seen: 3 weeks 2 days ago
Translator
Joined: 2009-01-23 04:52
I've fixed that in mine, but

>>> I've fixed that in mine, but still no luck. What DLL's are you referring to, sst?

Respond =

1)Update Launcher file "VistaSwitcherPortable.ini" with like below.
ProgramExecutable64=VistaSwitcher\x64\vswitch64.exe

2)After, you must compile with "PortableApps.com Launcher", to create the new VistaSwitcherPortable.exe file.

3) Replace the VistaSwitcherPortable.exe file, with the new compiled file, then now it will use automatic the x86 or x64 with match your OS.

Launcher "VistaSwitcherPortable.ini"

[Launch]
ProgramExecutable=VistaSwitcher\x86\vswitch.exe
ProgramExecutable64=VistaSwitcher\x64\vswitch64.exe
DirectoryMoveOK=yes
WaitForEXE1=vsconfig.exe
WaitForEXE2=vswitch.exe
WaitForEXE3=vsconfig64.exe
WaitForEXE4=vswitch64.exe

[Activate]
Registry=true

[RegistryKeys]
VistaSwitcher=HKCU\Software\Alexander Avdonin\VistaSwitcher

[RegistryCleanupIfEmpty]
1=HKCU\Software\Alexander Avdonin

[RegistryValueBackupDelete]
1=HKCU\Software\Microsoft\Windows\CurrentVersion\Run\VistaSwitcher

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 1 week 3 days ago
DeveloperModerator
Joined: 2008-07-24 18:46
Already done, still no go

sst,

As you can see below, I've already done that, as well as added language switching to the launcher, but it still doesn't load. I'm sure we can get this to work, as the app -does- run when started directly. There must be something else missing.

sst
Offline
Last seen: 3 weeks 2 days ago
Translator
Joined: 2009-01-23 04:52
Look at = Mamex86x64 Portable Lancher.

Look at = Mamex86x64 Portable Lancher

[Launch]
ProgramExecutable64=MAMEUI\MameUI64.exe
ProgramExecutable=MAMEUI\MameUI32.exe
WorkingDirectory=%PAL:AppDir%\MAMEUI
SinglePortableAppInstance=true
DirectoryMoveOK=yes

[FilesMove]
MAMEUI32.INI=%PAL:AppDir%\MAMEUI
MAMEUI64.INI=%PAL:AppDir%\MAMEUI

[FileWrite1]
Type=INI
File=%PAL:DataDir%\MAMEUI32.INI

[FileWrite2]
Type=INI
File=%PAL:DataDir%\MAMEUI64.INI

sst
Offline
Last seen: 3 weeks 2 days ago
Translator
Joined: 2009-01-23 04:52
Then now, ...

Then now, ...

Please add directory = DefaultData

Also, ... made directory "VistaSwitcher", without "x86, x64" sub-directory.
VistaSwitcher\vswitch.exe
VistaSwitcher\vswitch64.exe
VistaSwitcher\vsconfig.exe
VistaSwitcher\vsconfig64.exe

Also, edit file "VistaSwitcherPortable.ini"

[Launch]
ProgramExecutable64=VistaSwitcher\vswitch64.exe
ProgramExecutable=VistaSwitcher\vswitch.exe.exe
WorkingDirectory=%PAL:AppDir%\VistaSwitcher
SinglePortableAppInstance=true
DirectoryMoveOK=yes

[Activate]
Registry=true

[RegistryKeys]
VistaSwitcher=HKCU\Software\Alexander Avdonin\VistaSwitcher

[RegistryCleanupIfEmpty]
1=HKCU\Software\Alexander Avdonin

[RegistryValueBackupDelete]
1=HKCU\Software\Microsoft\Windows\CurrentVersion\Run\VistaSwitcher

After, ... recompile the launcher.

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 1 week 3 days ago
DeveloperModerator
Joined: 2008-07-24 18:46
Language Handling

I added language handling for you, as well as switching to App\VistaSwitcher like I've mentioned. Remember that for language handling to be done properly, you need to have the VistaSwitcher.reg file in DefaultData.

The registry key might need to be quoted as well, since there's a space in the key name. Not sure, but it's a possibility.

http://pastebin.com/xHX8qcvr

[EDIT] Ok, still trying to get this to work, I found that i can run vswitch.exe directly, so no need for the 64-bit stuff after all. I've updated my link accordingly, and added WorkingDirectory, trying to find the solution.

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 7 years 7 months ago
Developer
Joined: 2008-09-30 19:18
Wasn't working

Language switching wasn't working, but I left the stuff in the launcher.ini to show you. I tested it within the platform.

I fixed the ProgramExecutable64 thing and put everything in one directory and added WorkingDirectory.

Aluísio A. S. G.
Offline
Last seen: 6 years 4 months ago
DeveloperTranslator
Joined: 2010-11-09 17:43
Why ConfigRead?

The REG file is in fact an INI file; the language handling can become:

[Language]
Base=%PAL:LanguageName%
CheckIfExists=%PAL:AppDir%\VistaSwitcher\lang\%PAL:LanguageCustom%.lng

[LanguageStrings]
SimpChinese=Chinese (Simplified)
TradChinese=Chinese (Traditional)
SpanishInternational=Spanish (LA)
PortugueseBR=Brazilian Portuguese

[LanguageFile]
Type=INI
File=%PAL:DataDir%\settings\VistaSwitcher.reg
Section=HKEY_CURRENT_USER\Software\Alexander Avdonin\VistaSwitcher\1.0
Key='"LangFile"'
TrimLeft="
TrimRight="

[FileWrite1]
Type=INI
File=%PAL:DataDir%\settings\VistaSwitcher.reg
Section=HKEY_CURRENT_USER\Software\Alexander Avdonin\VistaSwitcher\1.0
Key='"LangFile"'
Value='"%PAL:LanguageCustom%"'

DefaultData is not required anymore.

@John: should we prevent the application from launching on Windows' startup (i.e. on exit, remove any registry entries with this purpose), or just leave it disabled by default?

Previously known as kAlug.

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 1 week 3 days ago
DeveloperModerator
Joined: 2008-07-24 18:46
RE: @John section

We could do a FileWriteN Replace for the value...

[EDIT] missed "do". Keep hitting save instead of preview.

Aluísio A. S. G.
Offline
Last seen: 6 years 4 months ago
DeveloperTranslator
Joined: 2010-11-09 17:43
In general

I meant, in all apps where we can choose to do it. Act defensively or let the user do whatever they want?

Previously known as kAlug.

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 1 week 3 days ago
DeveloperModerator
Joined: 2008-07-24 18:46
Probably best to act defensively

Otherwise, we run the risk of having users complain about traces being left, or other problems arising we can't easily fix, even though it's their own fault.

Let's see what John has to say. Smile

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 1 week 3 days ago
DeveloperModerator
Joined: 2008-07-24 18:46
Language Base

[Language]
Base=%PAL:LanguageName%

should be

Base=%PAL:LocaleName%

unless you're building using the current HG tip.

Aluísio A. S. G.
Offline
Last seen: 6 years 4 months ago
DeveloperTranslator
Joined: 2010-11-09 17:43
Thanks

Yeah, I'm using the tip. But the correct value is PortableApps.comLocaleName.
BTW, it had been changed before PAL 2.2 Beta 1 (thus being included on it).

Previously known as kAlug.

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 7 years 7 months ago
Developer
Joined: 2008-09-30 19:18
Updated to Dev Test 3

Please test this on x64 machines.

John T. Haller
John T. Haller's picture
Online
Last seen: 25 min 44 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Not Working

It's still not working on Win7 x64. If I run it directly, it works. With the launcher, it doesn't. No errors. And it doesn't show up in Task Manager (likely exiting immediately when run).

Sometimes, the impossible can become possible, if you're awesome!

Aluísio A. S. G.
Offline
Last seen: 6 years 4 months ago
DeveloperTranslator
Joined: 2010-11-09 17:43
The way PAL launches it

For some odd reason, launching it through ExecShell's default action instead of ExecWait works.

Previously known as kAlug.

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 7 years 7 months ago
Developer
Joined: 2008-09-30 19:18
I might work on a custom launcher

...if that's what it's going to take.

Aluísio A. S. G.
Offline
Last seen: 6 years 4 months ago
DeveloperTranslator
Joined: 2010-11-09 17:43
Custom code
${SegmentFile}

${OverrideExecute}
	${DebugMsg} "About to execute the following string and wait till it's done: $ExecString"
	${EmptyWorkingSet}
	ClearErrors
	ExecShell "" $ExecString
	${DebugMsg} "$ExecString has finished."

	; Wait till it's done
	ClearErrors
	${GetFileName} $ProgramExecutable $1
	${DebugMsg} "Waiting till any other instances of $1 and any [Launch]:WaitForEXE[N] values are finished."
	${EmptyWorkingSet}
	${Do}
		${ProcessWaitClose} $1 -1 $R9
		${IfThen} $R9 > 0 ${|} ${Continue} ${|}
		StrCpy $0 1
		${Do}
			ClearErrors
			${ReadLauncherConfig} $2 Launch WaitForEXE$0
			${IfThen} ${Errors} ${|} ${ExitDo} ${|}
			${ProcessWaitClose} $2 -1 $R9
			${IfThen} $R9 > 0 ${|} ${ExitDo} ${|}
			IntOp $0 $0 + 1
		${Loop}
	${LoopWhile} $R9 > 0
	${DebugMsg} "All instances are finished."
!macroend

[Changed from expired pastebin link to the text - mod Chris]

Previously known as kAlug.

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 1 week 3 days ago
DeveloperModerator
Joined: 2008-07-24 18:46
This works :)

This works now, as expected. I edited my launcher.ini to remove the Programexecutable64 line, and it still runs just fine.

Aluísio A. S. G.
Offline
Last seen: 6 years 4 months ago
DeveloperTranslator
Joined: 2010-11-09 17:43
PE64 fine

You can leave that line. But unless the 64-bit version is required, we should remove it completely. Also check the need for working directory.

Previously known as kAlug.

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 1 week 3 days ago
DeveloperModerator
Joined: 2008-07-24 18:46
Answers

Since the 64-bit version isn't required (I just double-checked on my system), we should remove both it and the PE64 line to go with it. Otherwise, if we only remove the 64-bit version, but not the line to launch it, users on x64 architecture will have PAL error out, since the appropriate executable is missing.

Working Directory: I just commented out that line, and it's not necessary, the app still launches & runs correctly.

The WaitFor lines should remain, however, as they could still be running locally.

Aluísio A. S. G.
Offline
Last seen: 6 years 4 months ago
DeveloperTranslator
Joined: 2010-11-09 17:43
Correct

64-bit: That was what I meant by "completely".
WaitForEXE: VistaSwitcher is a background program; it's likely that the user will forget to close the local version (or will let Windows close it on logoff/shutdown). PAL needs a better way to handle this.

Previously known as kAlug.

John T. Haller
John T. Haller's picture
Online
Last seen: 25 min 44 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Expiring

Can we stop with expiring pastebins please? It winds up making posting code in forums a bit useless.

Sometimes, the impossible can become possible, if you're awesome!

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 1 week 3 days ago
DeveloperModerator
Joined: 2008-07-24 18:46
Pastebin

I reposted it on my pastebin: http://pastebin.com/PFLksHJj

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 7 years 7 months ago
Developer
Joined: 2008-09-30 19:18
Updated to Dev Test 4

See release notes for changes.

OLLI_S
Offline
Last seen: 1 month 7 hours ago
Joined: 2011-10-19 04:36
Works in x64

Hello,

The Dev Test 4 runs in Windows 7 x64.
Perfect.

Thank you!

Greetings

OLLI

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 7 years 7 months ago
Developer
Joined: 2008-09-30 19:18
great

thanks for testing.

OLLI_S
Offline
Last seen: 1 month 7 hours ago
Joined: 2011-10-19 04:36
Works on 2 Win7 systems

I also tested on my other Win7 x64 System (Notebook) and there it also works!
Good job!

OLLI_S
Offline
Last seen: 1 month 7 hours ago
Joined: 2011-10-19 04:36
When does it get public?

Hello,

VistaSwitcher works fine, so when does it get public?

Greetings

OLLI

Pyromaniac
Pyromaniac's picture
Offline
Last seen: 7 years 7 months ago
Developer
Joined: 2008-09-30 19:18
idk

Whenever there's time for new app releases, I guess. I don't see a reason to rush it either, as this version (as we've seen through extensive testing) works fine now.

OLLI_S
Offline
Last seen: 1 month 7 hours ago
Joined: 2011-10-19 04:36
Reason for making it ublic

Hello,

when you release VistaSwitcher as an official portable app, then it can be downloaded and updated via the portable apps platform.
Much more comfortable than searching for it manually here in the PortableApps.com test applications pages.

Greetings

OLLI

Russell English
Offline
Last seen: 1 year 2 months ago
Joined: 2013-03-19 22:41
Link to portable is no longer available

Link in post #1 to ... [Download VistaSwitcher Portable 1.1.4 Dev Test 4] has been withdrawn, no longer available

Progress is mans ability to complicate simplicity

Log in or register to post comments