You are here

[Fixed] Problem with PortableApps.com Launcher -- Another instance of GIMP is starting...

24 posts / 0 new
Last post
ag0815
Offline
Last seen: 2 years 3 months ago
Joined: 2013-02-12 06:44
[Fixed] Problem with PortableApps.com Launcher -- Another instance of GIMP is starting...

Hi

When I try to start GIMP Portable (v2.8.2 Rev_2) on my Win7 (64bit) PC, I get an error message from PortableApps.com Launcher: "Another instance of GIMP Portable is starting. Please wait for it to start before launching it again." After hitting OK the program does not start. Obviously I checked whether another instance is really running, or I even tried it straight after boot-up, but without success.

Other symptoms:
- The same happens for uTorrent and JDownloader Portable, but not for others (e.g. VLC Player Protable is starting OK)
- No problems if I start these tools as administrator
- Tried to remove and re-install GIMP, but it did not help...

The problem only came up recently, all these tools were working fine before. I cannot nail down the exact point in time tough. Changes I have done recently, which might have triggered the problem, are:
- Install Kaspersky Internet Security 2013 (but after rolling back the system to a checkpoint before the installation did not solve the problem).
- Update to Java RE 7.13 (32bit)
- A few Windows updates over the last few days...
- Install Adobe Acrobat XI
- Install XEmacs

I would appreciate a lot, if somebody can help. If you need more details (general HW/SW configuration, ...) I can provide that directly via email.

Thanks
AG

John T. Haller
John T. Haller's picture
Offline
Last seen: 6 hours 26 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Anything Else

Anything else like install an alternate State Menu.

Sometimes, the impossible can become possible, if you're awesome!

ag0815
Offline
Last seen: 2 years 3 months ago
Joined: 2013-02-12 06:44
I guess you mean alternate

I guess you mean alternate START menu?! No, nothing like this.
Windows Update installed "Microsoft Visual C++ 2010 x64 Redistributable - 10.0.40219" (replacement of 10.0.30319), not sure whether this can cause such a problem?

John T. Haller
John T. Haller's picture
Offline
Last seen: 6 hours 26 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Something Else

Something else is interfering with the standard Windows API then. The only way for that to appear is if a mutex comes back as already existing. Which, if it isn't already starting, it should not. The reason it doesn't happen with VLC is it uses an older custom launcher instead of the PortableApps.com Launcher.

What path did you install the apps into? Does this happen on a completely fresh install (not an upgrade, using no existing Data) of these apps?

Sometimes, the impossible can become possible, if you're awesome!

ag0815
Offline
Last seen: 2 years 3 months ago
Joined: 2013-02-12 06:44
GIMP is installed in

GIMP is installed in "C:\PortableApps\GIMPPortable". The problem remains on a clean new install, no Data or Other reused from the previous installation.

John T. Haller
John T. Haller's picture
Offline
Last seen: 6 hours 26 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Launching

How are you starting GIMP Portable? From the EXE directly or a menu? What else is running on the PC at the time? Was this a fresh Windows install or an upgrade? Ultimate, Home Edition, etc? Retail, direct download, etc?

Sometimes, the impossible can become possible, if you're awesome!

ag0815
Offline
Last seen: 2 years 3 months ago
Joined: 2013-02-12 06:44
Usually I start it via a link

Usually I start it via a link in my start menu. But also a direct start of the EXE causes the same problem.

Even if I stop all my other programs, and most of the processes in Task Manager (some Windows related processes and quite many services are still running) it is still not starting. Only Kaspersky is still running in the background (not an active scan, just normal).

I'm running Win7 Ultimate 64bit original (not an OEM version) plus Service Pack 1.

ag0815
Offline
Last seen: 2 years 3 months ago
Joined: 2013-02-12 06:44
Windows was a fresh install,

Windows was a fresh install, not an upgrade.

John T. Haller
John T. Haller's picture
Offline
Last seen: 6 hours 26 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Users

Did you install as one user and use as another considering this is NTFS? Or do you run as admin for the installers? Or do you use a utility to up or down your user permissions?

Sometimes, the impossible can become possible, if you're awesome!

ag0815
Offline
Last seen: 2 years 3 months ago
Joined: 2013-02-12 06:44
I am the only user on this

I am the only user on this PC. I have Admin rights, all the time. All installations are done by me with admin rights. I don't use any utility for permission management.

cbj0129
Offline
Last seen: 3 years 2 months ago
Joined: 2006-04-03 21:59
Permissions?

I had similar problem a few weeks ago using a NTFS formatted portable hard drive. Fixed it by changing the permissions. Why the error message about another process running is beyond me.

Try running from a Fat32 formatted stick to rule out an issue with your system.

Clair

ag0815
Offline
Last seen: 2 years 3 months ago
Joined: 2013-02-12 06:44
Thanks Clair for the

Thanks Clair for the suggestion! Unfortunately it does not help, still the same issue when trying to run GIMP from a FAT32 USB stick on my PC. If I run the same stick on another Laptop, I don't have the problem anymore. So it really seems to be my PC... Sad

ag0815
Offline
Last seen: 2 years 3 months ago
Joined: 2013-02-12 06:44
Clair, how did you cleanup

Clair, how did you cleanup your permissinons? What should I be looking for to fix? I would not like to give myself full permissions for everything on the HDD...

cbj0129
Offline
Last seen: 3 years 2 months ago
Joined: 2006-04-03 21:59
Sounds different

In my case it ran fine from Fat32. My failing case was a portable harddrive formatted NTFS. I just changed permissions for the PortableApps folder to give full access. You seem to be running on the C: drive. I'm not skilled with Win7, so can't help much.

Did you install to C: or did you copy from a thumbdrive (or similar)?

ag0815
Offline
Last seen: 2 years 3 months ago
Joined: 2013-02-12 06:44
The installation on both C:

The installation on both C: and USB stick were fresh, not a copy from somewhere else...

Simeon
Simeon's picture
Offline
Last seen: 9 years 6 months ago
DeveloperTranslator
Joined: 2006-09-25 15:15
crash

Did it crash recently?
Sometimes the launcher couldnt clean up because of the crash or something else and a file indicating so is left behind in the Data folder. I cant recall its name offhand.

"What about Love?" - "Overrated. Biochemically no different than eating large quantities of chocolate." - Al Pacino in The Devils Advocate

ag0815
Offline
Last seen: 2 years 3 months ago
Joined: 2013-02-12 06:44
GIMP did not crash. But my

GIMP did not crash. But my complete system shut down unexpectedly due to a virus a few days back. GIMP did not run at that time, but may be another portable app. Is it possible that such a left-over now effects all portable apps using the new Launcher (i.e. GIMP, uTorrent, JDownloader)?

Simeon
Simeon's picture
Offline
Last seen: 9 years 6 months ago
DeveloperTranslator
Joined: 2006-09-25 15:15
no

Such a leftover file (the correct name is AppName/Data/PortableApps.comLauncherRuntimeData-AppNamePortable) only affects the app in question.

"What about Love?" - "Overrated. Biochemically no different than eating large quantities of chocolate." - Al Pacino in The Devils Advocate

ag0815
Offline
Last seen: 2 years 3 months ago
Joined: 2013-02-12 06:44
AppData\Local\Temp permissions

I found this file in the Data folder for both JDownnloader and uTorrent (both not starting correctly), but not for GIMP. In both cases the content was someting like:

[PortableApps.comLauncher]
PluginsDir=D:\Users\Alex\AppData\Local\Temp\nsb9821.tmp

Not sure whether the file is not supposed to be there at all, but when I renamed it, the problem still remains the same.

However, this got me thinking about the AppData\Local\Temp directory. WinZip also complains that it cannot change to a directory in there even I see it creating this. I remember that the Virus/Trojan that I had a few days back was also located in this Temp dir, so may be it manipulated the premissions. The permissions of this AppData\Local\Temp directory are:

- Administrators - full control - not inherited
- Everyone - special - not inherited
- No mentioning of me or the SYSTEM...

This seems suspicious. What permissions does your Temp directory have? Are all the permissions simply inherited from Appdata\Local ?

Thanks a lot so far!
Alex

John T. Haller
John T. Haller's picture
Offline
Last seen: 6 hours 26 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Permissions

As it is now, TEMP is likely not properly usable by you. Everyone should not be listed at all. SYSTEM, Administrators and your account should be listed with full control.

The 12.0 platform beta automatically checks for TEMP issues now. But the apps do not.

Sometimes, the impossible can become possible, if you're awesome!

ag0815
Offline
Last seen: 2 years 3 months ago
Joined: 2013-02-12 06:44
Solved

After changing the permissions of the AppData/Local/Temp directory (now all permissions are inherited from AppData/Local), everything works fine again.

Thank you very much John and Simeon for your help!!
Alex

ag0815
Offline
Last seen: 2 years 3 months ago
Joined: 2013-02-12 06:44
Adobe Acrobat 11 !!!

After a bit of online research, I found that Adobe Acrobat 11 is actually changing permissions of the AppData\Local\Temp directory. Not a virus, but happening everytime you open a PDF...

See http://answers.microsoft.com/en-us/windows/forum/windows_8-security/cant... and http://forums.adobe.com/message/5033519

So John, maybe this will hit others as well, when they use portable apps with the new Launcher and Adobe Acrobat 11 on the same PC.

Cheers
Alex

poppy101
Offline
Last seen: 1 year 6 months ago
Joined: 2013-04-20 09:24
Yes, I isolated it to Acrobat

Yes, I isolated it to Acrobat XI too. Permissions on appdata/local/temp were all messed up - restoring permissions allowed the portable app to launch finally, and also cleared up a separate problem I had been having with Winrar acting weird

chuck2019841
Offline
Last seen: 10 years 2 months ago
Joined: 2014-02-05 09:22
Sorry if I am too noob but I

Sorry if I am too noob but I am having the same issue. Can someone shows/step by step process in permissions in Temp folder.

Thanks in advance for the help.

Log in or register to post comments