You are here

Failed Upgrades - Win10

14 posts / 0 new
Last post
jlschrag
Offline
Last seen: 6 months 4 days ago
Joined: 2021-12-21 11:08
Failed Upgrades - Win10

Like many before me, the platform updater is having trouble downloading apps - and has for several weeks. I have looked through every existing forum post I could find but haven't found a resolution. Unlike many of the 2018 posts, however, I'm on an up-to-date Win10 machine.

The error is:
"Unable to download the file. This could be due to a proxy or network issue or the hosting server not permitting downloads from your location."
which I get for 7Zip, DVDStylerPortable, FileZilla, Firefox, Gimp, Notepad++, Opera, PDFTKBuilder, PicPick, WinMerge, & Workrave.

My System:
* Portable Apps 19.1 (long standing install, upgraded over the years)
* Connection setting in platform options: Automatic
* Windows 10 Pro 64 bit, Version 21H2, Build 19044.1415, Windows Feature Experience Pack 120.2212.3920.0
* Install location
* C:\Portable Apps\PortableApps\PortableApps.com contains PortableAppsPlatform.exe & PortableAppsUpdater.exe
* C:\Portable Apps contains Start.exe

What I've tried:
* When I try downloading one of them manually using Internet Explorer, it DOES work (specifically, it loads the SourceForge download page, which then downloads the file):
http://portableapps.com/redirect/?s=p&a=7-ZipPortable&d=sfpa&wv=8.1&f=7-...
* I have checked internet options, and I have all the TLS boxes checked & SSL boxes unchecked.
* I CAN load the Platform "Get more apps" window
* I didn't try loading the various apps listed in this post as I don't know how current it is: https://portableapps.com/node/57916

Any help is greatly appreciated.

John T. Haller
John T. Haller's picture
Offline
Last seen: 2 hours 6 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
PicPick

Try PicPick again. It's not open source so it's on our server. I'm betting this is a SF-only issue. Just want to confirm before diving deeper.

Sometimes, the impossible can become possible, if you're awesome!

jlschrag
Offline
Last seen: 6 months 4 days ago
Joined: 2021-12-21 11:08
Thanks for the quick reply

Thanks for the quick reply John!

PicPick fails from the platform updater when I try to update it by itself, but succeeds in IE.

John T. Haller
John T. Haller's picture
Offline
Last seen: 2 hours 6 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Fresh Install

Ok, next step is to try a temporary fresh install. Close all instances of the PA.c Platform and your portable apps. Download a fresh copy from the Download link above. Then install it to your Desktop directory temporarily. Don't make any changes at all and just run it. It'll bring up the app directory. Select DSpeech in Accesssibility, DB Browser for SQLite and NSIS in Development. This will test our own download server, Github, and SourceForge in that order.

Sometimes, the impossible can become possible, if you're awesome!

jlschrag
Offline
Last seen: 6 months 4 days ago
Joined: 2021-12-21 11:08
Downloads failed for DSpeech

Downloads failed for DSpeech & NSIS. Succeeded for DB Browser.

Also worth noting: On the first screen after install, which has four tabs (version info, apps, etc.), the apps tab is blank. However, after I close that, it brings up the updater.

John T. Haller
John T. Haller's picture
Offline
Last seen: 2 hours 6 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Paste Into IE

Ok. Odd. Try right-clicking on this link and selecting Copy Link (or similar). Then in IE, paste it into the URL bar.

Sometimes, the impossible can become possible, if you're awesome!

jlschrag
Offline
Last seen: 6 months 4 days ago
Joined: 2021-12-21 11:08
That downloads in IE and runs

That downloads in IE and runs properly.

John T. Haller
John T. Haller's picture
Offline
Last seen: 2 hours 6 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Proxy, Other PC

Do you have any proxy / antivirus / antimalware installed on the affected PC? Do you have another PC to test on to rule out any network issues fully?

Sometimes, the impossible can become possible, if you're awesome!

jlschrag
Offline
Last seen: 6 months 4 days ago
Joined: 2021-12-21 11:08
I have Windows Defender, but

This PC has Windows Defender, but I don't think there are any other relevant programs installed (this is a corporate computer). I have a linux box & a macbook handy, but no other Windows PCs.

John T. Haller
John T. Haller's picture
Offline
Last seen: 2 hours 6 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
VirtualBox?

Is your PC powerful enough to spool up a Windows 10 install in VirtualBox? You could leave it inactivated and use it just to test if it works on a fresh up to date Windows install on your network. Just spit-balling here. Other option is if it's a laptop, try it on another network (work, school, coffee shop, etc) or if it's a desktop, try it with another WiFi network (city wifi, phone hotspot, neighbor, etc).

Sometimes, the impossible can become possible, if you're awesome!

jlschrag
Offline
Last seen: 6 months 4 days ago
Joined: 2021-12-21 11:08
I switched from my local

I switched from my local network to a mobile hotspot & had the same issue. So, it would seem it may be antivirus/firewall/etc. I'll engage with my IT folks & see what we can figure out.

John T. Haller
John T. Haller's picture
Offline
Last seen: 2 hours 6 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
IE Settings

In Internet Options under Advanced at the bottom, make sure Warn if changing between secure and not secure mode is unchecked.

You could also try resetting your internet settings to their defaults (Reset button at the bottom of that same Advanced tab)

Sometimes, the impossible can become possible, if you're awesome!

jlschrag
Offline
Last seen: 6 months 4 days ago
Joined: 2021-12-21 11:08
Tried these two, but no luck.

Tried these two, but no luck. Also tried adding rules to the Windows firewall.

For now, I just updated everything manually, given the log4j bug that many of these updates may have been patching. But, this will probably pop up again in the next few days.

duwil
Offline
Last seen: 6 months 1 day ago
Joined: 2021-11-07 06:06
me too

I had the very same problem (see here: https://portableapps.com/node/65079) but it seem like it's gone away now. I first changed my network from corporate to mobile and successfully updated my apps, then I switched back to my corporate network, tried another update with success again. So I cannot confirm the switch solved my problem or if it was just a coincidence.

Log in or register to post comments