You are here

VLC: URGENT: No video on AVI playback

9 posts / 0 new
Last post
foxcole
Offline
Last seen: 8 months 2 days ago
Joined: 2007-05-26 16:30
VLC: URGENT: No video on AVI playback

I am on a hot project to create some documentation based on AVIs created with SnagIt 8 that include both video and sound. On playback I can only get the sound. I have VLC 0.8.6c running on WinXP Pro SP4.

I've searched this forum as many ways as possible, and found no help. I saw one suggestion to go into the Windows folder options and make sure the advanced settings for avi files had "donble/single quotes" around %1, but I don't know whether that meant either/or, or whether it meant two sets of single quotes... and in any case, I think it meant I'd need to associate VLC to AVI files on that computer. I don't wish to do so. The only other thread I found concerning this same problem went unanswered a year ago... so here I am asking. I've spent way too much time on this already and am under pressure to get this done overnight.

I tried switching video codecs in the Settings preferences with no luck. There were only three options: Fake, Theora, and x264. Maybe I just don't know how to set one of those up properly. I also tried streaming to an output file, but the file was never created so I can't tell whether it worked. (I fruitlessly searched all the temporary, hidden and system files for the file name, and then for any file created that day. So I screwed up something in that attempt, apparently.)

I also read in this forum that codecs are integrated in VLC so it's not possible to just add one.

Is there any possibility for getting these AVI files to play correctly on VLC, or is there another portable player that will do this particular job? This is the first time VLC hasn't come through for me... so I'm hoping there's something I am ignorantly overlooking.

I am begging for any advice you might be able to offer.
Sad

EDIT: I should add that I'm not using Windows Media Player for this because it has a huge control bar (for pause, play, etc.) that in full-screen mode sometimes will drop and hide, but usually won't. The recordings are full screen and this control bar is in the way when I need screenshots. It's not possible to change the zoom on the video because that compresses the display so the text in the screenshots becomes unreadable, and we can't have that in documentation.

So I need to be able to play these back at full screen, or as close to it as at all possible. VLC has a true fullscreen mode, so this is why I am praying for a solution.

m-p-3
m-p-3's picture
Offline
Last seen: 11 months 3 days ago
Joined: 2006-06-17 21:25
Are you able to play the

Are you able to play the video file in Windows Media Player ? It would help us in helping you finding the appropriate configuration for VLC, like if it needs additionnal codecs that Windows use (DirectShow).

I can't remember the name of a media file analyzer, which can indicate what codecs has been used to encode the video and audio stream. Can somebody help me on that one ?

EDIT: Try to analyze the file with AVIcodec. What are the info written in the file details, audio details and video details ?

[Link fixed, this forum uses html not bbcode]

foxcole
Offline
Last seen: 8 months 2 days ago
Joined: 2007-05-26 16:30
Yes...

... WMP plays the AVIs just fine. I'm downloading AVIcodec. Do I have to install that locally or can it run as a portable?

Cheers!
---Fox

m-p-3
m-p-3's picture
Offline
Last seen: 11 months 3 days ago
Joined: 2006-06-17 21:25
It's not portable, you will

It's not portable, you will have to install it locally. Uninstall when you don't need it anymore.

foxcole
Offline
Last seen: 8 months 2 days ago
Joined: 2007-05-26 16:30
Details

Regardless of whether that can run portably, here's what AVIcodec gives:

File : 223 MB (223 MB), duration: 0:10:22, type: AVI, 1 audio stream(s), quality: 80 %, ,
Video : 196 MB, 2655 Kbps, 15.0 fps, 1016*764 (4:3), CRAM = Microsoft Video 1 (MSVC), Supported
Audio : 26 MB, 352 Kbps, 22050 Hz, 1 channels, 0x1 = PCM, CBR, , Supported

(I tried to simply edit my last post to add that information, but I got an "Access Denied" error! That's never happened before. Weird!)
(Oh---it was because you were replying at that exact moment, LOL)

EDIT:
The version of MSVC on this computer (same computer that was used to record the AVIs) is 5.1.2600.0, if that helps anything.

Cheers!
---Fox

foxcole
Offline
Last seen: 8 months 2 days ago
Joined: 2007-05-26 16:30
Upgraded.... :-(

... to 0.8.6h, just in case that made a difference, but it did not. I still need this to work if possible, even though it's almost too late for this documentation project. More are coming.

Cheers!
---Fox

foxcole
Offline
Last seen: 8 months 2 days ago
Joined: 2007-05-26 16:30
Using MPlayer temporarily.... -- NOT

... it plays the AVIs but only on the primary monitor. I don't like MPlayer though (for one thing, it doesn't have some security patches, so I don't trust it)... Am still hoping for help with VLC.

EDIT: Can't use MPlayer. I can't take screenshots from it. The screenshots are just black, so I'm not sure how it's displaying the AVI file.

Please, please help!!!!!! Situation desperate!

Cheers!
---Fox

Simeon
Simeon's picture
Offline
Last seen: 7 years 10 months ago
DeveloperTranslator
Joined: 2006-09-25 15:15
can you

do a local install?
Maybe a local install works...
If you can istall it, you could try Media Player classic
Can you get SnagIt to use a different codec?

"What about Love?" - "Overrated. Biochemically no different than eating large quantities of chocolate." - Al Pacino in The Devils Advocate

foxcole
Offline
Last seen: 8 months 2 days ago
Joined: 2007-05-26 16:30
Can't do anything with SnagIt BUT----

--- Media Player Classic works!! It plays, I can see the video, AND I can capture screenshots from it with FastStone. My project is back on track! *Thank you*!!

Cheers!
---Fox

Log in or register to post comments