You are here

Outdated: PortableApps.com Updater 1.0 ALPHA 9

305 posts / 0 new
Last post
MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Outdated: PortableApps.com Updater 1.0 ALPHA 9

see: https://portableapps.com/node/14735

Application: PortableApps.com ™ Updater
Category: Utilities
Description: Holds Your PortableApps up to date.

Download PortableApps.com ™ Updater 1.0 ALPHA9 [1.2MB download / 1.4MB installed]
(MD5: 6b93b3853e8460d0cb6603445d65f93b)

Features
PortableApps Updater is an update tool with features like:

  • automatic update of all hosted Apps
  • multi-language support (offers the right localized package/informations depending of the selected language)
  • built in md5sum check for the offered packages
  • Support of all packages in paf format (Installer and 7-Zip packages)
  • Configuration with ini (over config page)or command line
  • built in support for randomized mirror servers
  • built in support for http and ftp sources
  • built in support for the Sorceforge and OOoDev mirror network
  • proxy support (Windows Proxy by default, own proxy server, no proxy)
  • proxy authentification
  • add. parameters for wget
  • personal blacklist (block update offers for unwanted Apps)
  • recommend packages / make packages mandantory
  • support for local or private web based (other servers than PortableApps.com) Application management
  • self update support for the updater

It uses GNU Wget Version 1.11 as a binary version found on: http://wget.addictivecode.org/
(This version was compressed with upx --best --compress-icons=0 --crp-ms=999999 in order to save space.)
Learn more about GNU Wget
... in the Wget manual
... in the Wget Wiki
More about GNU wget...

Release Notes:


Version 1.0 Alpha9 (2008-05-04):
(not Beta1, until the last issues fixed...)
This version will fix the following issues:

  • Version check fix
  • new icon (thanks again to Zé Pedro)
  • Configuration page over /SHOWOP parameter only


Version 1.0 Alpha8 (2008-04-28):
(not Beta1, cause there was no new statement of John...)
This version will fix the following issues:

  • GUI (with multi-lang support) to change all settings (including target path and
    proxy settings)
  • no run checkbox in the installer (really Smiling )
  • better version check (only packages with higher version number than local)
  • Proxy authentification support
  • only packages for installed Apps as default
  • license page and directory page removed
  • new icon (thanks again to Zé Pedro)
  • support for paths with blanks
  • smarter database structure closer to appinfo.ini
  • show version description instead version number)


Version 1.0 ALPHA7 (2008-04-10):
This version will fix the following issues:

  • calculating size of selected packages
  • prev and next button components page fixed (prev shows Welcome page, next checks if a App is selected)
  • better size/style for components page
  • Proxy authentification support
  • use dynamic download banner instead fixed splash


Version 1.0 ALPHA6 (2008-04-07):
(ALPHA5 inclomplete upload)
This version will fix the following issues:

  • Standard installer
  • Change self update function
  • enable restart for interupted download (wget )


Version 1.0 ALPHA4 (2008-04-04):
This version will fix the following issues:

  • app.ini fix
  • show local version information


Version 1.0 ALPHA3 (2008-04-03):
This version will fix the following issues:

  • License- Welcomepage (show only once)
  • updater.ini format closer to app.ini
  • better function for component page preparation
  • new icons (thanks to ptmb)
  • self update support for the updater
  • Defaults changed (packagedir set to $TEMP, pdel=true)
  • Fix Path to license.txt



Version 1.0 ALPHA2 (2008-03-12):

  • Fix width of component page (thanks to John Smile )
  • Defaults changed (packagedir set to $TEMP, pdel=true)
  • Fix Path to license.txt



Version 1.0 ALPHA1 (2008-03-12):

  • initial relase (it is stable but ALPHA for several reasons)

Version 1.0 1.0 ALPHA1 (2008-03-12): Initial release

Many thanks to Simeon for first tests, feedback and all the answers releated to questions and requests for this tool in the forums :-). Thanks to John (and all the contributors) for the installer and to the translators for the needed strings.

You'll find the older entries here:
https://portableapps.com/node/12584
https://portableapps.com/node/12040

[Set back to filtered HTML by moderator JTH. Full HTML isn't for forum posts.]

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Some translations for french, italian, spanish needed...

... because of some changes in the updater there a few strings and (if You'll have a complete Updater in this language for the App descriptions) for translation.

You'll find the source files for the languages in Other/Source.

If the strings for all languages are complete I thing it's time for BETA1 now, cause all heavy problems are fixed now.

Paid for Software more or less?
What You need is OSS!

wk
wk's picture
Offline
Last seen: 3 months 3 weeks ago
Joined: 2007-09-05 12:31
Strange..?

Updated Installer from Alpha 6 and made a complete renewed install. In both cases The updater GUI window says "Mozilla Firefox 2.0.0.120- (local: MozFirefox 2.0.0.130)" and the checkbox is selected, even after unchecking, cancelling and restart.
Buggy database? Counting error? And: no real local firefox is installed (if that was meant, the portable FF is indeed 2.0.0.130).

"Lorem ipsum dolor sit amet, consectetur adipisici elit, sed eiusmod tempor incidunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis .." Friday Next -
"May The Schwartz be with You!" Yogurt the Yoda

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Yes :-)

The database has 12 instead 13, will be fixed today.
The App will be offerent if the server version is different to the version found on Your stick/PC.

Local means the local on You Stick/PC (present/found: could be a better expression)

Paid for Software more or less?
What You need is OSS!

Simeon
Simeon's picture
Offline
Last seen: 7 years 11 months ago
DeveloperTranslator
Joined: 2006-09-25 15:15
cool

I really like it now.
The auto-selection is good. The list is big/wide enough. The free space calculation is cool.

Just the ini needs an update to FF 13 and Peazip 2.

Definitely beta now.

"What about Love?" - "Overrated. Biochemically no different than eating large quantities of chocolate." - Al Pacino in The Devils Advocate

Stevoisiak
Stevoisiak's picture
Offline
Last seen: 3 years 1 month ago
Joined: 2008-02-05 11:22
???

Why did you make a new forum instead of using the old one. Now, the Development Test link must be changed, old links are obsolete, the old forum must be locked, and there is clutter with more than one topic for the same app. Still, congratulations on the update, it sounds like the best one yet! I'll just download and test it out.

Edit: Bug found. I have firefox 2.0.0.130, the most recent version, and it wants me to install version 2.0.0.120. I think you should program in a system to realize whether the version you have is higher than the version it picks up.

Edit: Also, the other apps I have, (7 zip, Joleem, Sudoku, and THE UPDATER) were not on the list. This may be a bug, or a feature put in on purpose, but if it's a bug, I wanted to let you know. Also, It would be very nice to be able to update my beta apps under development test.

Edit: Also, It keeps wanting to install the apps to C:\DOCUME~1\2013SV~1\LOCALS~1\Temp\Data\setup, when it should be installing to the portableapps folder in my documents, aka, where it's being run from.

Edit (again): And it still is not space compatible. I have to change the space in my documents to a _ manually.

Simplifying daily life through technology

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Some answers...

New tread in order to keep it readable, Development link will be fixed soon.

Database is up to date now.

Only outdated or not existing Apps are offered for update.

The updater don't install, he dowloads the packages (installer) to the temp directory (as described on the components and directory pages)

It is space compatible (in the sense that the use of directories with strings it not allowed).

Thanks for feedback!

Paid for Software more or less?
What You need is OSS!

ZachHudock
ZachHudock's picture
Offline
Last seen: 4 years 8 months ago
Developer
Joined: 2006-12-06 18:07
I already fixed the link on

I already fixed the link on the Development Test page...It was done 5 minutes after you posted this update.

The developer formerly known as ZGitRDun8705

Stevoisiak
Stevoisiak's picture
Offline
Last seen: 3 years 1 month ago
Joined: 2008-02-05 11:22
Not true

When I am adding the installers I usually download to my documents. (Since this is a school PC, I don't want to tamper with the temp folder) Here is the file path I start with. (Once again, since this is a school PC, the folders for my username/grade/school/personal info are represented by ...) "\\...\hd\...\...\My Documents\Portable apps\setup" And if I hit ok, it says "Error: The instalation directory has 2 spaces. Please select another directory." But if I change "My Documents\Portable apps" to "My_Documents/Portable_apps" It works just fine.

Simplifying daily life through technology

Jimbo
Offline
Last seen: 2 years 8 months ago
Joined: 2007-12-17 05:43
Another database ini file error

The version number for eraser portable is 5.86.1.1 in the ini file, but the current official release is 5.82 rev 3, which the updater correctly downloads, but which installs with a version number of 5.82.0.2, prompting to be updated again.

Other than that, this is looking really good! Excellent app. Thanks

Edit:
Also Miranda Portable is now at 0.7.3.0 but the ini version seems stuck at 0.6.8.0

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Thank You for the feedack ...

... database fixed!

Paid for Software more or less?
What You need is OSS!

José Pedro Arvela
Offline
Last seen: 3 years 8 months ago
Joined: 2007-07-10 07:29
It works fine

I don't have nothing to complain (perhaps that you aren't using the most recent version of the icon, but nothing more).

pt-PT fix:

LangString DESC_Section40 ${LANG_PORTUGUESE} "leva as tuas finanças contigo"
LangString DESC_Section41 ${LANG_PORTUGUESE} "o arquivador de ficheiros portátil"

Blue is everything.

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
??? I use the icon ...

... You have sent with the Download splash. Please send the last icon again and I'll add it togther with the strings soon.

Thanks again

Paid for Software more or less?
What You need is OSS!

José Pedro Arvela
Offline
Last seen: 3 years 8 months ago
Joined: 2007-07-10 07:29
It is on the go

Check your mail... Wink

Blue is everything.

r.andom
r.andom's picture
Offline
Last seen: 14 years 1 month ago
Joined: 2007-11-12 15:11
A dozen comments ...

I tried PA-Updater alpha 6/alpha 7. Thx for your work, Marko! Here are my comments:

1) The updater doesn't offer all Portableapps you can find at portableapps.com (for example: xampp-launcher, Pidgin-OTR). Why not?

2) The updater doesn't always offer the newest available version (for example: Firefox 2.0.0.12 instead of 2.0.0.13, Filezilla 3.0.7.1 instead of 3.0.8.1, Inkscape 0.45.1.0 RC1 instead of 0.45.1.0). I hope the database is generated automatically without the need of human interaction? This seems to be a possible SPOF. Base for the version check could be the sourceforge web page with the "latest file releases" (http://sourceforge.net/project/showfiles.php?group_id=151265).

3) If a md5 check fails, the updater should offer to download the file from another mirror.

4) If the server answers with a "404 Not found" or "No such file" the updater should tell the user. A message "MD5 checksums do not match" is irritating for unexperienced users (for example: Inkscape)

5) How can I get a "silent" install of the apps (without splash screens and questions for install directory)?

6) I'd like to get offered the apps in development (alpha, beta, RC). As you know it can take a long long time until a ready to post app gets approved ...

7) The updater should indicate the language of the offered apps, so users can decide not to install an app in a language they don't understand.

8 ) The updater should offer language packs that are not automatically installed with the main app (for example: kompozer-langpacks).

9) Each newly installed or updated app should (if the user wants) be started once by the updater to configure it and/or to install add-ons.

10) If certain components are necessary to get the app working in the selected language, the updater should select those components automatically (for example: GIMP, Pidgin).

11) The space calculation recognizes the needed space on the stick, but not the needed temporary space on hd. So it can happen that e.g. OpenOffice installation fails. The updater unfortunately does NOT recognize such a failure and does NOT offer another try at the next run.

12) How can I combine the web database plus a local file for further apps?

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
a dozen answers...

1) He supports only 'full" Apps cause if we will add Launcher-only and Plugin-packages we have to handle it (check if the main App is installed and in the current version and so on) [no fix]

2) fixed in next version

3) No, run it again, cause this 'feature' could create loops and will break the
ability to run stable in batch mode [no fix]

4) The Error Messages are shown in the install window, if this message isn't read or
understand by the user any message (what text ever) will still irritate. [no fix]

5) Add batch=true in the [update] section of Your settings.ini [still solved]

6) That is what the entry Ofile= is for. Find someone how is willing to maintain and host a database for this packages an use this file. [no fix needed]

7) The updater offers an App in localized version if it is available. If not the
en version is offered. Most versions are multilang by default. To select/filter
packages (thinking we know what the user wants) is a bad idea and not a task for
the updater. [no fix]

8) No, see 1) That is a task for the packages, not for the updater.[no fix]

9) No, cause automatic start of a PAFed App after install is not wanted and breaks
the defined installer format. [no fix]

10)John tells me that this feature will be added to the installers of the apps in
the near future. Again, no task for the updater. [no fix]

11) No. Read the components and directory page carefully. The installer only
calculates the needed space for the packages (what target ever) not for the
installed Apps, this is the job of the package installers. [no fix]
12) No way! The installer have to use one (!) database (local or not) But You can
run it twice (with a batch, first time with server database, second time with
local database and so on. [no fix]

Paid for Software more or less?
What You need is OSS!

RogerL
Offline
Last seen: 1 day 11 hours ago
Joined: 2007-03-14 09:17
Minor adjustment to Choose Components page needed?

On my system, WinXp SP2, 1280 x 768, the bottom of the Application ListBox and the top of the Description GroupBox touch each other. If the ListBox height was reduced slightly it could display exactly 8 entries instead of the 8 and 3/4s it does at present thus fixing two minor problems at one stroke.

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Thank You for the feedack ...

... fixed in next version Smile

Paid for Software more or less?
What You need is OSS!

Hung0v3r
Offline
Last seen: 14 years 2 months ago
Joined: 2007-01-07 18:27
Doesn't recognize RC or Betas

I have Sunbird .80RC and it wants to download and install .70

I can understand not supporting Betas or RC but at least don't have it auto-select to install an older version.

Other than that, it's beautiful. A fantastic idea for an app.

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
fixed ...

... next version will only offer an App if the local version is older.

Paid for Software more or less?
What You need is OSS!

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Ready for BETA1?

I think so Smile
If John will agree on this I'll post next version as beta1 today.

Paid for Software more or less?
What You need is OSS!

José Pedro Arvela
Offline
Last seen: 3 years 8 months ago
Joined: 2007-07-10 07:29
WAIT!

Wait! I will speed up the icon creation process a little bit and I will see if I can manage it to today.

New status, new icon Wink

+ annoying request yet again: Make the updater.ini have batch=true by default please. Last time I say it, really. I won't annoy you again with this.

Idea: Shouldn't the translation of the description of a package be offered on web database too? Think about this, as that way, always that a new app comes out you don't need to update the Updater.

EDIT: Icon on the way. It isn't really really changed, but it has a few differences between it and the one you have.
But for the audience it will be a big change, as they only saw the first version. Biggrin

Blue is everything.

John T. Haller
John T. Haller's picture
Online
Last seen: 9 min 14 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Nope

We're not quite at beta stage yet.

Still need to remove the run checkbox from the installer for this.

Any way to have it list the apps that need updating up top with the local version first? Perhaps we could even use the PackageVersion internally but use the DisplayVersion in the interface. Something more like:

AbiWord Portable (2.6 -> 2.6.2)
Mozilla Firefox, Portable Edition (2.0.0.12 -> 2.0.0.13)
PuTTY Portable (0.60 Rev 2 -> 0.60 Rev 3)
[Add] 7-Zip Portable (4.57)
[Add] Audacity Portable (1.2.6 Rev 3)
...

Make sense?

Perhaps it would make sense to give users the option to only have it update by default (not list apps they haven't installed). We could have it start with a custom page (a welcome-ish page) with a checkbox to also list apps that are not installed that is unchecked by default. When they click next from there have it download the updated app list.

Sometimes, the impossible can become possible, if you're awesome!

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Ok.

The checkbox is removed... I used the old one the last update Sad

Local Version first is no Problem, use of display version too Smile

Your idea for the custom welcomish page is great.

If I get this working ... this is BETA1 isn't it Smile ?

Paid for Software more or less?
What You need is OSS!

Steve Lamerton
Steve Lamerton's picture
Offline
Last seen: 9 years 1 week ago
Developer
Joined: 2005-12-10 15:22
Well

I don't see why not. I just used the updater for the first time since a really early release, and I must say it is really good, and with those extra suggestions added it will be very useful indeed!

Oh and the database will need updating for tonight's new releases!

Stevoisiak
Stevoisiak's picture
Offline
Last seen: 3 years 1 month ago
Joined: 2008-02-05 11:22
Wait a sec

Nobody locked the old forum yet...

Simplifying daily life through technology

Chris Morgan
Chris Morgan's picture
Offline
Last seen: 7 years 3 months ago
Joined: 2007-04-15 21:08
issue

I just downloaded and installed ALPHA7...
System setup includes Windows 2000, large fonts.

  • On-ScreenKeyboard Portable 1.0.0.0 --> (local:1.1.0.0)
    thinks... hmm... it's trying to downgrade me.
  • CommandPrompt Portable should be Command Prompt Portable
  • On-ScreenKeyboard Portable should be On-Screen Keyboard Portable
  • The Description fieldset's title ("Description"), its background (grey) slightly overlaps the component choice box. This may be an NSIS problem, I don't know. But when you scroll down, it loses it! The component list doesn't refresh it, so you get an extra grey line! It must be Christmas time!
  • An extract from the GPL, in the terms and conditions for copying, distribution and modification:
    5. You are not required to accept this License, since you have not signed it.

    The upshot of this is that the updater should not require you to accept the GPL.
    From PortableAppsUpdater.nsi, I think that you should remove the lines which deal with the license stuff, in other words, the following lines (line numbers are from ALPHA7):

    83   ; == License page ==
    84   !define MUI_PAGE_CUSTOMFUNCTION_PRE Pre-License
    85   !define MUI_PAGE_CUSTOMFUNCTION_LEAVE LicenseLeave
    86   !insertmacro MUI_PAGE_LICENSE "..\..\Other\Source\License.txt"
    87   
    
    180  var lpage
    
    641      ;=== read the parameter for license page
    642      ${GetOptions} "$CMDLINE" "/NOL" $R0
    643      IfErrors noskip6
    644          StrCpy "$lpage" "false"
    645      noskip6:
    
    919  Function Pre-License
    920  StrCmp $lpage "true" +2
    921      Abort
    922  FunctionEnd
    923  
    924  Function LicenseLeave
    925      WriteINIStr $EXEDIR\Data\Settings.ini "Show" "License" "false"
    926  FunctionEnd
    927  
    
    931      StrCpy "$lpage" "true"
    
    1153     ReadINIStr $0 "$EXEDIR\Data\settings.ini" "Show" "License"
    1154     StrCmp $0 "" +2
    1155     StrCpy "$lpage" $0
    

    I think that that should do it.

I think that that should do it for today!

I am a Christian and a developer and moderator here.

“A soft answer turns away wrath, but a harsh word stirs up anger.” – Proverbs 15:1

Stevoisiak
Stevoisiak's picture
Offline
Last seen: 3 years 1 month ago
Joined: 2008-02-05 11:22
Proxy

I noticed you still haven added the feature to configure your proxy manually. Websence keeps blocking my downloads. Also, spaces are still not supported. When downloading the installers, I still have to manually change \My Documents\Portable apps to \My_Documents\Portable_apps

Simplifying daily life through technology

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Please read the release notes and the post please

Spaces in the path are (and will never) allowed, cause this causes trouble.
The proxy authentification is suported since Alpha7

Paid for Software more or less?
What You need is OSS!

Stevoisiak
Stevoisiak's picture
Offline
Last seen: 3 years 1 month ago
Joined: 2008-02-05 11:22
I know

I mean, it works if I manually replace the spaces with _, and it would be nice if the updater did this automaticly for me. Also, yes, proxies do work, but I am using a school PC, and I need to use a web proxy to download anything, like proxydust or math-read. I would like to be able to tell the updater to use those proxys, just like I can tell firefox to do so.

Simplifying daily life through technology

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Preview for next version (BETA1)

This version will have the following changes:

* no run checkbox in the installer (really Smile )
* skinned look (introducing a new skin for the updater)
* better version check (only packages with higher version number than local)
* only packages for installed Apps as default
* GUI (with multi-lang support) to change all settings (including target path and
proxy settings)
* license page and directory page removed
* new icon (thanks again to Zé Pedro)

I think this is worth to call it BETA1 isn't it?

Paid for Software more or less?
What You need is OSS!

KickButts
KickButts's picture
Offline
Last seen: 12 years 2 months ago
Joined: 2008-03-13 09:58
I can barelly wait for that...

What's the ETA?

By the way, congratulations for the good work.

Alive and kicking!
"If you were a robot, and I knew but you didn't, would you want me to tell you?"

Simeon
Simeon's picture
Offline
Last seen: 7 years 11 months ago
DeveloperTranslator
Joined: 2006-09-25 15:15
cool

I really like it now and I think these changes will make it better.
Am I right that you'll drop the checkbox completely? Cause I liked it. Maybe dont have it checked by default cause none of the Apps here do that. But keeep it.
Another thing I think is great is the "having installed Apps pre-checked by default"-thing. I think it makes it easier.
One last thing: I think the "loading - please wait"-splash at the beginning could be bigger. Not as big as the normal splashs but not as tiny as it is now.

"What about Love?" - "Overrated. Biochemically no different than eating large quantities of chocolate." - Al Pacino in The Devils Advocate

ZachHudock
ZachHudock's picture
Offline
Last seen: 4 years 8 months ago
Developer
Joined: 2006-12-06 18:07
John asked him to remove

John asked him to remove that checkbox because it's not "official" since none of the other apps use it.

The developer formerly known as ZGitRDun8705

José Pedro Arvela
Offline
Last seen: 3 years 8 months ago
Joined: 2007-07-10 07:29
What do you mean with...

What do you mean with skinned look? It will look like the menu and have skins?
If it is that... not a bad idea, but leave an option for default look.

It isn't worth of calling BETA1... It is worth of calling Beta 1 Biggrin

BTW, it isn't ptm, but ptmb. The nic is full, ptm isn't a personal name (neither pseudonym), so the b is kept.

And I though I said John he could change my nick with my complete name. I think that I am a (sort of) developer. I keep the pt-PT translation in some apps (2) and make the icons for the updater (for now).

Blue is everything.

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Fixed ...

... in the original post Smile

Paid for Software more or less?
What You need is OSS!

José Pedro Arvela
Offline
Last seen: 3 years 8 months ago
Joined: 2007-07-10 07:29
Thanks

Thank you. Smile

Blue is everything.

eresele
Offline
Last seen: 5 years 6 months ago
Joined: 2007-10-28 18:21
Info on setting up a server repository?

Could someone point me to where I can find information about setting up a server repository, please. I don't remember having seen that information in any of the PortableApps.com Updater 1.0 topics, yet. Thanks!

yrochon
yrochon's picture
Offline
Last seen: 6 years 7 months ago
Joined: 2008-03-17 07:49
Updater.ini not found

I just installed the application, and once I started it, I received the error message :
R:\PortableApps\PortableAppsUpdater\Data\updater.ini not found! 1033

So I decided to create this file, restarted the application, and then the file disappeared.

Any idea what's happening?

Thanks!

Signature automatically removed for containing links

ZachHudock
ZachHudock's picture
Offline
Last seen: 4 years 8 months ago
Developer
Joined: 2006-12-06 18:07
I had the same issue. The

I had the same issue. The issue is that you're proxy settings are not configured. Is your PC behind a proxy at work or a school? If so, you need to manually edit the settings file to tell it to connect to the proxy.

The developer formerly known as ZGitRDun8705

Unemployed Stor...
Offline
Last seen: 10 years 1 month ago
Joined: 2007-12-18 22:35
How So

How do I need to edit the setting file to get it working behind a proxy?

ZachHudock
ZachHudock's picture
Offline
Last seen: 4 years 8 months ago
Developer
Joined: 2006-12-06 18:07
It's not really well

It's not really well documented, but there is an example under /App/DefaultData in settings.ini.

Section 'Proxy' tells the program the adress (IP:Port)
and if needed and set the Username and Password of Your proxy.
Set it to 'auto'and the program will use the proxy settings of the logged in user
who has started the program (no Proxy authentification supported).
Set it to blank or don't use it and the program will connect without proxy settings (default).

[Proxy]
Proxy_Adr=proxy_address:port_number
Proxy_User=proxy_username(may or may not be needed)
Proxy_PW=proxy_password(may or may not be needed)

Add the above code to your Settings.ini that is located in /Data

The developer formerly known as ZGitRDun8705

odin81
Offline
Last seen: 4 years 4 months ago
Joined: 2008-04-15 17:02
Hi, the updater is great.

Hi,

the updater is great. But I can't use it at work, since our proxy is blocking wget, only IE and Firefox is allowed.

Is it possible to implement a switch in the config file to set the user-agent.
Or maybe a switch to set additional command line options for wget?
That would be great.

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
what additional options...

... do You mean?
I was thinking about a switch to use NSISdl instead of wget. But this is very buggy (no ftp with proxy, several problems with proxy authentification).

Tell me what options do You need and we will see.

Marko

Paid for Software more or less?
What You need is OSS!

Stevoisiak
Stevoisiak's picture
Offline
Last seen: 3 years 1 month ago
Joined: 2008-02-05 11:22
Me

I'm not sure about him, but I want to use a web proxy to download.

Simplifying daily life through technology

yrochon
yrochon's picture
Offline
Last seen: 6 years 7 months ago
Joined: 2008-03-17 07:49
Behind a proxy

Right, I'm at work and behind a proxy, so I'll try to set the Settings.ini file to see if it works better.

Thanks for the advice!

[...]

Once I setup my Settings.ini file with blank, I just receive "No actualization needed" message box, at work and at home :
Proxy_Adr=
Proxy_User=
Proxy_PW=

I'll see once I know there is a new version of my applications.

Signature automatically removed for containing links

odin81
Offline
Last seen: 4 years 4 months ago
Joined: 2008-04-15 17:02
User-Agent

hi,

I mean this wget option (this is only an example)
--user-agent="Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7"

So for the proxy this looks like wget is a Firefox browser.

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
could be added...

to the updater options.
Perhaps is is in Beta1.

Paid for Software more or less?
What You need is OSS!

gmatyola
Offline
Last seen: 11 months 2 weeks ago
Joined: 2007-01-08 12:29
Use WordFunc.nsh/Wordfind to find spaces?

Marko:

I'm not certain about why you can't have spaces in the temporary install directory (is it a WGET limitation?), but you can use Wordfind from Wordfunc.nsh to find the spaces instead of doing it yourself in the code...

so...

  ;=== compare value of ini fileCall the CheckForSpaces function.
  Push $INSTDIR # Input string (install path).
   Call CheckForSpaces
  Pop $R0 	;=== The function returns the number of spaces found in the input string.
 
  ;===  Check if any spaces exist in $INSTDIR.
  StrCmp $R0 0 NoSpaces

can be replaced by...

;=== compare value of ini fileCall the CheckForSpaces function.
;  Push $INSTDIR # Input string (install path).
;   Call CheckForSpaces
;  Pop $R0 	;=== The function returns the number of spaces found in the input string.
; Can do this with ${WordFind} of wordfunc.nsh.
  ${WordFind} "$INSTDIR" ' ' "*" $R0
  ;===  Check if any spaces exist in $INSTDIR.
  IntCmp $R0 0 NoSpaces

...and you can ditch the "CheckForSpaces" function. Just make sure you put the following in the headers:

!include "WordFunc.nsh"

!insertmacro WordFind

Thanks for your good work on this!

[Double post removed by moderator SL]

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Thank You :-)

Will be added to Beta1.

... and You are right, it is a wget problem.

Paid for Software more or less?
What You need is OSS!

ZachHudock
ZachHudock's picture
Offline
Last seen: 4 years 8 months ago
Developer
Joined: 2006-12-06 18:07
i'm not sure how you're

i'm not sure how you're doing things exactly, or if wget will recognize it, but couldn't you pass wget the path in quotes so it can see the full path?

The developer formerly known as ZGitRDun8705

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
The path is allready quoted ...

... but it don't work Sad

Paid for Software more or less?
What You need is OSS!

gmatyola
Offline
Last seen: 11 months 2 weeks ago
Joined: 2007-01-08 12:29
Spaces...

Okay, I took a brief look at this, and it seems to be fine with spaces on Windows XP Pro and Home. (Both SP 2)

I recompiled with the source out of the .paf package (and for some reason, mine has the "half-components" window as before), but spaces in the path seem to work absolutely fine. NSIS version is 2.37, freshly downloaded.

It even creates the directory if it doesn't exist and it has permissions to do so.

Possible thoughts: Is it running into a non-ascii character and is that causing wget to fail?

Also: It might be beneficial to have the "Back" Button go "back" to the Options dialog. I'm working on some code to do this, but I also want to try to use nsDialogs, which might make things easier in the long run. But it's good practice for me anyhow. Smile

Ryan McCue
Ryan McCue's picture
Offline
Last seen: 12 years 12 months ago
Joined: 2006-01-06 21:27
Subversion?

I know I've said it before, but I think it'd be a good idea to add this to the PA Subversion (assuming you have write access, I'm pretty sure you do because I think I do).
I could work on it a lot easier if this was done, as at the moment, I'm tempted not to touch it.

"If you're not part of the solution, you're part of the precipitate."

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
I'll try to upload Beta1 to PA Subversion on monday...

... than we will se if it works Wink

BTW: If you still interessted in taking over Inkscape Portable ... a new version is out Wink

Paid for Software more or less?
What You need is OSS!

Ryan McCue
Ryan McCue's picture
Offline
Last seen: 12 years 12 months ago
Joined: 2006-01-06 21:27
Yay!

If it does, I'll see if I can merge some of my changes from the old alpha into it.

And I think Jwyanze said he'd take it from me (he asked me on IRC).

"If you're not part of the solution, you're part of the precipitate."

Steve Lamerton
Steve Lamerton's picture
Offline
Last seen: 9 years 1 week ago
Developer
Joined: 2005-12-10 15:22
I

hate to seem like a pain, but could you change the folder name to updater as the PortableApps is implied by the fact it is in the repository, and I think keeping it all lower case would keep it neat, in fact hopefully when the menu gets put up there it will go in a folder called menu.

Also by the look of things the source isn't actually up there, it would be better if you deleted the whole folder called files and replaced it with one called trunk in which you would need to put the .nsi files. That way if a branch is ever need them it can easily be created in a new folder called branch, an example is the toucan bit of the repository, see here.

Smile

José Pedro Arvela
Offline
Last seen: 3 years 8 months ago
Joined: 2007-07-10 07:29
How do I download...

How do I download several files at a time, do I need a SVN client? Which is best? Can I download an entire folder trough the web interface?

I wanted to check the translations I made, clean up everything and e-mail them to Marko before the official beta. Smile

Blue is everything.

Ryan McCue
Ryan McCue's picture
Offline
Last seen: 12 years 12 months ago
Joined: 2006-01-06 21:27
Rename it yourself

You can rename it yourself Steve and let Marko svn up. I'll do it now though.

Edit: Done. I'll rename files/ to trunk/ now.

"If you're not part of the solution, you're part of the precipitate."

Steve Lamerton
Steve Lamerton's picture
Offline
Last seen: 9 years 1 week ago
Developer
Joined: 2005-12-10 15:22
I

know, I just thought I would let everyone know what was happening!

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
First try to upload ...

... and if I said in the commit comment 'preparation to upload the beta1 source'
Let me some time to remove old stuff from the source.
As I said it before, I'll upload it on Monday.

Paid for Software more or less?
What You need is OSS!

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Ok...

... I will upload last Inkscape to svn to Wink

Paid for Software more or less?
What You need is OSS!

gmatyola
Offline
Last seen: 11 months 2 weeks ago
Joined: 2007-01-08 12:29
Quote problem

I'll take a look at it and see if I can't figure out why it breaks.

arnie1066
Offline
Last seen: 13 years 8 months ago
Joined: 2008-04-14 16:02
A few Thoughts...

I have just installed this and immediately got into an infernal loop, install, update, new update, install... yada yada.

I cant remember how i broke out of it but it appears to be OK now.

Thought1 - Spaces... now dont shout, i understand you dont like them, cant use them however, the default install path that is displayed, is a dos truncated version of a path with spaces! So could you not just resolve the path into its dos equivalent? ie for /documents and settings/, use /docume~1/

Thought2 - Installed vs Available apps. Is it possible to colour code the apps that are installed?

Thats all for now

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Update: This issues are fixed in Beta1 ...

*no loops in selfinstall
*only installed Apps as default (if all packages are shown, the ones for installed packages are preselected to separtem tem from the not installed)

I have found a solution for the path with space. Remember it was not I don't like it, its an wget issue...
Fixed in Beta1 Smile

Paid for Software more or less?
What You need is OSS!

sysadmn
Offline
Last seen: 5 years 8 months ago
Joined: 2007-12-13 11:17
Proxy Authentication Working

Downloaded Alpha 7 and re-installed it. The proxy auth issues I reported at https://portableapps.com/node/12584#comment-78020 are gone.

I had to completely remove the portableapps/portappsupdater directory. I would guess it's because I had changed some of the settings.ini and .wgetrc files, and the 6 -> 7 upgrade preserved them. Unfortunately I did not think of that before testing 7 the first time.

Great work - this is the app I've been waiting for since John's first update Smile

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Your Welcome ;-)

Thank You all for the feedback and testing!

Paid for Software more or less?
What You need is OSS!

arnie1066
Offline
Last seen: 13 years 8 months ago
Joined: 2008-04-14 16:02
List Detail Wrong/Missing

Updater today only seems to find one of my installed files, ClamWin (and is asking me to update to an older version. (.93 to .92)

None of my other apps:
Firefox
OpenOffice
Notepad++
PokerTH
Miranda
Mines
Soduku
Sunbird
VLC_Viewer
WinDirStat

have any Versions in the (local:) section. Of those not seen, Notepad++ is the only one which has the default install directory. (ClamWin also does)

If the apps is simply ignoring the others as they are up to date, it would be handy if it showed the Local Version anyway as at the moment, this is the only way to tell they are installed within the app.

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Some answers...

The actual database is outdated and will be up to date with Beta1 (cause there are some changes in the db structure).

If an App isn't installed, local version is "", this could be changed to whatever we want (in Beta1 You'll only see this Apps if You set the option to show all instead installed Apps).

The Updater is designed to offer only packages if newer versions are available, cause this makes the App list as short as possible. I could set up an option to show up to date packages de-selected an greyed out, if a lot of people vote for this feature...
BTW: You can see in the Menu wich packages are installed.

Paid for Software more or less?
What You need is OSS!

RogerL
Offline
Last seen: 1 day 11 hours ago
Joined: 2007-03-14 09:17
could set up an option to

could set up an option to show up to date packages de-selected an greyed out, if a lot of people vote for this feature...
I vote for it!

BTW: You can see in the Menu wich packages are installed.
Not if you don't use the Menu. PAM is impractical for me without categories/folders. Longing for 1.5 to come out! (I have tried the mods, but prefer the simplicity of ASuite, it's classic view, and it's non-scrolling mode)

BTW it was nice to see all the Alpha versions, but since the Beta was anounced you haven't posted any updates...

arnie1066
Offline
Last seen: 13 years 8 months ago
Joined: 2008-04-14 16:02
Version and updates

Could we have the version number shown on the App itself.

"BTW: You can see in the Menu which packages are installed."

Which Menu do you mean, because my PA menu doesn't.

If an App isn't installed, local version is "", this could be changed to whatever we want (in Beta1 You'll only see this Apps if You set the option to show all instead installed Apps).

This response confused me slightly, I have all of the apps listed in my previous post installed. Yet the Local version is blank. ie "".

While switching between versions, i noticed that if the updater itself is required, the Space Required remains at 0.0KB

Also if the updater is required, its appears as a non optional update (ticked and grey). In my humble opinion, the app should not reach the selection screen but either auto download the update (as it only does this one then restarts itself anyway) or ask if you wish to continue and then perform its own update last.

arnie1066
Offline
Last seen: 13 years 8 months ago
Joined: 2008-04-14 16:02
Version and updates

Could we have the version number shown on the App itself.

"BTW: You can see in the Menu which packages are installed."

Which Menu do you mean, because my PA menu doesn't.

If an App isn't installed, local version is "", this could be changed to whatever we want (in Beta1 You'll only see this Apps if You set the option to show all instead installed Apps).

This response confused me slightly, I have all of the apps listed in my previous post installed. Yet the Local version is blank. ie "".
I can provide a snapshot if required

While switching between versions, i noticed that if the updater itself is required, the Space Required remains at 0.0KB

Also if the updater is required, its appears as a non optional update (ticked and grey). In my humble opinion, the app should not reach the selection screen but either auto download the update (as it only does this one then restarts itself anyway) or ask if you wish to continue and then perform its own update last.

BTW: Love the app, cant wait for it to 'go live'

José Pedro Arvela
Offline
Last seen: 3 years 8 months ago
Joined: 2007-07-10 07:29
@ Marko

Marko, I have seen you don't have any scripts for the Updater executable beyond the installer. Well, I would like to review the pt-PT translations before they land on a Beta (not grammar, but see if the context is right). So... could you add (even if unstable) versions of the updater to the svn so it is possible to test them?

And could someone provide info on how to download the files easily trough SVN to a SVN newbie?

Blue is everything.

Jacob Mastel
Offline
Last seen: 1 year 11 months ago
Developer
Joined: 2007-06-13 19:36
It's been working well

You're doing a great Job on this. I haven't been testing it super extensively but I have bee using it to update all of my apps. It seems to work very well for me I haven't run into any problems. I do have two suggestions though. The first is the icon doesn't look very perfessional to me. A cleaner icon would be good. Another thing is the list is a little confusing. Currently the menu options are: AppName, New Version #, (Local) (what does local mean?). What I would like to see is AppName, Old Version => New Version. Also if I don't have the app installed but I check the box will it install the app??

Release Team Member

Simeon
Simeon's picture
Offline
Last seen: 7 years 11 months ago
DeveloperTranslator
Joined: 2006-09-25 15:15
well...

"local" is the version of the copy installed on your USb drive.
IF you dont have an App installed and you check the box it will download and run the Apps installer.

"What about Love?" - "Overrated. Biochemically no different than eating large quantities of chocolate." - Al Pacino in The Devils Advocate

Stevoisiak
Stevoisiak's picture
Offline
Last seen: 3 years 1 month ago
Joined: 2008-02-05 11:22
Error

Database error
I:/PortableApps/PortableAppsUpdater/Data/Updater.ini not found! 1033

Simplifying daily life through technology

Stevoisiak
Stevoisiak's picture
Offline
Last seen: 3 years 1 month ago
Joined: 2008-02-05 11:22
Update

Uhh, macro? If you update your program, make a post so the topic is moved to the top

Simplifying daily life through technology

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Alpha8 is out...

... with one minor issue.

The radiobuton for the "delete package after installation" don't work. This will be fixed next version. If You want to save the packages set:
[Cleanup]
pdel=0
in settings.ini

Paid for Software more or less?
What You need is OSS!

odin81
Offline
Last seen: 4 years 4 months ago
Joined: 2008-04-15 17:02
wget options

hi,

wow, the new version is really a big footstep.
and thanks for implementing the wget options feature. the only problem is, that the updater doesn't use this options at the beginning, when the database is fetched.

would be great when it uses the wget options at this stage, too.

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
fixed next version ...

... I saw it yesterday too Smile

Paid for Software more or less?
What You need is OSS!

arnie1066
Offline
Last seen: 13 years 8 months ago
Joined: 2008-04-14 16:02
No Actualisation Needed

No what now?

I get this message every time since i did a fresh install

4 Things:

#1
OK so i do know what it means, but i disagree.

If you dont tick the 'Only Installed' then this becomes a great way to install new apps without having to go to the website. It is also a good way to find out what version of apps are installed without starting them all up manually.

In my humble opinion, the message should be a little more friendly and should still be an option (or at least an option depending on your settings) EG:

No Updates Required
[Continue] [Exit]

What does everyone else think?

#2
I have ticked the Show options Dialogue, but this message box and its resulting closure is stopping me from seeing it, its there in the background but disappears with the message box.

#3
It asks me what language i want to use EVERY time i start the app. I suspect this is due to the choice not being written to file as the app doesnt fully start (see #1)

#4
The options tend to be a bit daunting, the average user may not know what database your on about much less where they should put it. (Maybe "if blank" ../portableappsupdater/data)

Also at the bottom are several options to show or not to show certain dialogue boxes. Not all of there names make it obvious what their functions are... Would expand but cant get back to the options window at the moment (see #3)

Apart from not being currently Useable - Love the app

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
That is the problem of every advanced usage ...

... if You see all possible options You can use it Smile

If You don't understand an option, simply use the defaults or ask for it (at the moment there is no help for the options dialog is present).

#1 If the native english speakers Your sentence like better, no problem we can change it:-9

#2 right, that is, what's the option means (uncheck it and You'll never see the option dialog again until You'll set
[Show]
Options=1
in the settings.ini (next version will come with a commandline switch for it)

#3 right, that's why the environment variable is not set by the suite at the moment. Next version will check for the ini entry too to prevent multiple language questions.

#4 see above

Paid for Software more or less?
What You need is OSS!

arnie1066
Offline
Last seen: 13 years 8 months ago
Joined: 2008-04-14 16:02
Just Waiting...

... for someone to update an app so i can check it out a bit more Smile

However, as i didn't set 'Installed Apps Only' Shouldn't the program start and allow me to see the programs not yet installed?

José Pedro Arvela
Offline
Last seen: 3 years 8 months ago
Joined: 2007-07-10 07:29
Nice

The new Updater looks great. It turns out the pt-PT language is Ok. I like the option to update only new apps from the beginning.

Keep on with great job, is all that I have to say.

Blue is everything.

Patrick Patience
Offline
Last seen: 2 years 9 months ago
DeveloperModerator
Joined: 2007-02-20 19:26
Nice

Alpha 8 is SWEET Marko. I really like proxy support, as well as a custom location for the downloaded packages and option for no delete, as I like keep them myself. I will be using this instead of manually downloading now.

If I see any bugs or anything, I'll be sure to let you know.

John T. Haller
John T. Haller's picture
Online
Last seen: 9 min 14 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Too Complicated

The interface should be as unobtrusive as possible and instead a user gets hit with an advanced options window as the first screen. The advanced options should all be hidden by default.

I'd actually recommend having it as a page after welcome. When clicking next from Welcome, it attempts to connect directly... if that fails, attempt to get the proxy from the registry. If that fails, head to the manual proxy page. The ability to hide welcome, etc shouldn't be on that config page... just in the INI is fine. Same with the advanced wget options, database location, etc. The interface should have options for 99% of users. The 1% of advanced users can use config files (just like about:config in Firefox, etc) rather than cluttering up the interface and confusing regular users.

FOOTNOTE: Sorry if the above sounded crotchety or personal... the updater is coming along very well Smile Just the initial user experience needs some polish before we call it a beta.

Sometimes, the impossible can become possible, if you're awesome!

Patrick Patience
Offline
Last seen: 2 years 9 months ago
DeveloperModerator
Joined: 2007-02-20 19:26
I Agree

I love the features, but for normal users it's too much. Having the option to go an advanced route is a better idea.

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
constructive feedback is never crotchety or personal ...

... it is the best way to get things better Smile

But if 99% of users use the defaults I think the best solution is really to hide the config page as default and show it (once) only if the updater is started with the commandline parameter /SHOWOP. I think proxy=auto (use ie settings) is good for 99% of the users too (cause most of them - if they need a proxy - know where and how to set it in IE) all others should use the advanced mode.

What do You think?

Paid for Software more or less?
What You need is OSS!

App Guy
Offline
Last seen: 8 years 11 months ago
Joined: 2008-03-16 14:24
Help

Where is the Help.html file?

May the Shwartz be with you

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 11 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
help is on the root of the updater ...

... but not finished yet.

Paid for Software more or less?
What You need is OSS!

Stevoisiak
Stevoisiak's picture
Offline
Last seen: 3 years 1 month ago
Joined: 2008-02-05 11:22
Few things

1. If you are going to embed the installers in the system data folder, (Which the average user may not know aqbout) or even if it's stored anywhere, I thing they may want it to be deleted by defalt. Especially if they run it on a public computer where they cant remove it.

2. Make a tool bar or check mark for advanced options. I dont want it at start up.

3. Database error
I:/PortableApps/PortableAppsUpdater/Data/updater.ini not found!

Simplifying daily life through technology

Pages

Topic locked