You are here

Outdated: PortableApps.com Updater 1.0 ALPHA 9

305 posts / 0 new
Last post
MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 7 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Yes it is ...

... start the configuration with /SHOWOP,
and set 'package directory' to the folder You want.

Paid for Software more or less?
What You need is OSS!

Glenn
Offline
Last seen: 7 years 2 months ago
Joined: 2005-12-12 00:56
Starting configuration with /SHOWOP

Maybe I'm missing something but what file do you run to configure the application?

Simeon
Simeon's picture
Offline
Last seen: 7 years 8 months ago
DeveloperTranslator
Joined: 2006-09-25 15:15
The file

PortableAppsUpdater.exe with the switch /SHOWOP.

"What about Love?" - "Overrated. Biochemically no different than eating large quantities of chocolate." - Al Pacino in The Devils Advocate

Glenn
Offline
Last seen: 7 years 2 months ago
Joined: 2005-12-12 00:56
Thanks, I'd already tried

Thanks, I'd already tried that and it didn't work but it is working now!

r.andom
r.andom's picture
Offline
Last seen: 13 years 10 months ago
Joined: 2007-11-12 15:11
Alphabetical order

At the moment the updater presents the applications in the order they are listed in updater.ini. Can you manage to present the applications in alphabetical order, please? That would speed up finding a certain application in the updater list ...

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 7 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
This should be, but ...

... the problem is, that the quickest way to include the new apps without an selfupdate is to add it at the end of the database.

With every update (like the comming Beta) the entries will be sorted in the database.

At the moment there is no way to perform a sort of the entries, cause there is no direct support for arrays in NSIS. There are some work arrounds and array fake functions but most of them are buggy or non-perfomant Sad

Paid for Software more or less?
What You need is OSS!

r.andom
r.andom's picture
Offline
Last seen: 13 years 10 months ago
Joined: 2007-11-12 15:11
.wgetrc

The updater uses wget.exe for downloading the needed files. How does it take the configuration file .wgetrc into account?

I made a change to .wgetrc (progress = bar) but without success.

Reading the wget documentation it seems that there should be an environment variable (WGETRC or HOME) for wget to find its configuration file. I couldn't see such a variable when using the updater. But maybe you used another solution, Marko?

laynelab
Offline
Last seen: 9 years 2 months ago
Joined: 2008-03-25 09:05
updater.ini not found!

OK, call me dumb. What is the entry to which *.ini file to make Proxy setting automatic as I am trying to use it on a network

lane

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 7 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Please read the release notes ...

... start the configuration with /SHOWOP,
and set proxy settings to what You want.

Paid for Software more or less?
What You need is OSS!

Glenn
Offline
Last seen: 7 years 2 months ago
Joined: 2005-12-12 00:56
Running the config utility

What about putting a button to run the config utility on the PortableApps Updater so that things can be checked /corrected before items for updating are selected?.

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 7 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
Nope ...

... cause there was a strong request to design the updater for the over 90% users which use default settings. The advanced usage is only for experienced users.
A button is easy clicked, also by newbies. Commandline usage tells You 'hey, You'll perform more than a normal start!'

Paid for Software more or less?
What You need is OSS!

App Guy
Offline
Last seen: 8 years 8 months ago
Joined: 2008-03-16 14:24
updater.ini

When I start PAUpdater it says updater.ini is not found. When I put updater.ini in the Data folder, it still says that it is not in there. What am I doing wrong?

edit:Ok I got the whole /showop thing but what am I suppose to put in the configurations page.

May the Shwartz be with you

r.andom
r.andom's picture
Offline
Last seen: 13 years 10 months ago
Joined: 2007-11-12 15:11
Updater crashes on unexpected html file

When trying to update Coolplayer+ to v.2.19.1 the SF mirror forwards to mirrorservice.org which delivers an index.html instead of the wanted binary. The updater can't handle this and crashes Sad

The temp files on the hard disk are left behind. They even aren't deleted on next start of the updater.

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 7 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
don't know the reason for this issue

... at the moment Sad

Paid for Software more or less?
What You need is OSS!

r.andom
r.andom's picture
Offline
Last seen: 13 years 10 months ago
Joined: 2007-11-12 15:11
No filename

I tried to track down this issue. The updater normally tells wget to fetch http://ser.ver.name/path/to/filename. But with Coolplayer+ it doesn't tell wget the filename, only a slash (http://ser.ver.name/path/to//), as I could detect in wget log file. So SF can't deliver the file.

Not being a developer it's difficult to investigate the source but I've got an idea: Coolplayer+ is app 43 in updater.ini. Marko, are you sure "StrCpy $OName S43" in PortableAppsUpdater09.nsi is correct? For all apps except S41 and S43 there is no 'S' in front of the app's number. I imagine this could be the reason for not telling wget the filename.

Am I right?

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 7 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
You are so right!!!

I must be blind Sad
Thank You for finding this ugly typos!

Will be fixed with Beta1.

Paid for Software more or less?
What You need is OSS!

r.andom
r.andom's picture
Offline
Last seen: 13 years 10 months ago
Joined: 2007-11-12 15:11
Wrong version number in updater.ini

Infrarecorder was last updated to v.0.45.0.2 (according to appinfo.ini) but the updater states it knows about v.0.45.1.0 as last version (according to updater.ini). So the versions don't match and the updater tries to update the program again on each run ...

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 7 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
fixed ...

thx for the hint.

Paid for Software more or less?
What You need is OSS!

r.andom
r.andom's picture
Offline
Last seen: 13 years 10 months ago
Joined: 2007-11-12 15:11
Double mirror

In updater.ini one SF mirror has two entries: heanet is number 001 as well as number 005 ...

BTW: Why the updater doesn't use the SF geographical locator? Sometimes when the updater gives me a mirror in another continent the performance is poorer than necessary.

r.andom
r.andom's picture
Offline
Last seen: 13 years 10 months ago
Joined: 2007-11-12 15:11
No updates because of wrong MD5 hashes

The updater doesn't do its work for some apps because some MD5 hashes in updater.ini are wrong. They are from outdated versions. For example WinMerge 2.8.4 is offered but the MD5 hash is the one of version 2.8. Same applies to Pidgin 2.4.3 (MD5 is the one of v.2.4.2). Please control if other applications are affected, too.

Proposal: When creating the actual updater.ini MD5 hashes should be generated automatically and double checked to avoid such errors!

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 7 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
This version is ALPHA ...

at the moment I have to set the entries with the values from the app websites.

The reason for the wrong md5 hashes and the last problems is simple, at the moment I have to update two databases (Alpha9 an the one for the comming Beta 1 which is different in some points). Its double work at the moment and thats why there was some mistakes.

BTW: It is easy to use !!! , but it isn't really helpful Smile

With Beta 1 John will set the entries at the same time like the release.

At the moment there is no way to create the entries automatic, but up to beta 1 it is part of the publishing process

Paid for Software more or less?
What You need is OSS!

r.andom
r.andom's picture
Offline
Last seen: 13 years 10 months ago
Joined: 2007-11-12 15:11
Blank in SName

At the moment Coolplayer+ 2.17.1 is installed on my flash drive. The updater doesn't offer me an update to v.2.19.1 but handles this program as a not yet installed new software.

Could it be that there shouldn't be a blank in SName in updater.ini? I'm not sure because I detected an other application with a blank in SName (LBreakout2).

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 7 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
It was the blank ...

... the updates will be offered yet but sf still deleivers the ugly index pages instead of the package Sad

Paid for Software more or less?
What You need is OSS!

r.andom
r.andom's picture
Offline
Last seen: 13 years 10 months ago
Joined: 2007-11-12 15:11
Parallel update series

With most applications the update policy is easy: There's only one release version at a given time.

But there are some applications like Mozilla Firefox with two release versions at the same time. At the moment v.2.0.0.x and v.3.0.x are released parallel until the end of this year. The updater doesn't offer both series at the moment.

I would really appreciate a possibility to differentiate the update policy because I prefer the v.2.0.0.x series until the v.3.0.x series is less performance hungry.

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 7 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
The problem is ...

... that these Apps use the same directory for both releases. If the package directory for the old series will be changed we can offer both series.

But I can add an entry for the old series an set the SName to another dir (like Firefox2). So You are able to rename Your install dir (but You have to change the target path for each update to Firefox2). Its up to John if he is willing to support the ols series in the future an change the packages.

Paid for Software more or less?
What You need is OSS!

r.andom
r.andom's picture
Offline
Last seen: 13 years 10 months ago
Joined: 2007-11-12 15:11
SF mirror list in updater.ini

At the moment there is a fixed list of some SF mirrors to download the updates. But there are some issues with this list:

- The updater selects a random SF server, not the best located one.
- SF changes the servers from time to time, so you have to manually follow these changes. (Atm it seems there is a big change in the North American server locations)

To avoid these problems and to avoid unneeded work, why not use dl.sourceforge.net as the only server? Via DNS this hostname gets resolved to a list of mirror IPs with a nearby located one at the first place. And wget can handle this, other than the redirection SF pages.

Or are there any side effects I don't overlook?

MarkoMLM
MarkoMLM's picture
Offline
Last seen: 6 years 7 months ago
DeveloperTranslator
Joined: 2006-01-16 04:08
I'll check it out ...

... if this is a solution for the problem with the page redirection bug I'll change this.

Paid for Software more or less?
What You need is OSS!

orca
Offline
Last seen: 13 years 11 months ago
Joined: 2008-07-08 14:15
Update the Updater?

This app has been working well for me. Can this app update itself or notify me that an update is available?

r.andom
r.andom's picture
Offline
Last seen: 13 years 10 months ago
Joined: 2007-11-12 15:11
Self update

The actual alpha can update itself. What version are you using?

orca
Offline
Last seen: 13 years 11 months ago
Joined: 2008-07-08 14:15
0.9.0

0.9.0

r.andom
r.andom's picture
Offline
Last seen: 13 years 10 months ago
Joined: 2007-11-12 15:11
That's ok

Your version is up to date. It will autoupdate when Beta 1 comes out.

orca
Offline
Last seen: 13 years 11 months ago
Joined: 2008-07-08 14:15
Thanks

Thanks for sharing this helpful info!

Tynen
Offline
Last seen: 12 years 11 months ago
Joined: 2006-06-20 02:14
Wonderful

The last version of this I had was 7. The alpha9 version is very useful. It is working like a charm for my set up. Thank you very much!! This will be a wonderful addition to the portable apps collection when it's done. Even now it's amazing.

Everyone make sure to vote on SourceForge for portable apps!! Smile

I do have a quick question about it. Why doesn't it continue to download updates while it's installing new versions? My flash drive is pretty slow so it takes a while for programs to install. I was just curious why it doesn't continue downloading updates in the background.

Cheers Smile

r.andom
r.andom's picture
Offline
Last seen: 13 years 10 months ago
Joined: 2007-11-12 15:11
One by one

The apps are downloaded and unpacked to your %TEMP% folder. If the drive with this folder (usually drive C:) lacks free space installation will fail. To avoid this it's better to do it one by one and to delete each app's temp files after installing it (and before downloading the next one).

Pages

Topic locked