You are here

Thunderbird resets to previous date (and vers)

7 posts / 0 new
Last post
SirVival
Offline
Last seen: 13 years 10 months ago
Joined: 2008-05-01 13:46
Thunderbird resets to previous date (and vers)

Hi,
once in a while Thunderbird portable starts downloading POP3 massages that should be already on disk.
If this happens all sent email prior to the date of the first "new" inbox is lost.

Since I am lazy with backups this is kind of annoying.

And I have to sort lots of email if it happens (the junk ones are back too).
I got allot of filters running but not for everything.

It happened when I had Portapps on a Flash drive, it happens now on my external 1.8'' drive.

But the most annoying thing is that Thunderbird is now back to ver 2 while it should be ver 3.

Unrelated:
Sometimes my IMAP folders loose their contents completely (all massages have to be downloaded again). It happens more often then the POP issue (no back to ver 2).

Maybe this helps: at the same time Firefox 3.6 Portable is also reset to a previous state (tabs are open which are from an old session).

What is the cause of this?

Portapps is up to date

Thanks

ottosykora
Offline
Last seen: 2 weeks 4 days ago
Joined: 2007-10-11 17:48
this is not possible

>But the most annoying thing is that Thunderbird is now back to ver 2 while it should be ver 3.

Otto Sykora
Basel, Switzerland

J Neutron
Offline
Last seen: 1 month 1 week ago
Joined: 2008-06-10 19:26
Original upgrade was separate

You've got it right, I think.

If I remember correctly, the initial TB version 3 distribution installed itself to a different directory to preserve the existing installation during the testing phase.

The OP probably has both 2 and 3 on the drive and sometimes picks one or the other to run, giving the effect reported.

On a side note, "being lazy with backups" and then complaining about loss of data points to a solution so OBVIOUS that I won't even bother typing it.

neutron1132 (at) usa (dot) com

SirVival
Offline
Last seen: 13 years 10 months ago
Joined: 2008-05-01 13:46
Hi thats it. There was

Hi thats it.
There was another Thunderbird folder.
I did not notice it at first since it was not in the main Portapps folder but one level above. I can not say if this was the real issue since I did reinstall TB3 just before noticing the folder. But I guess so.

I use Portapps not on a stick I installed it on harddrive.
I like that it is independent of the Windows installation that way.
If my PC breaks down I still have my Email and Bookmarks save.
And be online in no time on another PC.

And backup is easier that way.

I usually do a backup once a month (on Raid5; I know not perfect but there is no perfect backup I guess); not only Portapps but everything important.

Still:
The IMAP looses all contents (just recently happend). Not a big Problem but annoying because it takes up time.

What could be the issue?

Thanks

PS: the reason for my post was that I had problems when I used a flash drive and TB2. Once in a while it would start to download mail that was already on disc. Thats why I thought this could be something similar.

ottosykora
Offline
Last seen: 2 weeks 4 days ago
Joined: 2007-10-11 17:48
imap

>Still:
The IMAP looses all contents (just recently happend). Not a big Problem but annoying because it takes up time.
Once in a while it would start to download mail that was already on disc.

Otto Sykora
Basel, Switzerland

SirVival
Offline
Last seen: 13 years 10 months ago
Joined: 2008-05-01 13:46
Hi, I marked IMAP for local

Hi,
I marked IMAP for local download.
Server update might be the case.
But I have two IMAP accounts.
One at my current university one on my previous.
I doubt both update their server at once.
Can it be that if I use thunderbird at university it makes thunderbird at home update?
I will try it out.
Also mails already read at university are marked unread at home.
Still does not explain why the IMAP of my previous university resets (I do only download those messages at home).

What I meant with "downloads emails already on disk" is that it downloads all the messages that are still on the server.
That is a couple of hundred messages.
Is this log about all downloaded messages?
That would explain the behavior.
It happened more often when I still used a SD Card flash disk.
It never happened on hard disk install and I use Thunderbird since version 1 (I think could be 1.5 also).
I first thought it had to be an issue with the flash disk (which did fail three month after the "issue" appeared the first time).
On the SD Card flash disk it happened once a week. The easy way was to close Thunderbird via Taskmanager and reopen it (it would not resume the download).

I posted because it now happened on hard disk install (no "issues" since I switched from SD Card to hard disk which was three month ago).

Thanks

PS: random thought: I got a SSD disk and disabled the timestamp for last access on files to keep the wear level low. Could that be related?

dodi
Offline
Last seen: 2 years 1 month ago
Joined: 2010-10-15 09:26
IMAP issue related to corrupted data on flash card?

What about this possible reason: After a Windows collapse for whatever reason with a flash card connected to the system, Windows checks the integrity of the flash card when you restart Windows. Perhaps Windows "repairs" some file structure during this integrity check even if it says that no errors where found. When running TB portable next time it might not find some data and downloads the whole IMAP mails again.
SirVival, did you observe such integrity checks when you were using TB from SD card?

Log in or register to post comments