You are here

unable to remove usb stick

13 posts / 0 new
Last post
ottosykora
Offline
Last seen: 1 day 34 min ago
Joined: 2007-10-11 17:48
unable to remove usb stick

Since some recent times, I am unable to eject the stick after it has run the suite.
When I just connect it and copy something from or to it, no problem, the windows driver (green arrow) works and will eject the stick.

However once I start the suite, it does not matter how I close it, windows reports 'still accesed by some programm' and thus the stick can not be stopped.

This hapends only on my xp machine, w7 and w2k all is fine.

Any idea how to find out what is still stopping the eject mechanism to operate correctly?

sweepsnregs
sweepsnregs's picture
Offline
Last seen: 11 months 3 weeks ago
Joined: 2009-11-26 00:26
If killing

If killing StartPortableApps.com then allow u to eject it, then I didn't understand u. (I'm surprised u r baffled cuz u always have intel insights..among a few others..never nagging and criticizing eyes, so u r a-ok in my book!)

Btw, what's wrong with using Safely Remove Drive (Green Eject thingy) if it works? It's the only way I understand it tho I asked 1 time bout the X and the ^ @ bottom of PAM but I got the attitude instead. Sad how social skill challenged set refuse anything with improving that exact skillset that need improving. What ya gonna do?

I instead receptive and open minded so I can traverse both the people aspect and the tech aspect: being well rounded

End of my rant/venting (somewhat) frustration..but I'm mature (enuff)..to leave everything at the end of this period -> and move on.

ottosykora
Offline
Last seen: 1 day 34 min ago
Joined: 2007-10-11 17:48
just got caught by that

it never was a problem on any of my machines so far. Suddenly I got this problem so I have to start taking care about it somehow. No normal means of eject work. It used to work just from the suite or via the 'greenarrow' or even from the context menu in explorer. No nothing works at all, getting the famous 'can not be removed other prog is accesing it'

Will try the unlocker, thought there must be some other solution, it is just some windows snag playing fool on me.
All settings are to fast remove etc.

Otto Sykora
Basel, Switzerland

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 2 days 3 hours ago
DeveloperModerator
Joined: 2008-07-24 18:46
Please don't use text-speech

Please use Full words, rather than text abbreviations. Thanks Smile

Ken Herbert
Ken Herbert's picture
Offline
Last seen: 5 hours 15 min ago
DeveloperModerator
Joined: 2010-05-25 18:19
Try Unlocker Portable. Takes

Try Unlocker Portable. Takes a couple of steps to get it working, as it is a launcher only and you have to add the app files to it yourself, but once you get it, it works fine.

ottosykora
Offline
Last seen: 1 day 34 min ago
Joined: 2007-10-11 17:48
can someone assist me

with the unlocke?

I have the launcher and the latest installer. Extracted all files, entered the proper files to the poratble.
When running the unlockerportable, the app seems to start, there is some icon in the try and an icon in the context menu.
What next? How to use it?

When I right click on the usb stick drive, select the unlocker, I am getting error concerning some rights to debug, but nothing else happens.
It seems anyway to work under admin only.

After that I still can not remove the stick, windows gives still same msg.

Otto Sykora
Basel, Switzerland

ottosykora
Offline
Last seen: 1 day 34 min ago
Joined: 2007-10-11 17:48
found something strange

when I set my account to admin rights, all work normal, I can remove the stick either with the suite option or with the 'green arrow'.
When I go to the drive, properties, hardware, it is set to fast removal.

When I set my account to restricted as normal, the settings under properties, hardware are grayed out obviously, but the are set to optimize for performance and not as it should be for fast removal.

So this whole thing has to do only with the restricted account sets it itself to optimize for speed.

Any ideas which registry keys are operating this joke?

Otto Sykora
Basel, Switzerland

Ken Herbert
Ken Herbert's picture
Offline
Last seen: 5 hours 15 min ago
DeveloperModerator
Joined: 2010-05-25 18:19
Not sure what is going on

Not sure what is going on there, sorry.

I have only ever used it on PC's with full admin rights, and have never seen anything like that.

What *should* happen, is that you get a window open with a list of processes that are running from the device, which you can selectively kill processes and unlock files.

Someone with some more experience in using Unlocker may be able to help you out more, I only use it on rare occasions.

OliverK
OliverK's picture
Offline
Last seen: 1 year 3 months ago
Developer
Joined: 2007-03-27 15:21
kill explorer.exe with the

kill explorer.exe with the task manager and then start it up again.

Too many lonely hearts in the real world
Too many bridges you can burn
Too many tables you can't turn
Don't wanna live my life in the real world

prapper
Offline
Last seen: 1 year 8 months ago
Developer
Joined: 2008-01-24 17:01
Avast!

I found that the latest Avast! versions 5.1.864 (01/01/11) & 5.1.889 (14/01/11) are somehow locking my USB stick too. I was also having problems with this. Going back to Avast! 5.0.677 (08/09/10) sorted it all out. You can get it at FileHippo. No need to go into safe mode to uninstall, just Add/Remove.

Using XP SP3 as admin.

ottosykora
Offline
Last seen: 1 day 34 min ago
Joined: 2007-10-11 17:48
avast?

huuuuh, then we have to complain to them.
Yes I use avast, yes on this particuzlar machine I leave the avast update itself, on other machine with w7 I have the same version, but the usb eject mechanism is there anyway completely different and works.

Funny is, that when I use an account with admin rights, no problems, on restricted acc problems occure.

Otto Sykora
Basel, Switzerland

ottosykora
Offline
Last seen: 1 day 34 min ago
Joined: 2007-10-11 17:48
avast

I can confirm that the avast is the major culprit in this case. With version 50677 no problems of that kind.

I am at them moment in contact with avast , hope they will sort it out soon.

The problem is not the avast alone, since I have a xp system with similar installation and all works fine, but it looks as it is some problem with avast and java or java update service or so. This sill not 100% clear.

Otto Sykora
Basel, Switzerland

ottosykora
Offline
Last seen: 1 day 34 min ago
Joined: 2007-10-11 17:48
got avast6

the avast support gave me some link to get some avast 6 version, now all works again fine.

Otto Sykora
Basel, Switzerland

Log in or register to post comments