You are here

[Fixed] Daphne Portable 1.48 Error Message

5 posts / 0 new
Last post
VIC-20
Offline
Last seen: 4 years 9 months ago
Joined: 2010-06-27 13:34
[Fixed] Daphne Portable 1.48 Error Message

I just upgraded to Daphne Portable v1.48 from v1.47 and when I try to run it, I get the following error message:

Daphne.exe - Unable to Locate Component

This application has failed to start because mfc100u.dll was not found. Re-installing the application may fix the problem.

As per the suggestion, I re-installed it and the same message comes up.

What is the easiest way to resolve this issue? (i.e., How do I go about getting the mfc100u.dll file?) I am running a fully patched Win XP Home system and have never had any issues running Daphne Portable v1.47.

Thanks in advance for any and all help.

3D1T0R
3D1T0R's picture
Offline
Last seen: 1 year 6 months ago
Developer
Joined: 2006-12-29 23:48
New requirement for Daphne 1.48; Copy from Listary

One of the changes between Daphne 1.47 & Daphne 1.48 is that the author is now building Daphne using Microsoft Visual Studio 2010, due to this you will now need part of the Microsoft Visual C++ 2010 Redistributable Package [Download]. I believe however that the .DLL in question can legally be (and should be) distributed with the package, as it's currently included with Listary Portable, likely future versions will include this file, but in the meantime (and to make sure that this is the only thing necessary), try installing Listary Portable, and copying the "mfc100u.dll" file from the …\ListaryPortable\App\Listary\Win32 directory into the …\DaphnePortable\App\Daphne directory.

Please reply as to whether or not this fixes it for you, as it will likely occur for others, and if other changes are necessary they should also be included in future updates.

~3D1T0R

VIC-20
Offline
Last seen: 4 years 9 months ago
Joined: 2010-06-27 13:34
Two Missing Files

Thank you for the prompt reply, 3D1T0R!

For the record, and as I'm sure you're already aware, I currently do not have the Microsoft Visual C++ 2010 Redistributable Package installed on my system.

Rather than simply go ahead install it, and for my own curiosity, I elected to try out your logical solution to see if this one missing file was indeed the culprit. (Incidentally, I already had Listery Portable installed.)

This lead to a new error message though which read in part:

This application has failed to start because msvcr100.dll was not found.

I then copied this missing file from Listery Portable and voila! Daphne v1.48 started working as expected.

My only other question now is, would it be a good idea to install the Microsoft Visual C++ 2010 Redistributable Package on my system now anyway? I don't like to have anything unnecessary installed (especially from Microsoft), but if this would bring some added benefit, then perhaps I should?

Thanks again for your prompt reply and assistance as it is sincerely appreciated.

John T. Haller
John T. Haller's picture
Offline
Last seen: 2 hours 17 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Fix Coming

I've got the fix built and working. Just waiting for SourceForge to fix their download mirror issues to post it.

Sometimes, the impossible can become possible, if you're awesome!

John T. Haller
John T. Haller's picture
Offline
Last seen: 2 hours 17 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Fixed in Rev 2

This is fixed in 1.48 Rev 2 as it now includes these files by default.

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments