You are here

[Fixed] LibreOffice Portable 3.6.1 mistakenly offers to install VC runtime on Windows 7 SP1 (it comes pre-installed there)

5 posts / 0 new
Last post
shadowlmd
Offline
Last seen: 1 year 3 months ago
Joined: 2012-02-18 11:42
[Fixed] LibreOffice Portable 3.6.1 mistakenly offers to install VC runtime on Windows 7 SP1 (it comes pre-installed there)

Since all my comments are ignored in this topic: https://portableapps.com/node/32157, I decided to create a separate one.

On Windows 7 SP1 it's not required to install VC runtime, because it's already there. LO launches successfully if I refuse to install VC runtime. This dialog appears every time I launch LO apps and is very annoying. Please fix this long standing issue finally. Thank you.

John T. Haller
John T. Haller's picture
Online
Last seen: 55 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
It shouldn't

It's coded to only ask if you run on Windows XP or earlier and then only if it can't find it using 5 different methods of location. Additionally, it's coded so that if you say No, it won't ask you again no matter what to account for the few people on XP that have an oddball VC++ runtime installed.

It seems the build process may have included the previous launcher version, though. Please try downloading this proper version of LibreOfficePortable.exe and replacing your existing one to confirm.

Sometimes, the impossible can become possible, if you're awesome!

shadowlmd
Offline
Last seen: 1 year 3 months ago
Joined: 2012-02-18 11:42
Thank you. This one works

Thank you. This one works perfect for me.

Wolfgang Klein
Offline
Last seen: 10 years 2 months ago
Joined: 2011-06-28 11:24
Sorry, but it doesn't work for me!
John T. Haller
John T. Haller's picture
Online
Last seen: 55 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Fixed in 3.6.1.1

This issue is properly fixed in LibreOffice Portable 3.6.1.1. Vista/7/8 users should no longer be prompted even if it can't find it in the standard location.

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments