You are here

Gramps 3.4.7 error

8 posts / 0 new
Last post
paulhutch
Offline
Last seen: 6 years 2 months ago
Joined: 2014-02-04 16:29
Gramps 3.4.7 error

Hello,

My update today caused Gramps to fail to start, looking at the error trace I saw that a new required python source file was missing _HasSourceNoteRegexp.py.

I downloaded the source code, found the file and copied it to \PortableApps\GrampsPortable\App\Gramps\Filters\Rules\Citation.

Gramps starts normally again.

Bart.S
Offline
Last seen: 1 month 1 week ago
Developer
Joined: 2008-07-23 07:56
...

The Gramps Portable 3.4.7 installer includes this file.

Ken Herbert
Ken Herbert's picture
Offline
Last seen: 21 hours 24 min ago
DeveloperModerator
Joined: 2010-05-25 18:19
Maybe an AV false positive

Maybe an AV false positive blocked it during the install.

Bart.S
Offline
Last seen: 1 month 1 week ago
Developer
Joined: 2008-07-23 07:56
Hmm,

blocking a text file? Pardon

Ken Herbert
Ken Herbert's picture
Offline
Last seen: 21 hours 24 min ago
DeveloperModerator
Joined: 2010-05-25 18:19
Yeah, does sound a little

Yeah, does sound a little far-fetched, even for me....

John T. Haller
John T. Haller's picture
Offline
Last seen: 21 hours 20 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Working

I've confirmed that the file is in the installer and properly installed and that it is clean according to VirusTotal. It is a Python file, so it could be detected as a virus by some antivirus programs.

Sometimes, the impossible can become possible, if you're awesome!

fortiter
Offline
Last seen: 10 years 5 months ago
Joined: 2014-02-04 08:28
Update to 3.4.7 is broken

I have experienced exactly the same issue (on Win 7) that the application displays the splash and then stops with no trace of Services left running.

"Missing" file identified by the OP is certainly present on my install.

Bart.S
Offline
Last seen: 1 month 1 week ago
Developer
Joined: 2008-07-23 07:56
.

Did you try a fresh install?
What's your installation path?
Do you get an error message?
What's your AV?
Can you run 'GrampsPortable\App\Python27\python.exe' ?

Log in or register to post comments