You are here

[Fixed] Solfege Portable errors on first run - unreproducible

4 posts / 0 new
Last post
Gord Caswell
Gord Caswell's picture
Offline
Last seen: 10 hours 9 min ago
DeveloperModerator
Joined: 2008-07-24 18:46
[Fixed] Solfege Portable errors on first run - unreproducible

I received the error messagebox below upon my first attempt at running Solfege Portable.

I have not been able to duplicate this, whether I use a clean VM and fresh copy of the installer or not.

http://i.imgur.com/TA4kzUM.jpg

System details: Win7 x64, standard PA.c install location on P: external drive.

Note that the path shown does not exist on my system, nor has it ever.

I have also attempted installation to my local C: drive, as well as to a clean Win7 x86 VM's desktop folder.

Running a "find in files" on Solfege Portable using Notepad++ Portable, I find similar strings throughout many of the base app's files.

Was this app recompiled/rebuilt for PA.c?

John T. Haller
John T. Haller's picture
Online
Last seen: 49 min 32 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
pyc

It would get that from a compiled py file, a pyc. Each pyc keeps a record of where it was compiled location-wise. That was where I had first run the app on my system, so several pyc files likely have that string in it. That path no longer exists for me either.

Not sure why you would have gotten that error on startup. We pass in the --no-splash option, but no other options are fed. No one else has reported anything, so it could be a onetime base app issue. It is odd you can't reproduce it. What OS was the very first error on... your Win7 x64 machine? Have you tried a fresh run in a clean VM of Win7 x64?

I can't reproduce this on a fresh run on Windows 7 x64 in a clean VM. Or on XP, Vista, or Win8.

Sometimes, the impossible can become possible, if you're awesome!

3D1T0R
3D1T0R's picture
Offline
Last seen: 1 year 4 months ago
Developer
Joined: 2006-12-29 23:48
I've seen it twice, but can't figure out what's causing it.

I've seen this exact error message twice now, but haven't been able to track down what's causing it. Both times I had been digging through the settings, then closed Solfege and tried to open it again only to be greeted by this error, also both times pythonwSolfegePortable.exe has continued to run in the background after pressing Close which prevents relaunching the Portable App.

As with Gord Caswell I have not been able to get it to purposefully cause it to happen by doing the same things I had done or by doing other similar things (both times I had been trying to debug a different issue see /node/42411) I'm not sure what to think of it. Oh and for the record this is on Windows 7 Home Premium x64 SP1.


P.S.:
Also on another note the paths to Notepad++Portable.exe & VLCPortable.exe are defaulting to C:\AppNamePortable\AppNamePortable.exe while they (Solfege included) are installed to C:\PortableApps\AppNamePortable\AppNamePortable.exe
My guess is that this may be due to the fact that I'm NOT launching Solfege Portable via the Platform (I'm running SolfegePortable.exe from Windows Explorer)

~3D1T0R

John T. Haller
John T. Haller's picture
Online
Last seen: 49 min 32 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Should be fixed

This should be fixed in 3.22.2 Rev 2 if it is unique to our implementation. I believe it was due to UPX compression. If it is not fixed, it likely occurs in the base app as well, in which case it is not our bug.

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments