You are here

I can not install Firefox Dev edition.

2 posts / 0 new
Last post
mk2
Offline
Last seen: 8 years 2 months ago
Joined: 2015-08-24 00:36
I can not install Firefox Dev edition.

This is the error I got: https://i.imgur.com/y5WvvjL.png

Could anyone please fix it?

John T. Haller
John T. Haller's picture
Online
Last seen: 6 min 35 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
New Version

This happens whenever a new version is released. Just post a note in the Outdated Apps thread and it'll be sorted.
https://portableapps.com/development/outdated

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments