You are here

[Fixed] SWI-Prolog: outdated license and supported windows versions

3 posts / 0 new
Last post
janw
Offline
Last seen: 1 year 2 months ago
Joined: 2017-05-13 10:15
[Fixed] SWI-Prolog: outdated license and supported windows versions

On https://portableapps.com/apps/development/swi-prolog_portable, it is stated:

System Requirements: Windows XP/Vista/7/8/10
License: Free / Open Source (SWI-Prolog: GPL/LGPL, Launcher: GPL)

Since some versions, the oldest Windows release supported is AFAIK, Windows 7. Since 7.4.x, the license was changed to BSD 2-clause. You can checkout http://www.swi-prolog.org to verify these claims.

Gord Caswell
Gord Caswell's picture
Offline
Last seen: 12 hours 59 min ago
DeveloperModerator
Joined: 2008-07-24 18:46
Confirmed, page updated

I've confirmed both of those.

The application page has been updated, although the application itself has not yet been updated to require Windows 7 or higher - this will be fixed in an upcoming release.

John T. Haller
John T. Haller's picture
Offline
Last seen: 6 hours 45 min ago
AdminDeveloperModerator
Joined: 2005-11-28 22:21
Marked Fixed

As the page has been updated, we're good closing this as a 'bug' though it's more of a documentation change. We'll have SWI check for Win7 on next release. A launcher not checking isn't really a bug, though, as it's not a requirement. More of a convenience.

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments