You are here

Process Explorer 17.0 will not install

2 posts / 0 new
Last post
mrw2day
Offline
Last seen: 4 weeks 1 day ago
Joined: 2013-12-23 07:30
Process Explorer 17.0 will not install

I had the previous Process Explorer 16.x.x installed but I have tried upgrade to 17.0 and at the end of the installation I get a warning that the download is not valid. I download the PE 17.0 paf.exe directly and get same results. I uninstalled my 16.x.x version and attempt fresh install of PE 17.0 and get same result. I tried reinstalling version 16.x.x and get the same message.

I copied version 16.x.x from a backup into the portableapps folder and it opens fine.

I am running windows 10 64bit and it is up to date.

P.S. I downloaded the zip file directly for process explorer. It appears to be ver 17.0.1.0 vs 17.0
could this be the problem?

John T. Haller
John T. Haller's picture
Online
Last seen: 56 min 31 sec ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
New Version

There was a new release from the publisher. So we needed to update our online installer. It was posted a few minutes ago. In the future, you can report this in the Outdated Apps thread linked from the Support and Development sections of the site as well as a callout at the top of the page when creating a new forum topic.

Sometimes, the impossible can become possible, if you're awesome!

Log in or register to post comments