You are here

Help - PTB not playing custom sound file when folder moved

4 posts / 0 new
Last post
Anonymous (not verified)
Help - PTB not playing custom sound file when folder moved

Hi

May I make a feature request of Portable Thunderbird?

I am using v1.5 RC1 and would like to have my own custom wav file to announce the arrival of a new message. The problem I am finding is that when the Portable Thunderbird folder is moved, the wav file does not play. I expect that it is looking for an absolute path rather a relative path. Is it possible to use a relative path for this file or, if not, some how point to the folder in which Thunderbird is being run where the wav file can be put?

This is set up under the Tools>Options>General>When new message arrives>Advanced>Custom .wav file.

Many thanks - Great product by the way! (Can't wait until v1.5 Final is out)

John T. Haller
John T. Haller's picture
Offline
Last seen: 2 hours 8 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
Try resource

Try placing the wav in the same directory as thunderbird.exe and set the path to resource://custom.wav (may be 3 slashes). Post back if it works or not.

Sometimes, the impossible can become possible, if you're awesome!

kirkzeus (not verified)
Hi John Thanks for the

Hi John

Thanks for the reply.

Unfortunately what you have suggested doesn't work, either with 2 or 3 slashes.

It doesn't accept 'resource://custom.wav' when I enter it into the 'custom .wav' Browse button's 'Open' field.

I then tried going to Tools>Options>Advanced>General>Config Editor and replaced the entry for mail.biff.play_sound.url to 'resource://custom.wav' but that doesn't play my wav file.

Any other ideas that I can try?

Many thanks

John T. Haller
John T. Haller's picture
Offline
Last seen: 2 hours 8 min ago
AdminDeveloperModeratorTranslator
Joined: 2005-11-28 22:21
It won't work then

TB hard codes the path, so it changes every time.

Sometimes, the impossible can become possible, if you're awesome!

Topic locked